KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Auto Volume Adjust Issues with Audio Technica Pro 8HEMW / Andrea PureAudio USB_MA
Topic Summary:
Created On: 06/22/2021 01:19 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 06/22/2021 01:19 PM
User is offline View Users Profile Print this message

Author Icon
twobitrye
New Member

Posts: 8
Joined: 12/29/2018

Hi folks. Any suggestions on how to stop Windows from auto adjusting volume? I just purchased and started using the Audio Technica Pro 8HEMW / Andrea PureAudio USB_MA combo. DPI 15.3 on Windows 10 boot camp on a 2017 MacBook Pro. 

 

On a fresh restart, I open up sound preferences, select properties for this mic, and set the level to 90. But as soon as I start Dragon, it drops to 70 and adjusts up and down as it sees fit. Also happens if I turn off Dragon and launch a video conference. It's driving me crazy!

 

I already tried all the suggestions on this page. Any help is appreciated.



 06/22/2021 03:21 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39241
Joined: 10/01/2006

Dragon is the culprit; not Windows. You really don't want Windows adjusting your microphone input levels because Dragon has to handle this chore to make it work well with dictation. Unfortunately, this is your problem. You could automate this task with a macro. This is 1 of Dragon's most powerful non-dictation features. If you're not using KnowBrainer 2017 feel free to copy the following command into Dragon as an Advanced-Scripting command. Our command name is Volume Level <1to100> but note that you will also have to add a 1 to 100 list into Dragon. Other options include using 2 dedicated sound systems adjusting the volume level from within your video app or just using KnowBrainer

Sub Main
AppBringUp "C:\Windows\System32\SndVol.exe"
Wait 1
SendKeys "{End}"
Wait 1
SendKeys"{Up "+ListVar1+"}"
Wait 1
SendKeys "{Esc}"
End Sub


-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1



 06/22/2021 05:17 PM
User is offline View Users Profile Print this message

Author Icon
twobitrye
New Member

Posts: 8
Joined: 12/29/2018

Thank you for the reply! I just loaded up KnowBrainer to test it out. The command "Volume Level 90" raises the speaker volume, but is there a command to set and lock the mic input level?

 06/22/2021 07:41 PM
User is offline View Users Profile Print this message

Author Icon
ax
Top-Tier Member

Posts: 302
Joined: 03/22/2012

Originally posted by: twobitrye

..., but is there a command to set and lock the mic input level?

 

 

2 ways I know of:

 

 

1. https://www.tenforums.com/tutorials/77458-rundll32-commands-list-windows-10-a.html

 

Use Dragon to run:

 

"Rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,1"

 

Above takes you straight to the classic Sound --> Recording tab.  From there use Dragon/KB to navigate up and down to select the microphone you want to control (in our evil days of the Corona and remote up-the-yin-yang most folks have several mics attached to their rig, as I do).  Use Dragon to double-click the Mic of your choice.  Click/Select "Levels".  Then use Dragon/KB to drive the left or right arrow to move the gain slider.  Not being a KB user, I am nevertheless 100% certain KB can automate that for you in style.  

 

 

2. Download AutoHotKey.  Run Soundcard Analysis script once (or every time you add/remove a mic), to find out the device number of the sound device you want to control.

 

Let's say the device number corresponding to the mic of your interest is 6, which you can easily find out by manually setting the mic gain to any odd number (say 39) and run the Soudcard Analysis script above to see which device number has "39" beside it.   

 

Then it is easy as pie (and if you find anything peasier let me know): 

 

SoundSet,100,,,6

 

You can bind above to a hotkey or call it with ShellExecutethisandthat from Dragon, which has been liberally mentioned umpteen times a day around here.

 

To "lock" the gain in place, you can run "SoundGet" every so often against the device number.  If it is not 100, set it to 100.

 

 

P.S., there must be 25 other ways to approach this on Windows, from PowerShell, VBS, etc. etc.  But simpler than AHK without installing something proprietary?  Likely bar none.

 

Non-pro tip from me: so long as you are tethered to this sorry platform called Windows: your choice of mitigation depends on where you wish to go:

 

Go sexy, go Python.

 

Go pro, go .NET (C#, VB, etc.)

 

Go home (as in wanting to accomplish what you need to get done and head home), get a shot of AutoHotKey.



 06/22/2021 05:30 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39241
Joined: 10/01/2006

We haven't run into this problem in Microsoft Teams but we are not certain how to lock the microphone input level. We simply haven't had to.

-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1

Statistics
32127 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 302 guests browsing this forum, which makes a total of 304 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.