KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Disabling Dragon gathering vocabulary on application switches
Topic Summary:
Created On: 09/14/2021 02:00 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 Disabling Dragon gathering vocabulary on application switches   - zmcgohan - 09/14/2021 02:00 PM  
 Disabling Dragon gathering vocabulary on application switches   - Lunis Orcutt - 09/14/2021 06:14 PM  
 Disabling Dragon gathering vocabulary on application switches   - zmcgohan - 09/14/2021 06:55 PM  
 Disabling Dragon gathering vocabulary on application switches   - Lunis Orcutt - 09/15/2021 11:38 AM  
 Disabling Dragon gathering vocabulary on application switches   - Ag - 09/15/2021 09:53 PM  
 Disabling Dragon gathering vocabulary on application switches   - Ag - 09/15/2021 10:06 PM  
 Disabling Dragon gathering vocabulary on application switches   - Ag - 09/15/2021 10:15 PM  
 Disabling Dragon gathering vocabulary on application switches   - Ag - 09/15/2021 10:24 PM  
 Disabling Dragon gathering vocabulary on application switches   - johnargu - 09/17/2021 04:44 PM  
 Disabling Dragon gathering vocabulary on application switches   - R. Wilke - 09/18/2021 11:22 AM  
 Disabling Dragon gathering vocabulary on application switches   - johnargu - 09/24/2021 02:14 PM  
 Disabling Dragon gathering vocabulary on application switches   - R. Wilke - 09/24/2021 02:54 PM  
 Disabling Dragon gathering vocabulary on application switches   - johnargu - 09/25/2021 05:13 PM  
 Disabling Dragon gathering vocabulary on application switches   - Lunis Orcutt - 09/18/2021 09:53 PM  
 Disabling Dragon gathering vocabulary on application switches   - kkkwj - 09/18/2021 05:09 AM  
 Disabling Dragon gathering vocabulary on application switches   - Ag - 09/20/2021 03:12 PM  
Keyword
 09/14/2021 02:00 PM
User is offline View Users Profile Print this message

Author Icon
zmcgohan
Junior Member

Posts: 32
Joined: 08/02/2019

Most of my Dragon lockups appear to occur whenever I switch between tabs or applications with a bunch of text, or when I paste in a large amount of text for editing. It seems dependent on size/complexity (and some amount of randomness) for how long Dragon takes to ingest the vocabulary, but it is frequently longer than the value add of the temporary vocabulary.

Is there any way to turn off this feature to ensure more consistent speed and less lockups?

 09/14/2021 06:14 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39368
Joined: 10/01/2006

If you are experiencing this issue with your browser, you can disable HTML but of course that will limit your functionality. You shouldn't run into a problem switching between applications. However, our solution is to throw 64 Gb of RAM at the problem. We have been using 64 Gb of RAM for the last 8 years and 32 Gb of RAM before that. It might sound like overkill but wait until you open a 300 page Microsoft Word document and attempt to dictate within the 1st 10 seconds. 8 Gb of RAM now seems barely acceptable. However, in all fairness, we are using 23 Gb of RAM as we dictate this answer.



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1



 09/14/2021 06:55 PM
User is offline View Users Profile Print this message

Author Icon
zmcgohan
Junior Member

Posts: 32
Joined: 08/02/2019

I do have 64 GB of RAM already, of which only 11 GB at the time of writing is being used. Processor usage is also negligible. This problem has appeared similarly under both max spec Intel and AMD-based builds.



 09/15/2021 11:38 AM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39368
Joined: 10/01/2006

Would you mind creating a new user profile for test purposes? If it works, you have identified the problem and can import your previous vocabulary & commands. If you import your previous vocabulary, make certain to do so as an XML or Plain Text file. Do not go through the Manage Vocabularies menu because that is the most likely common culprit for user profile corruption. If this doesn't work, we will make up another answer



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1



 09/15/2021 09:53 PM
User is offline View Users Profile Print this message

Author Icon
Ag
Top-Tier Member

Posts: 647
Joined: 07/08/2019

Originally posted by: zmcgohan Most of my Dragon lockups appear to occur whenever I switch between tabs or applications with a bunch of text, or when I paste in a large amount of text for editing. It seems dependent on size/complexity (and some amount of randomness) for how long Dragon takes to ingest the vocabulary, but it is frequently longer than the value add of the temporary vocabulary. Is there any way to turn off this feature to ensure more consistent speed and less lockups?


Amen brother! I am so glad to hear that I am not the only person who has encountered such problems. I was so frustrated with Dragon until I figured this out. I have disabled As much of this stuff as I have been able to find:

The two biggies seem to be

DragonBar > Options

... > Commands > [ ] Enable HTML support
^^ Which I have disabled, or rather not enabled

... > Miscellaneous > [ ] Voice-enable menus, buttons, and other controls, excluding
^^ which I have again not enabled


---+ more details

Basically, I went and disabled everything that sounded like it might possibly affect performance. And then only added back if I found that Dragon functionality was dramatically reduced.


From DragonBar > Options

... > Commands

[ ] ** Enable HTML support <-- i.e. I have disabled HTML support
[ ] Enable desktop search commands <-- i.e. I have disabled desktop search commands, since I sometimes dump a lot of stuff on my desktop and searching it can slow things down
[ ] Enable launching from the Start menu
[ ] Enable launching from the desktop

In the "More commands" dialogue I have everything disabled
[ ] Enable Natural Language Commands ... disabled for Microsoft Word/Excel/PowerPoint/Corel WordPerfect
[ ] Enable Twitter post commands


... > Miscellaneous
[ ] Use menus that are compatible with screen readers
[ ] ** Voice-enable menus, buttons, and other controls, excluding
^^ at the moment I disable all of these menus buttons and other controls, i.e. I have no excluding list, but I am considering re-enabling it and then adding applications as I encounter problems

---

Disabling HTML support had the biggest effect.

I was not at all sure that the stuff on the ...> Miscellaneous option tab/pane mattered, but a quick Google found me the following on the Nuance Dragon FAQ:

https://www.nuance.com/products/help/dragon15/dragon-for-pc/enx/dpg-cp/Content/CommandandControl/menus_buttons_other_controls.htm

Turning off voice-enabling for menus, buttons, and other controls

Dragon allows users to navigate menus, click buttons, or work with other screen elements by voice. If you don't use this feature, you can disable it to help improve Dragon's speed.


---

Dragon's documentation says that the HTML support applies only to Internet Explorer and Chrome. But I think it is highly likely that it also applies to Microsoft Edge and quite possibly Mozilla Firefox.

I am not 100% sure, but I think that the HTML Dragon setting seems to apply to Thunderbird, the email program that used to come from Mozilla. like Firefox, much of Thunderbirds user interface is based on HTML. And I think that Dragon may well be parsing lots of links in the user interface as you move from one email to another. In fact, I have a sneaking suspicion that it is parsing all of the HTML in a Thunderbird folder listing (which in my case may have several thousand messages), not just those that are visible.

I wish that there was selectivity, that I could enable or white list HTML parsing only for certain applications and windows and webpages within the HTML-based applications.

It would be nice, it might be possible, that the "voice-enabled menus buttons and other controls excluding" list might interact with the HTML support. It would be nice if you could voice-enabled menus etc. and enable HTML, but where adding Thunderbird to the excluding list might excluded from the HTML support.



-------------------------

DPG15.6 (also DPI 15.3) + KB, Sennheiser MB Pro 1 UC ML, BTD 800 dongle, Windows 10 Pro, MS Surface Book 3, Intel Core i7-1065G7 CPU @ 1.3/1.5GHz (4 cores, 8 logical, GPU=NVIDIA Quadro RTX 3000 with Max-Q Design.



 09/15/2021 10:06 PM
User is offline View Users Profile Print this message

Author Icon
Ag
Top-Tier Member

Posts: 647
Joined: 07/08/2019

BTW, my old machine had 64 GB of RAM, and I was very unhappy. My current machine has "only" 32 GB of RAM, and I am reasonably happy, having disabled all of the stuff above.

I am fairly sure that my usage pattern greatly influences this: I am constantly flipping between several webpages in different browser windows, three or four OneNote windows, emacs, multiple windows/frames within emacs including several shells, and my mail program. Three or four monitors, quite a few megapixels. am not 100% sure but I think the problem was less when I was using only one monitor at low resolution, although that might just be because I cannot work as fast is such a stripped-down configuration.

I finally twigged on this problem when I noticed that shortly after whenever I switch to Thunderbird I would get a stall. Not immediately, but a minute or so after I had switched to Thunderbird. Sometimes after I switched into Thunderbird and then switched back out quickly, which was causing me to think that the problem might be in some other app.

Thunderbird was by no means the only application that had this problem. But it was the application where I figured out at least this aspect of the performance problems.

I found it very useful to create AutoHotKey scripts that I could invoke by a non-Dragon hotkey or mouse click when Dragon was stalling. With timestamps, so that I could interleave my own "Dragon is slow or hung" observations with those in the standard Dragon log file. Which I then studied trying to figure out what might be happening within Dragon. There seemed to be error messages within the Dragon log that indicated issues loading/parsing new command sets. But the problem seem to occur even when there were no such errors. Ultimately it was my own observations, not log analysis, that led me to the same conclusion that you have arrived at: Dragon gets low when you flip between command sets.



-------------------------

DPG15.6 (also DPI 15.3) + KB, Sennheiser MB Pro 1 UC ML, BTD 800 dongle, Windows 10 Pro, MS Surface Book 3, Intel Core i7-1065G7 CPU @ 1.3/1.5GHz (4 cores, 8 logical, GPU=NVIDIA Quadro RTX 3000 with Max-Q Design.

 09/15/2021 10:15 PM
User is offline View Users Profile Print this message

Author Icon
Ag
Top-Tier Member

Posts: 647
Joined: 07/08/2019

Coincidentally, I ran into a second post from somebody who  learned that disabling HTML support helped performance:

Vocola 2: Disable "Enable HTML support"!



-------------------------

DPG15.6 (also DPI 15.3) + KB, Sennheiser MB Pro 1 UC ML, BTD 800 dongle, Windows 10 Pro, MS Surface Book 3, Intel Core i7-1065G7 CPU @ 1.3/1.5GHz (4 cores, 8 logical, GPU=NVIDIA Quadro RTX 3000 with Max-Q Design.

 09/15/2021 10:24 PM
User is offline View Users Profile Print this message

Author Icon
Ag
Top-Tier Member

Posts: 647
Joined: 07/08/2019

Possibly relevant:

 

I do not use Vocola as do some of the people reporting this problem.

 

At the time I was running into this problem  I was using mainly KnowBrainer commands.  and I believe Lunis  says that at one point in time KnowBrainer had gone overboard in providing too many commands.  but even after I updated to a supposedly more efficient KnowBrainer, I was still running into these problems on context switch.

 

At the moment I use neither Vocola nor Dragon nor KnowBrainer command scripting, except a little bit of Dragon command scripting to bootstrap my personal command scripting system.

 

I have gone from several hundred or more KnowBrainer commands to less than a page full  of commands in the Dragon Command Browser.   and there are almost no commands that are being swapped in or out on application switches.

 

In effect, rather than swapping vocabularies in and out on application switches, I have substantially the same vocabulary recognized by Dragon at all times.  at the time the command is invoked, it may add a check to see what application or window is running.  I suppose I trade off slightly increased latency at the time I actually invoke the command,  to get faster application switches.   Supposedly slightly increased: I haven't noticed any annoying slowdown.   

 

(Meta-comment: this is actually typical of a  long-term trend in computer performance. In the old days, if you switched to an application and were in it for a long time, it made a lot of sense to do a lot of pre-computation. Computers were slow, and pre-computation optimizing the data structures  helped performance if you use the data structures over and over again.   However, CPUs got fast faster than memory did,  and more and more it makes sense to recompute things and it does to look it up in a memory data structure.)

 



-------------------------

DPG15.6 (also DPI 15.3) + KB, Sennheiser MB Pro 1 UC ML, BTD 800 dongle, Windows 10 Pro, MS Surface Book 3, Intel Core i7-1065G7 CPU @ 1.3/1.5GHz (4 cores, 8 logical, GPU=NVIDIA Quadro RTX 3000 with Max-Q Design.



 09/17/2021 04:44 PM
User is offline View Users Profile Print this message

Author Icon
johnargu
New Member

Posts: 11
Joined: 09/05/2021

I'm experiencing a problem which might be related to the OP. Word and Dragon are locking up for almost a full minute as I dictate. This isn't related to my switching tabs, however. It just locks up. I believe it is related to a dialogue box which keeps popping up when I open Dragon warning me that Dragon has reached the maximum amount of speech data that can be saved. It tells me to go to the data option and increase the disk space reserved for playback but while I've doubled then tripled the amount of space it hasn't stopped the box from popping up or the freezes. This is hapening just about every ten minutes like clockwork.



 09/18/2021 11:22 AM
User is offline View Users Profile Print this message

Author Icon
R. Wilke
Top-Tier Member

Posts: 7703
Joined: 03/04/2007

Originally posted by: johnargu I'm experiencing a problem which might be related to the OP. Word and Dragon are locking up for almost a full minute as I dictate. This isn't related to my switching tabs, however. It just locks up. I believe it is related to a dialogue box which keeps popping up when I open Dragon warning me that Dragon has reached the maximum amount of speech data that can be saved. It tells me to go to the data option and increase the disk space reserved for playback but while I've doubled then tripled the amount of space it hasn't stopped the box from popping up or the freezes. This is hapening just about every ten minutes like clockwork.

 



I don't think that this particular situation is related to the OP. The message you are getting and which keeps interrupting your workflow typically only comes up when dictating in very long sessions, and in one particular document. So how long are you documents actually?

The default setting for "disk space reserved for playback" is typically good for about thirty minutes of dictation in a row. You can always double or triple the size, but setting it at ten times the default also won't hurt, if this is needed. Considering that consuming disk space today typically isn't an issue any longer anyway.

Another recommendation given around here is to set it to 0 and thus deactivate it altogether, but this is more of shooting from the hip and in the dark, and not knowing what's going on actually.



-------------------------



No need to buy if all you want to do is try ...

DragonCapture KB Download (Latest)
DragonCapture Homepage



 09/24/2021 02:14 PM
User is offline View Users Profile Print this message

Author Icon
johnargu
New Member

Posts: 11
Joined: 09/05/2021

Originally posted by: R. Wilke
Originally posted by: johnargu I'm experiencing a problem which might be related to the OP. Word and Dragon are locking up for almost a full minute as I dictate. This isn't related to my switching tabs, however. It just locks up. I believe it is related to a dialogue box which keeps popping up when I open Dragon warning me that Dragon has reached the maximum amount of speech data that can be saved. It tells me to go to the data option and increase the disk space reserved for playback but while I've doubled then tripled the amount of space it hasn't stopped the box from popping up or the freezes. This is hapening just about every ten minutes like clockwork.

 

 

 

I don't think that this particular situation is related to the OP. The message you are getting and which keeps interrupting your workflow typically only comes up when dictating in very long sessions, and in one particular document. So how long are you documents actually? The default setting for "disk space reserved for playback" is typically good for about thirty minutes of dictation in a row. You can always double or triple the size, but setting it at ten times the default also won't hurt, if this is needed. Considering that consuming disk space today typically isn't an issue any longer anyway. Another recommendation given around here is to set it to 0 and thus deactivate it altogether, but this is more of shooting from the hip and in the dark, and not knowing what's going on actually.

 

I'm a writer. My files are often 20k-30k-40k words, and I can dictate for hours. I've tried increasing the buffer but it doesn't seem to matter. Every ten minutes the computer freezes up for a minute or so. I've tried closing down Dragon every half hour and restarting it but it doesn't seem to help.

 09/24/2021 02:54 PM
User is offline View Users Profile Print this message

Author Icon
R. Wilke
Top-Tier Member

Posts: 7703
Joined: 03/04/2007

Originally posted by: johnargu
Originally posted by: R. Wilke
Originally posted by: johnargu I'm experiencing a problem which might be related to the OP. Word and Dragon are locking up for almost a full minute as I dictate. This isn't related to my switching tabs, however. It just locks up. I believe it is related to a dialogue box which keeps popping up when I open Dragon warning me that Dragon has reached the maximum amount of speech data that can be saved. It tells me to go to the data option and increase the disk space reserved for playback but while I've doubled then tripled the amount of space it hasn't stopped the box from popping up or the freezes. This is hapening just about every ten minutes like clockwork.

 

 

 

   

 

I don't think that this particular situation is related to the OP. The message you are getting and which keeps interrupting your workflow typically only comes up when dictating in very long sessions, and in one particular document. So how long are you documents actually? The default setting for "disk space reserved for playback" is typically good for about thirty minutes of dictation in a row. You can always double or triple the size, but setting it at ten times the default also won't hurt, if this is needed. Considering that consuming disk space today typically isn't an issue any longer anyway. Another recommendation given around here is to set it to 0 and thus deactivate it altogether, but this is more of shooting from the hip and in the dark, and not knowing what's going on actually.

 

 

 

 

I'm a writer. My files are often 20k-30k-40k words, and I can dictate for hours. I've tried increasing the buffer but it doesn't seem to matter. Every ten minutes the computer freezes up for a minute or so. I've tried closing down Dragon every half hour and restarting it but it doesn't seem to help.

 



In this particular situation, I would actually recommend setting the buffer to 0 MB, because, most likely, you wouldn't want to go back correcting your dictation a few hours ago. Correcting your dictation and thus incorporating the corrections into the user profile is all the reason why the buffer has been provided by the manufacturer.

Probably a little difficult to understand, and there you go, but your mileage may always vary.



-------------------------



No need to buy if all you want to do is try ...

DragonCapture KB Download (Latest)
DragonCapture Homepage



 09/25/2021 05:13 PM
User is offline View Users Profile Print this message

Author Icon
johnargu
New Member

Posts: 11
Joined: 09/05/2021

That seems to have done the trick. Thanks very much! That was becoming very annoying.

 09/18/2021 09:53 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39368
Joined: 10/01/2006

Rüdiger nailed it.  The default setting for Disk space reserved for playback, in the Dragon Option/Data tab, is 100 Mb. Our KnowBrainer Dragon Installation/Training Guide recommends changing the setting from 100 to 200 Mb if your computer has 8 Gb of RAM.  We recommend 500 Mb for radiologists and pathologists. However, we recommend changing the default setting to 0 if you have 16 Gb or more of RAM because you don't need the wear and tear of virtual RAM (hard drive space).


We suspect Nuance went with 100 Mb As a safe default for everyone but we additionally suspect that the testers weren't very good it using speech recognition. When you only dictate 5 or 6 words at a time, you won't overrun the 100 Mb buffer. If you are overwriting the 100 Mb buffer and receiving this error, you're dictating right and need to either double or zero out the buffer. Of course this is only our opinion



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1

 09/18/2021 05:09 AM
User is offline View Users Profile Print this message

Author Icon
kkkwj
Top-Tier Member

Posts: 831
Joined: 11/05/2015

@Ag: This idea of yours is quite clever and seems very useful. "With timestamps, so that I could interleave my own "Dragon is slow or hung" observations with those in the standard Dragon log file." That's a great way to create a record of what's happening in the moment.

-------------------------

Win10/x64, AMD Ryzen 7 3700X, 64GB RAM, Dragon 15.3, SP 6 PRO, SpeechStart, Office 365, KB 2017, Dragon Capture, Samson Meteor USB Desk Mic, Klim and JUKSTG earbuds with microphones, 3 BenQ 2560x1440 monitors, Microsoft Sculpt Keyboard and fat mouse

 09/20/2021 03:12 PM
User is offline View Users Profile Print this message

Author Icon
Ag
Top-Tier Member

Posts: 647
Joined: 07/08/2019

Originally posted by: kkkwj @Ag: This idea of yours is quite clever and seems very useful. "With timestamps, so that I could interleave my own "Dragon is slow or hung" observations with those in the standard Dragon log file." That's a great way to create a record of what's happening in the moment.

Methinks I should package these up and post them on my speech GitHub.



-------------------------

DPG15.6 (also DPI 15.3) + KB, Sennheiser MB Pro 1 UC ML, BTD 800 dongle, Windows 10 Pro, MS Surface Book 3, Intel Core i7-1065G7 CPU @ 1.3/1.5GHz (4 cores, 8 logical, GPU=NVIDIA Quadro RTX 3000 with Max-Q Design.

Statistics
32177 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 0 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 316 guests browsing this forum, which makes a total of 316 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.