KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Commas in thousands
Topic Summary:
Created On: 04/28/2021 03:12 AM
Status: Post and Reply
Linear : Threading : Single : Branch
 Commas in thousands   - adrienneiii - 04/28/2021 03:12 AM  
 Commas in thousands   - PG LTU - 04/28/2021 01:18 PM  
 Commas in thousands   - Alan Cantor - 04/28/2021 01:51 PM  
 Commas in thousands   - adrienneiii - 04/29/2021 08:34 AM  
Keyword
 04/28/2021 03:12 AM
User is offline View Users Profile Print this message

Author Icon
adrienneiii
New Member

Posts: 14
Joined: 06/30/2015

Hello there, I work with documents that often contain a lot of values in the thousands and millions. When I dictate numbers in the millions, the commas are automatically inserted. This is not the case for thousands, however, which are much more frequent in the documents: 

2,960,840

2960

It is a total pain to have to go through and insert the commas every single time. I wonder if anyone knows of a solution for this?

Much appreciated!

 04/28/2021 01:18 PM
User is offline View Users Profile Print this message

Author Icon
PG LTU
Top-Tier Member

Posts: 2181
Joined: 03/21/2007

Did you check here:
https://www.knowbrainer.com/forums/forum/messageview.cfm?catid=4&threadid=21719

Hth,



-------------------------




PG





Remember folks, my comments and this forum are for entertainment value only, please, no wagering or other reliance on the contents herein.  I permit no commercial use of my ideas (whether expressions or embodiments) without my written consent.



 04/28/2021 01:51 PM
User is offline View Users Profile Print this message


Alan Cantor
Top-Tier Member

Posts: 4185
Joined: 12/08/2007

Check the "Regional" settings in the Control Panel to see how Windows is configured to display numbers. On my computer, it's set to display thousands with the comma, but it only seems to work for numbers greater than 10,000.

So there may not be much that you can do to force Dragon to insert a comma in numbers less than 10,000.

However, there may be workarounds.

1. If you're okay to dictate into Excel worksheets, you can set the cell formatting so that the comma is always inserted.

2. If you're dictating into a Dragon-friendly applications like Microsoft Word or Outlook, it may be possible to create a custom command to repair numbers after you've dictated them.

This (untested) Dragon command for Microsoft Word is supposed to add the comma to every four-digit number in the document:

Sub Main
With Selection.Find
.Text = "<([1-9])([0-9])([0-9])([0-9])>"
.Replacement.Text = "\1,\2\3\4"
.Forward = True
.Wrap = wdFindContinue
.Execute Replace:=wdReplaceAll
End With
End Sub

You'll need to set a "Reference" to make this command work. Click in the body of the command, press Alt + Enter, and then choose "Microsoft Word XX.0 Object Library (X.X)" from the list.

(The values of X depend on which version of Word you're using.)
 04/29/2021 08:34 AM
User is offline View Users Profile Print this message

Author Icon
adrienneiii
New Member

Posts: 14
Joined: 06/30/2015

Thank you both very much for your help! Alan, I primarily use a specialized translation software so the Microsoft options didn't work for me. But I never could have imagined the solution would be so simple: from the thread you posted, PG, simply setting an alternative comma context option to have no spaces between numbers, formatting the numbers before and after as numerals, and splitting the number into e.g. "seven comma three hundred and twenty nine point six". Works like a dream, massive time-saver. Thank you again!
KnowBrainer Speech Recognition » Dragon Speech Recognition » Commas in thousands

Statistics
32177 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 430 guests browsing this forum, which makes a total of 432 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.