KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: When notepad is started it does not have focus
Topic Summary:
Created On: 01/17/2015 06:13 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 When notepad is started it does not have focus   - danw700 - 01/17/2015 06:13 PM  
 When notepad is started it does not have focus   - Alan Cantor - 01/17/2015 08:36 PM  
 When notepad is started it does not have focus   - kc4cop - 01/17/2015 11:08 PM  
 When notepad is started it does not have focus   - danw700 - 01/18/2015 01:22 AM  
 When notepad is started it does not have focus   - danw700 - 01/18/2015 01:28 AM  
 When notepad is started it does not have focus   - kc4cop - 01/18/2015 05:45 AM  
 When notepad is started it does not have focus   - danw700 - 01/18/2015 06:22 AM  
 When notepad is started it does not have focus   - Lunis Orcutt - 01/18/2015 01:52 PM  
 When notepad is started it does not have focus   - Lunis Orcutt - 01/19/2015 05:29 PM  
 When notepad is started it does not have focus   - monkey8 - 01/18/2015 03:08 PM  
 When notepad is started it does not have focus   - Tiger Feet - 01/18/2015 09:38 AM  
 When notepad is started it does not have focus   - monkey8 - 01/18/2015 03:12 PM  
 When notepad is started it does not have focus   - danw700 - 01/18/2015 07:01 PM  
 When notepad is started it does not have focus   - Scribe - 01/19/2015 03:10 PM  
 When notepad is started it does not have focus   - Chucker - 01/19/2015 03:36 PM  
 When notepad is started it does not have focus   - kc4cop - 01/19/2015 04:56 PM  
 When notepad is started it does not have focus   - monkey8 - 01/19/2015 05:18 PM  
 When notepad is started it does not have focus   - Tiger Feet - 01/20/2015 01:28 PM  
 When notepad is started it does not have focus   - Chucker - 01/20/2015 02:01 PM  
 When notepad is started it does not have focus   - Tiger Feet - 01/20/2015 03:42 PM  
 When notepad is started it does not have focus   - danw700 - 01/20/2015 06:58 PM  
 When notepad is started it does not have focus   - kc4cop - 01/21/2015 06:00 PM  
 When notepad is started it does not have focus   - kc4cop - 01/21/2015 06:14 PM  
 When notepad is started it does not have focus   - Lunis Orcutt - 01/21/2015 06:35 PM  
 When notepad is started it does not have focus   - Chucker - 01/20/2015 07:32 PM  
 When notepad is started it does not have focus   - danw700 - 01/20/2015 09:28 PM  
 When notepad is started it does not have focus   - Scribe - 01/28/2015 07:36 PM  
Keyword
 01/17/2015 06:13 PM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

When I use the voice command to start notepad "start notepad" the notepad window opens but does not have focus so that my next stream of dictation does not appear in this notepad window or anywhere else for that matter.

I have to click on the notepad window in order to be able to dictate into it.

Is there a simple way to overcome this?

For instance I started this new topic on the KnowBrainer forum – I dictated the message title directly into the field – I move the cursor into a body of the Message Text – I Then Used the Voice Command Start Notepad Which Opens up Notepad on the Same Window. As I start to dictate there is no text input – the border of the notepad window is not highlighted and in order to be able to dictate into notepad I have to click the window to bring it into focus. I don't think that this is normal behaviour.

Cheers for now
Dan



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/17/2015 08:36 PM
User is offline View Users Profile Print this message


Alan Cantor
Top-Tier Member

Posts: 4176
Joined: 12/08/2007

Focus problems are regrettably too common in Windows. It may be a temporary glitch that resolves after a cold reboot; or there could be something about configuration that is causing something to steal focus from Notepad. It's hard to track down causes. On my PC, I had the same problem with Outlook, and I never figured out why Outlook was not getting focus. But it only happened on one computer.

Workarounds are varied. First, try rebooting the computer.

If that doesn't work the simplest solution may be to say "switch to Notepad" after Notepad opens.

You might also try adding a shortcut to Notepad on your desktop, renaming it something like "Note Something," and then launching Notepad by voice by saying "open Note Something." If that works, rename the shortcut to Notepad, and test again.

Or try changing the properties of the shortcut. Try running it maximized.

If you use Macro Express, create a macro activated when window title " - Notepad" opens. A single line of code should bring Notepad into the foreground:

Window Activate: - Notepad
 01/17/2015 11:08 PM
User is offline View Users Profile Print this message

Author Icon
kc4cop
Top-Tier Member

Posts: 312
Joined: 10/05/2007

Dan:

 

I’m having the same problem with "Microsoft Word" (in the situation) when the "KnowBrainer 14 Sidebar" will not allow "Word" to open in a maximized window. Killing the "KnowBrainer 14 Sidebar" by clicking on the “X” in the upper right-hand corner of the "Sidebar" application at this point does not allow "Microsoft Word" to open/re-open with a maximized window or with Windows’ focus.

 

Do you have a similar scenario?

 

Dick Zseltvay

KC4COP



-------------------------

Dell Inspiron 3847 64-bit; CPU i7-4790, 3.6 Ghz, 16 GB; Win 7 Pro; Dragon 14 DPI; KnowBrainer 17; Speechware 3-in-1; IE 11



 01/18/2015 01:22 AM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Dick,

You can in the KnowBrainer options (right click the icon in the system tray and then options, you have a few boxes you can tick. If you tick the box Automatically Adjust Active Window than the KnowBrainer sidebar will be there and the Microsoft Word window will come up to the edge of it. If you then hide the KnowBrainer sidebar the word window won't fill the screen by itself – you have to do double-click the window bar to maximise or use a voice command. Personally in the KnowBrainer Sidebar Options the only thing I have ticked is Show It Starter. I have the font set to a nice big size and in my case I have it showing on Monitor 2.

You could have the options set to always have the KnowBrainer sidebar on top but this gets in the way of a maximised window like word. Another cool option is to always have it on top but use the voice command"hide sidebar" and "show sidebar" to see it whenever you need to or want to. There is plenty of choice :-).

Cheers for now
Dan



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/18/2015 01:28 AM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Alan,

Thanks for the heads up for the moment I'm going to use the "switch to notepad" verbal voice command.

I was thinking about changing the code to actually name the Windows but that would be rather restrictive because sometimes it's  Windows Internet Explorer, Skype and various chat rooms plus some of my other editors. I can easily remember to say "switch to notepad"and then the "transfer" command swaps back to where the cursor was and does everything neatly except in Skype where I have to do switch focus to Skype and actually click send to send off the text.

Thanks for your swift and well thought out reply. There is a bit of a gremlin somewhere in my system because at the beginning of using KnowBrainer 2014 I did not automatically lose the focus on the notepad window but now it happens every time so it's one of those things that I'll have to look into :-). The ghost in the machine don't you love it :-).

Cheers for now
Dan



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/18/2015 05:45 AM
User is offline View Users Profile Print this message

Author Icon
kc4cop
Top-Tier Member

Posts: 312
Joined: 10/05/2007

Dan:

 

Ref: "open Microsoft Word"

   no full screen window

   lacks automatic focus when opened

I think/thought that I had done all that you mentioned. I find that unless I am able to completely close "KnowBrainer 14" (not just the "Sidebar") I can not maximize (FULLY expand window to full screen) the "Microsoft Word" window nor can I newly open "Microsoft Word" with "Word" automatically capturing Focus.

 

Clicking on "Microsoft Word 10" after it opens to give it focus is not too big a deal for me but it does keep me from being able to continually use voice command to give me smooth control of my task.

 

I don't recall if the above has always been the case. Note: I am presently using: "Microsoft Word 10" - "Home and Student Office" "Dragon Premium 12 and 12.5", "KnowBrainer 14" and "Windows Home Premium 7".

 

Dick Zseltvay

 

KC4COP



-------------------------

Dell Inspiron 3847 64-bit; CPU i7-4790, 3.6 Ghz, 16 GB; Win 7 Pro; Dragon 14 DPI; KnowBrainer 17; Speechware 3-in-1; IE 11



 01/18/2015 06:22 AM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Dick,

Always start KnowBrainer and DNS before you start word. Use the voice command hide sidebar then open word. If MS Word doesn't have the focus say switch to word or switch to MS Word this ought to switch the focus.

SpeechStart+ has some built-in commands that control the active window say "show SpeechStart+ commands" this should bring up the help menu. If you right click the speech start icon in the taskbar and run the slideshow it will show you how to use speech start you can use commands like display 2 maximise and this will fill out the window just familiarise yourself with the speech start commands. I think you have speech start date you?



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/18/2015 01:52 PM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39344
Joined: 10/01/2006

We believe there is a possible bug in the KnowBrainer 2014 where if you choose the Automatically Adjusts Active Window option, it may prevent using that screen real estate even when the KnowBrainer sidebar isn't running. On our computer, we can no longer uncheck this option. This will be fixed in the upcoming KnowBrainer 2015 release

 

 



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1

 01/19/2015 05:29 PM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39344
Joined: 10/01/2006

When you minimize or close the KnowBrainer sidebar you're not closing KnowBrainer. You will see KnowBrainer 2014 is still active as a miniaturized icon in your Windows taskbar. Say Close KnowBrainer to properly close KnowBrainer or right click on the KnowBrainer taskbar icon and select Exit.

You can disable the KnowBrainer Automatically Adjust Active Window via Lindsay's previous recommendation as follows:

1. Open C:\Users\WINDOWSUSERNAME\AppData\Local\KnowBrainer\KBPro.exe_Url_vnxpp\1.0.0.0\user.config file.

2. Go to the end of the file.

3. Change True to False in
False
to disable this feature. You will not have to go through this process when we release KnowBrainer 2015.



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1



 01/18/2015 03:08 PM
User is offline View Users Profile Print this message

Author Icon
monkey8
Top-Tier Member

Posts: 3824
Joined: 01/14/2008

Dick if you want to maximise Microsoft Word just minimise the sidebar, that is don't close it but just minimise it.  And then maximise Microsoft Word.

 

If you want the windows to stop being automatically adjusted to fit the sidebar and you have ticked the box to automatically adjust window in options and you can't get rid of the checkmark then go to the following location and change the value of Automatically Adjust Window to False as shown below.  Then restart KnowBrainer.  The folder name numbering below will be different but similar.  You can open the file with WordPad if you don't have anything else.

 

C:\Users\WINDOWSUSERNAME\AppData\Local\KnowBrainer\KBPro.exe_Url_vnxpp\1.0.0.0\user.config

 

<setting name="AutomaticallyAdjustWindows"serializeAs="String">
<
value>False<
value>

 

 

 



-------------------------



 01/18/2015 09:38 AM
User is offline View Users Profile Print this message

Author Icon
Tiger Feet
Top-Tier Member

Posts: 2180
Joined: 12/04/2009

Originally posted by: danw700 When I use the voice command to start notepad "start notepad" the notepad window opens but does not have focus so that my next stream of dictation does not appear in this notepad window or anywhere else for that matter.

I have to click on the notepad window in order to be able to dictate into it.



Dan, regarding the focus problem, try this:

1. Start Menu | (type in) regedit

2. Go to the following location: (take the usual registry precautions before editing your registry)

HKEY_CURRENT_USER\Control Panel\Desktop

Highlight the following entries on the right-hand pane of the registry editor, press enter and then modify as shown:

ForegroundFlashCount : this will probably be set to 7, change it to 1
ForegroundLockTimeout: this could be set to anything but just change it to 0


This should resolve the focus problem with various applications when trying to start them with DNS and using Windows 7.

Cheers



-------------------------

Tiger Feet

| DPG 15.7.1 | KnowBrainer 2020 | Windows 10 Professional /64 Bit | Intel® Core™ i9 Ten-Core Processor i9-10900K (3.7GHz) 20MB Cache |  32GB RAM. | 250GB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 2300MB/W) Boot Drive | 1TB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 3300MB/W) Storage Drive | Sennheiser D10 USB Wireless Microphone

 01/18/2015 03:12 PM
User is offline View Users Profile Print this message

Author Icon
monkey8
Top-Tier Member

Posts: 3824
Joined: 01/14/2008

Dan,

 

Windows not getting focus is a cross threading problem and happens quite often with Dragon because it's a background application trying to bring a new active window to the front of the queue.  (Z order) it's intermittent and doesn't always happen.  If for some reason it can't make the new window the active application window it will flash the taskbar buttons that you to let you know it wants attention. 

 

However you may find that you can fix it by doing the registry edit that Andy (Tiger Feet) has shown below/above.  You will need to restart windows after changing the registry. 

 

 



-------------------------



 01/18/2015 07:01 PM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Thanks guys,

I'm playing around with the switch to command at present and then I'll give the registry hack a go.

 Every time I come across these sort of setbacks I become amazed at the tenacity, patience and endurance folk who can't use their hands to control their computers. Personally I find it inspiring and a constant reminder to myself not to whinge and complain.

This forum does much more than provide a bit of technical help. One of the contributors suggested there would like the Forum to be able to have a like button :-). I even enjoy the banter although sometimes it does get quite serious. Please, don't let anybody bring up the fact that you need a high quality very expensive microphone to make Dragon work at optimal levels because if you do we will be entertained and informed until well past next Christmas :-).

Even on my busiest days I let my email inbox fill up with notifications from every section of this forum. I want to take a moment 2thank you all because I know that you have helped many folk stop that terrible slide into a frustrated, helpless blind panic that happens when you think that a bit of software has conned you and that you've been taken for a ride by an unscrupulous company or that you are a complete idiot and no-hoper when it comes to computers and their ilk :-).

Cheers for now
Dan

 



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/19/2015 03:10 PM
User is offline View Users Profile Print this message


Scribe
Top-Tier Member

Posts: 455
Joined: 04/02/2010

Just as a data point, I have found that it is never possible to use Notepad after opening it with Dragon, without mouse-clicking in Notepad first. Notepad is the only application in which I have had this problem. I use Dragon 11.5 and Windows 7. (I don't remember this being a problem before Windows 7, but I may be wrong.) Maybe I will try that Registry fix, but I tend to be cautious in that domain.

-------------------------

The woman who dueled with Aaron Burr and won: www.MmeJumel.com


 


Crohn's News Blog: www.crohns-news.net

 01/19/2015 03:36 PM
User is offline View Users Profile Print this message

Author Icon
Chucker
Top-Tier Member

Posts: 14123
Joined: 10/10/2006

Scribe,

I have four systems. One with Windows 7 32-bit, one with Windows 7 Ultimate 64-bit, and 2 with Windows 8.1. One of my Windows 8.1 systems is using DMPE 2.3, the other is using DNS 13 Professional. I have DNS 13 Premium on the Windows 7 32-bit system and DNS 13 Professional on the Windows 7 Ultimate 64 bit system. I have never on any of these systems had a problem with any application not assuming full focus when opened, and specifically never a problem with notepad not assuming full focus when opening such with Dragon all the way back through all the versions to DNS 10.1 (Preferred, Professional, and Medical).

I'm not questioning that others have this particular problem currently or have had it previously. However, I don't think it's the version of Windows itself and I don't think it's Dragon either. Nonetheless, since I can't replicate it, I can't pinpoint the source of the problem either.

If I recall correctly, it seems that those that experience this problem started reporting such with DNS 11-11.5. However, since it is continuing to rear its ugly head, my suspicion is that much of what is already been posted in this collection of threads points to the source of the problem being somewhere within the configuration of Windows on specific systems.

Just my $.02 worth.

Chuck

"What you are aware of you are in control of; what you are not aware of is in control of you." - Anthony de Mello

-------------------------

VoiceComputer: the only global speech interface.

The views, thoughts and opinions expressed in this post are my own and do not reflect those of VoiceTeach LLC.

Chuck Runquist
VoiceComputer technical support

 01/19/2015 04:56 PM
User is offline View Users Profile Print this message

Author Icon
kc4cop
Top-Tier Member

Posts: 312
Joined: 10/05/2007

Lindsay:

 

What I do - and what I see using KnowBrainer 14, Microsoft Word 10 (home and student version), Internet Explorer 11, Dragon Premium 12.0 and 12.5, and Windows Premium 7.  In the following scenarios the continued running of KnowBrainer after the sidebar has been hidden is confirmed by showing the KnowBrainer files present in task manager.

 

Usually I try to give more information in my initial posts. The pieces parts that are associated with this problem make reporting difficult and possibly confusing for me. I have tried to break details of the given situations down into manageable thoughts on the above and below associated conditions and issues. In summary, my problem is that I am not getting automatic resizing of application windows nor am I getting automatic focus to newly opened files and applications. Somewhere I missed the boat in being able to put across adequate details of my situation. The problems that I’m reporting on are not intermittent but rather take during the conditions reported above 100 percent of the time.

 

When I utter the commands that I use to minimize/maximize the KnowBrainer 14 sidebar, ie. “hide sidebar” and “show sidebar” other functions of KnowBrainer continue to run after I have closed the KnowBrainer sidebar. Automatic resizing of the window holding the currently opened Microsoft Word document does not automatically adjust the size of the screen in focus (examples include Microsoft Word and Internet Explorer). To get a window to open to full screen size often requires rebooting the computer. Closing open applications and reopening them does not resolve the problems of lack of automatic resizing and automatic focus being assigned appropriately - newly opened program is not received focus

 

Dan, I tried each of your suggestions before making my  responses to your original post in this string.  

 

KC4COP



-------------------------

Dell Inspiron 3847 64-bit; CPU i7-4790, 3.6 Ghz, 16 GB; Win 7 Pro; Dragon 14 DPI; KnowBrainer 17; Speechware 3-in-1; IE 11

 01/19/2015 05:18 PM
User is offline View Users Profile Print this message

Author Icon
monkey8
Top-Tier Member

Posts: 3824
Joined: 01/14/2008

Dick,

 

You are currently using the commands show sidebar and hide sidebar.  What I am saying is that you need to minimise the sidebar.  HIDE SIDEBAR does not minimise sidebar.  So for now if you want to maximise the Microsoft Word window then there are two ways of minimising the sidebar, switch focus to the sidebar and then say "minimise window" or click on the minimise button on the sidebar itself.  Once you have done that then maximise the Microsoft window and it will fill the screen.  The issue will be fixed with the next release.

 

Hope that makes more sense.

 

Lindsay



-------------------------

 01/20/2015 01:28 PM
User is offline View Users Profile Print this message

Author Icon
Tiger Feet
Top-Tier Member

Posts: 2180
Joined: 12/04/2009

I don't think it's the version of Windows itself and I don't think it's Dragon either. Nonetheless, since I can't replicate it, I can't pinpoint the source of the problem either.


Chuck,

This has happened to me in both Windows Vista & 7 and both of the registry fixes I have mentioned fixed the problem.  I don't know about Windows 8 because I don't have it.

Dan & Scribe, you clearly both have the problem that Chuck says he doesn't have because you have stated it in your posts.  So, if you try this, you can report back and prove to us if it worked or not.  Just follow the points carefully below and you won't have a problem.

Firstly, if you are worried about working within the registry, making a complete backup of the registry is very easy to do so do this first.

http://pcsupport.about.com/od/windows7/ht/backup-registry-windows-7.htm

then,

1. Start Menu | (type in) regedit

2. Go to the following location:

HKEY_CURRENT_USER\Control Panel\Desktop

Highlight the following entries on the right-hand pane of the registry editor, press enter and then modify as shown:

ForegroundFlashCount : this will probably be set to 7, change it to 1 then press OK.

ForegroundLockTimeout: this could be set to anything but just change it to 0 then press OK.

3. Close the registry

4. Restart Windows.


This should resolve the focus problem with various applications when opening them including notepad.

The reason you have this problem now is the explanation that Lindsay gave in his post.  If you want proof, read the links below.

http://technet.microsoft.com/en-us/library/cc957205.aspx


http://technet.microsoft.com/en-us/library/cc957208.aspx

Cheers



-------------------------

Tiger Feet

| DPG 15.7.1 | KnowBrainer 2020 | Windows 10 Professional /64 Bit | Intel® Core™ i9 Ten-Core Processor i9-10900K (3.7GHz) 20MB Cache |  32GB RAM. | 250GB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 2300MB/W) Boot Drive | 1TB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 3300MB/W) Storage Drive | Sennheiser D10 USB Wireless Microphone

 01/20/2015 02:01 PM
User is offline View Users Profile Print this message

Author Icon
Chucker
Top-Tier Member

Posts: 14123
Joined: 10/10/2006

Tiger et al.,

On all four of my systems the registry entries that you note in your post above are the default settings in both Windows 7 and Windows 8.1. If they have been changed, they were changed by something else, something installed on your systems, or some other unknown reason. This is why I've never had a problem with focus when opening any application.

That is, on my systems in the Windows system registry at the location you specify all show ForegroundFlashCount = 1 and ForegroundLockTimeout = 0. Been that way since I installed Windows 7 Ultimate, Windows 7 Professional, and Windows 8.1.

Go figure!!! That is nothing has ever changed those on any of my systems to anything other than the default settings. That's why I conclude that it's neither Dragon nor Windows itself.

Chuck

The biggest problem with debugging or resolving any software problem is that there are times when logic doesn't apply. Debugging is 90% serendipity, 3% experience, and 7% pure luck. - Unknown



-------------------------

VoiceComputer: the only global speech interface.

The views, thoughts and opinions expressed in this post are my own and do not reflect those of VoiceTeach LLC.

Chuck Runquist
VoiceComputer technical support



 01/20/2015 03:42 PM
User is offline View Users Profile Print this message

Author Icon
Tiger Feet
Top-Tier Member

Posts: 2180
Joined: 12/04/2009

On all four of my systems the registry entries that you note in your post above are the default settings in both Windows 7 and Windows 8.1. If they have been changed, they were changed by something else, something installed on your systems, or some other unknown reason. This is why I've never had a problem with focus when opening any application.


Good for you Chuck, but we are not talking about you, because you are the special one. 

If you look at the last two links I put in my last post, the default value in Windows 7 for the ForegroundFlashCount is 3 & the default value in the same for the ForegroundLockTimeout is 200000 according to Microsoft TechNet.  Go figure! 

This was also the same for me when I had Vista and Windows 7 Ultimate.  I now have Windows 7 Professional and it was the same with this.  This was one of the first tasks I did when I put Windows 7 Professional on my computer.  Go figure!

The problem has obviously reared its ugly head according to Dan and Scribe, as THEY are the ones who mention this problem in THEIR posts.

When Lindsay originally gave me this fix, I was using Windows Vista & Windows 7 Ultimate.  Those values on my computers when checked in the registry were not set, as I have specified in my previous posts.  When I changed them, noticeably notepad came out on my screen in focus when it did not before I changed those values.  This was also the case when I changed to a new computer with Windows 7 Professional on it. 

I have also shared this with many other people, some from Skip's now redundant website (Speech Computing) and it has worked for them as they came back and relayed that it had. 

Perhaps we should see if Dan & Scribe have those values in the registry.  I doubt it; otherwise, they would not be getting the focus problem that they are enduring now.

You can lead a horse to water, but you can't make it drink:  
Old English Homilies


Cheers



-------------------------

Tiger Feet

| DPG 15.7.1 | KnowBrainer 2020 | Windows 10 Professional /64 Bit | Intel® Core™ i9 Ten-Core Processor i9-10900K (3.7GHz) 20MB Cache |  32GB RAM. | 250GB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 2300MB/W) Boot Drive | 1TB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe SSD (up to 3500MB/R, 3300MB/W) Storage Drive | Sennheiser D10 USB Wireless Microphone



 01/20/2015 06:58 PM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Tiger and all,

Well I tried the registry hack but it made no difference. It might be that I'm opening notepad on my second screen but I can bring the focus to it with the "switch to notepad" command after notepad opens. This is not too hard to live with :-).

I have a recording set up where I use AutoHotkey to swap between a PowerPoint window and the recording software so that I can cue the recording software at the correct position for narrating a PowerPoint slide deck so that I can link the files rather than embed them. In the AutoHotkey script I actually use can name the window rather than just use a hotkey swap but that sort of solution is too restricted to handle dictating into notepad. I like notepad because it is definitely nice and quick and through the transfer command you can keep notepad open between, for instance, chats.

Thanks for all your help

at the moment I've got more difficult fish to fry. I'm working with a new deceptively simple image backup program that seems very cool. Unfortunately my Windows system has to be spread across 2 hard drives. I've decided in order to speed up the restore process I need to partition the second 2 TB drive so that the Windows system is separated from all of my data and data folders. It will take me a while. Of course I could get a bigger SSD drive for the system but these days I'm strapped for cash :-).

cheers
Dan



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/21/2015 06:00 PM
User is offline View Users Profile Print this message

Author Icon
kc4cop
Top-Tier Member

Posts: 312
Joined: 10/05/2007

Lindsay:

 

Minimizing KB Sidebar by voice is not working. Minimizing KB Sidebar using “ – “ in upper right area of title bar does not give automatic resizing of other Windows.

 

1.   Switch to Sidebar > focus is on KB Sidebar

2.    Minimize Sidebar > the following occurs
(A.) NO visible change to sidebar – SIDEBAR REMAINS OPEN.
(B.) “minimize sidebar” TEXT appears in the text being dictated in the opened “ Word” document.

 

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

From Previous Post of Mine

What I do - and what I see using KnowBrainer 14, Microsoft Word 10 (home and student version), Internet Explorer 11, Dragon Premium 12.0 and 12.5, and Windows Premium 7.  In the following scenarios the continued running of KnowBrainer after the sidebar has been hidden is confirmed by showing the KnowBrainer files present in task manager.

 

Usually I try to give more information in my initial posts. The pieces parts that are associated with this problem make reporting difficult and possibly confusing. I have tried to break details of the situation down into associated conditions and issues In summary, my problem is that I am not getting automatic resizing of application windows nor am I getting automatic focus to newly opened files and applications. Somewhere I missed the boat in being able to put across adequate details of my situation. The problems that I’m reporting on are not intermittent but rather take during the conditions reported above     100 percent of the time.

 

When I utter the commands that I use to minimize/maximize the KnowBrainer 14 sidebar, ie. “hide sidebar” and “show sidebar” other functions of KnowBrainer continue to run after I have closed the KnowBrainer sidebar. Automatic resizing of the window holding the currently opened Microsoft Word document does not automatically adjust the size of the screen in focus (examples include Microsoft Word and Internet Explorer). To get a window to open to full screen size often requires rebooting the computer. Closing open applications and reopening them does not resolve the problems of lack of automatic resizing and automatic focus being assigned appropriately - newly opened program is not received focus

 

 

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

3.   Switch to Sidebar > focus is on KB Sidebar

4.    Minimize Sidebar > the following occurs
(A.) NO visible change to sidebar – SIDEBAR REMAINS OPEN.
(B.) “minimize sidebar” TEXT appears in the text being dictated in the opened “ Word” document.

kc4cop



-------------------------

Dell Inspiron 3847 64-bit; CPU i7-4790, 3.6 Ghz, 16 GB; Win 7 Pro; Dragon 14 DPI; KnowBrainer 17; Speechware 3-in-1; IE 11

 01/21/2015 06:14 PM
User is offline View Users Profile Print this message

Author Icon
kc4cop
Top-Tier Member

Posts: 312
Joined: 10/05/2007

Since windows, even when focus is restored to them, do not present a wide enough screen to read all of the text and see the graphics. So far the only fix has been to re-boot Windows and not start KnowBrainer.

 

Displaying a page in the KnowBrainer forum only show approximately ¾ or a little more of the page’s contents.

 

Kc4cop



-------------------------

Dell Inspiron 3847 64-bit; CPU i7-4790, 3.6 Ghz, 16 GB; Win 7 Pro; Dragon 14 DPI; KnowBrainer 17; Speechware 3-in-1; IE 11

 01/21/2015 06:35 PM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 39344
Joined: 10/01/2006

If you wish to switch focus to the KnowBrainer sidebar say the Dragon switch to KB sidebar (the name of the Window) command. KnowBrainer does not include a switch to sidebar or minimize sidebar command. If the KnowBrainer sidebar is in focus, you can say Minimize. The appropriate commands are Show Sidebar and Hide Sidebar. Note that if you exit/close the KnowBrainer sidebar, you are not exiting KnowBrainer. You are only closing (more appropriately hiding) the sidebar. For a complete list of KnowBrainer hardcoded commands say Show Hardcoded Commands. To properly exit KnowBrainer say Close KnowBrainer to close KnowBrainer 2014 and the sidebar.

We believe the problem you're experiencing has been caused by the putting a check in Automatically Adjust Active Window. Unfortunately, in KnowBrainer 2014, you cannot uncheck this option. This will not be a problem in KnowBrainer 2015 but if you reread Lindsay's or our previous post, you will see how to undo this feature. The following 3 steps is a copy of those instructions:

1. Open C:\Users\WINDOWSUSERNAME\AppData\Local\KnowBrainer\KBPro.exe_Url_vnxpp\1.0.0.0\user.config file.

2. Go to the end of the file.

3. Change True to False in
False
to disable this feature. You will not have to go through this process when we release KnowBrainer 2015.

 



-------------------------

Change "No" to "Know" w/KnowBrainer 2020
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ex 1



 01/20/2015 07:32 PM
User is offline View Users Profile Print this message

Author Icon
Chucker
Top-Tier Member

Posts: 14123
Joined: 10/10/2006

Tiger,

I realize that we are not talking about me. Perhaps I should have been more clear. What I was trying to say, having unfortunately left a couple of things out, is that all my installs of Windows were absolutely clean. That is, I started from scratch and rebuilt those systems from the ground up the specific versions of Windows that I'm using. I've never changed anything. Unfortunately, I can't go back to square one and be absolutely sure that those with the default settings. For example, my Windows 7 Ultimate 64-bit was installed absolutely pristine from scratch back when Windows 7 Ultimate 64 bit came out. Windows 7 Professional 32-bit was installed absolutely clean and rebuilt for testing purposes. Both of my Windows 8.1 were also absolutely clean installs. None of these systems were ever upgraded from a previous version of Windows. I'm just trying to wrap my head around what may have caused those registry entries to have been modified on those systems where users are having the problem . I wasn't trying to toot my own horn.

Regardless, changing the settings as you specify should fix the problem.

Dan,

Have you tried rebooting your system (i.e., doing a cold boot - shutting down the system completely and restarting it). Also, before you do a cold boot recheck the settings and make sure that they are still as specified by Tiger. If they are, then do a cold boot and check the settings again. If you still can't get notepad to open focused so that you can dictate into it, have the settings changed?

Chuck

Trouble is the easiest thing to get into and the hardest thing to get out of. - Unknown



-------------------------

VoiceComputer: the only global speech interface.

The views, thoughts and opinions expressed in this post are my own and do not reflect those of VoiceTeach LLC.

Chuck Runquist
VoiceComputer technical support

 01/20/2015 09:28 PM
User is offline View Users Profile Print this message

Author Icon
danw700
Top-Tier Member

Posts: 1144
Joined: 04/25/2014

Chuck & Tiger,

Well I double checked. This time notepad has started and is focused – dictation straight away however once again after a cold reboot the
ForegroundLockTimeout setting moved from 0 to become a new value 30d40.

I did try this yesterday but I can't remember if I actually did a cold boot or not. I did do a cold boot this morning and the focus was not on notepad when it started.

Thanks again for all your help I will continue and see if notepad continues to be focused when I launch it with the start command :-).

Thanks for the help. By the way, this system was a clean install about a year ago to Windows 7 professional from scratch on a pristine hard drive. Of course, seeing I constantly tinker who knows what has happened to it in the meantime.

I had intended in the new year to do a fresh from scratch install but I was hoping that Windows 10 might have been ready. I like Windows 7 but unfortunately it does not support USB 3 except through third-party drivers which means that I can't use my USB 3 toasters with total confidence to make high-speed clones. I have to use the  eSata cable connection. I think Acronis has overcome this particular problem with 2015 but unfortunately they dropped the Try and Decide feature out of it. Anyway, I'm old school and prefer uncompressed clones for my system backups.

I'll try and remember the next time I do a pristine Windows install to check the settings :-).

Have a great New Year – it's well on the way to being done :-).
Cheers
Dan



-------------------------

The forum has me as a Top-Tier Member NO I am a laid-back layman

 01/28/2015 07:36 PM
User is offline View Users Profile Print this message


Scribe
Top-Tier Member

Posts: 455
Joined: 04/02/2010

Thanks to all who offered troubleshooting advice with the focus problem. Tiger Feet, your instructions for editing the registry worked perfectly for me. I use Windows 7 Professional, and I found that my ForegroundFlashCount was set at 7 and the ForegroundLockTimeout was set at 200000, which I changed to 1 and 0, respectively. (Note to those considering this edit, once you go into the edit box for ForegroundLockTimeout, you have to choose "decimal value" to be able to see and change the value of 200000.)

I am very happy to have immediate access to notepad , because I often use it when I want to take notes when I am reading a PDF. (Because it is small, I can see the PDF content above or below the notepad box. I don't have multiple monitors or a big monitor that would allow me to split screens and have Microsoft Word on one side.)

-------------------------

The woman who dueled with Aaron Burr and won: www.MmeJumel.com


 


Crohn's News Blog: www.crohns-news.net

Statistics
32171 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 467 guests browsing this forum, which makes a total of 469 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.