KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Error message the first time running a custom command
Topic Summary:
Created On: 04/23/2022 03:44 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 Error message the first time running a custom command   - Alan Cantor - 04/23/2022 03:44 PM  
 04/23/2022 03:44 PM
User is offline View Users Profile Print this message

Alan Cantor
Top-Tier Member

Posts: 4313
Joined: 12/08/2007

I have a custom Dragon command for Excel called "good bye <values> <values>.

The first time I run this command after launching Dragon, I get this error message:

The Macro contains the error:

MyCommand: "good bye 5 8"
Line:    5
Position:    0
Description: (10096) ActiveX Automation: no object currently active. -

Please use MyCommands Editor to make the appropriate corrections.

I clear the error message, repeat the command, and voilà! The command works, and continues to work for as long as Dragon is running.

The same thing happens the next time I run Dragon.

What might cause a command like this to fail the first time?

Not sure this is relevant, but as part of this command, I set the Reference to "Microsoft Excel XX.0 Object Library (X.X)". [The values of X depend on the Excel version.]

32306 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 381 guests browsing this forum, which makes a total of 383 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2022 FuseTalk™ Inc. All rights reserved.