KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: [Solved!] (Vocola) shift-key suddenly flaky?
Topic Summary: NoMachine: Can only select a few characters at a time
Created On: 01/06/2021 11:20 AM
Status: Post and Reply
Linear : Threading : Single : Branch
 [Solved!] (Vocola) shift-key suddenly flaky?   - Chan123 - 01/06/2021 11:20 AM  
 [Solved!] (Vocola) shift-key suddenly flaky?   - Chan123 - 01/07/2021 04:44 AM  
 01/06/2021 11:20 AM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 33
Joined: 01/15/2019

Returning to work after the holidays I discover that suddenly, selecting text through my Vocola commands as been greatly reduced. Although it only seems to affect editors through my NoMachine session. As far as I can tell, other select-and-say supported applications (such as notepad) as well as unsupported applications (IDLE, the address bar in Firefox) still work fine.

Although as of March I have been using a work laptop from home, my setup for NatLink, Unimacro, Vocola and associated commands have not changed for years. I tried creating and using a new profile in Dragon (thinking it was at fault initially) but the issue persists.

What seems to happen is the way of how the shift key is held down during voice commands has become flaky. If I issue a command to only select a couple of characters (such as "shift right four") then those will become selected. But if I become greedy and go for a "huge" number (such as "shift right six") then the cursor moves six steps but nothing is highlighted. If I try to select several lines (say "shift down eight") then it will appear that as the cursor moves down the very first line is selected but only briefly before the cursor continues moving without selecting anything further, therefore losing the initial line that was selected for a very brief moment.

I must admit that I'm a bit baffled why this has happened, and how to troubleshoot it. I use NoMachine and VS code on a Linux machine as a software developer. I see the same behaviour in Emacs through NoMachine (although I can live easier without Emacs). If I can't find a solution to this in NoMachine, it will slow down my programming even further.

I've got to DPI 15.3, NatLink version 4.2[1] (including Vocola 2.8.6 and Unimacro). The Vocola commands that I rely upon I *think* that I got from the Vocola website some years ago. I have trimmed down the files with the commands so I'll attach them to this post for reference.

I'd greatly appreciate if anyone could shed some light on this issue. I'll happily update NatLink/Vocola/Unimacro if that will help?


-- Edit --

[1] I think I'm on Version 4.2India, any significant changes in recent years?

ME_vocola.vcl  (0 KB)
ME_win32pad.vcl  (8 KB)




  NatLink version: 4.1whiskey3
  DNS version: 15
  Python version: 27
  Windows Version: 10
Unimacro enabled
Vocola enabled

31988 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 1 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 564 guests browsing this forum, which makes a total of 565 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.