KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Frustrating Lags on DPI 15.3 on a powerful machine
Topic Summary:
Created On: 08/18/2020 05:34 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 Frustrating Lags on DPI 15.3 on a powerful machine   - android94301 - 08/18/2020 05:34 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Lunis Orcutt - 08/18/2020 06:22 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - dilligence - 08/18/2020 07:58 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Stephan Kuepper - 08/19/2020 06:11 AM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - R. Wilke - 08/19/2020 03:18 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Mav - 08/24/2020 04:28 AM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - R. Wilke - 08/24/2020 02:00 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - PG LTU - 08/19/2020 04:54 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Rapp - 08/20/2020 09:22 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - TomDonovan - 08/25/2020 08:22 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Lunis Orcutt - 08/25/2020 10:26 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Edgar - 08/26/2020 10:41 AM  
 Frustrating Lags on DPI 15.3 on a powerful machine SOLVED! Here's the list.   - android94301 - 08/26/2020 01:33 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine SOLVED! Here's the list.   - Mav - 08/27/2020 06:09 AM  
 Frustrating Lags on DPI 15.3 on a powerful machine SOLVED! Here's the list.   - wristofdoom - 09/24/2020 01:44 PM  
 Frustrating Lags on DPI 15.3 on a powerful machine   - Lunis Orcutt - 09/24/2020 05:45 PM  
Keyword
 08/18/2020 05:34 PM
User is offline View Users Profile Print this message

Author Icon
android94301
Power Member

Posts: 45
Joined: 01/13/2015

So here is the deal. I’m running DPI 15.3 on an i7 intel machine, windows 8.1, with 16 GB of memory and a fast SSD drive.

 

When I am not dictating on my Sennheiser MB 1 wireless headset,  I leave Dragon running but the microphone off. I use a keyboard shortcut to turn the microphone on, but Dragon is unresponsive for anywhere from 30 to 60 seconds. I can’t right click on the Dragon icon and get any options, and there is no voice recognition yellow box.

 

After 30 to 60 seconds everything works again and it works fine until the next time I need to turn it back on. It doesn’t matter whether I use my wireless Sennheiser Mic or my wired USB mic, there is always that same lag.

 

This means that using Dragon is slow and annoying, since I don’t use it for everything, and prefer to type when doing short responses. But for longer entries I really like Dragon.

 

I would love to solve this problem. I thought it might be that in the old days I used to sleep the microphone, but I haven’t done that for a while and it doesn’t seem to make any difference.

 

Any suggestions would be very helpful. I’m running Dragon with Knowbrainer.

 

Thanks in advance, if I could solve this my life would be much better (at least computer life!)

 08/18/2020 06:22 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38002
Joined: 10/01/2006

We are not certain but suspect that Dragon is buffering some sort of interference noise. When you turn the microphone back on, Dragon will attempt to transfer your dictation but taking a long time because it is trying to figure out what you didn't say, if you understand what we are saying. Unfortunately, this is probably up there with our dumbest answers and the Big Haired Lady reacted by laughing so hard that she swallowed her lit cigarette and when I laughed she said “I hope you enjoy menthol mac and cheese”. This probably isn't any worse than when she made spaghetti and meatballs with hotdogs and ketchup.


1. Say Data Options to open Dragon's options to the Data tab
2. Change Disk space reserved for playback to 0
3. Cross your fingers and click OK
4. Report back with your findings because we have heard several complaints and still spit balling.

PS: When Dragon's microphone is completely off, we know it is still listing in some way because we regularly turn our Dragon microphone off and use our recorder to write jokes (as dumb as that sounds). When we turn the Dragon microphone back on, it often reproduces our recorder dictation. We do not know if it's coming from the recorder or simply using another microphone source, like our videocam. Yes, this all sounds pretty far out but there is something to it.



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1



 08/18/2020 07:58 PM
User is offline View Users Profile Print this message

Author Icon
dilligence
Top-Tier Member

Posts: 1130
Joined: 08/16/2010

Lunis, you mean Dragon is still doing some kind of processing while the microphone is actually Off (i.e. not just sleeping)? That sounds like Google Home

 

I have noticed only once so far that Dragon kept on responding while the microphone was supposedly off, but that appeared to be a one time glitch only (never happened again).

 

Anyway, you can easily find out if you use a utility like Core Temp. You will see immediate response in the core temperatures if Dragon picks up any sound at all (like it does in sleep mode for instance). So far, at least on my system, there's absolutely nothing happening if the microphone is Off



-------------------------

www.speechproductivity.eu 


SP 6 PRO - The Dragon Enhancement & Productivity Suite

 08/19/2020 06:11 AM
User is offline View Users Profile Print this message

Author Icon
Stephan Kuepper
Top-Tier Member

Posts: 2104
Joined: 10/04/2006

This behaviour has occurred frequently enough to earn the name of "Alexa mode" from one of our customers. After some research, we could narrow it down to the fact that cancelling recognition as opposed to turning the microphone off (and hence cancelling recognition) are two different events within Dragon. It seems that when you cancel recognition, sometimes the "microphone off" event is not received, resulting in audio being buffered and transcribed the second the microphone is turned on again. Of course, if there is audio coming in which does not qualify as dictation, Dragon may process that audio for some time, and seem to stall during the process.

The workaround is of course to make sure that the microphone is completely off, usually by using Dragon's hotkey.

There is also the option to enter the following lines into the nsuser.ini, section [Settings]:

Turn Speechmic Off Immediately=1
Turn Powermic Off Immediately=1

I have no idea whether this will work with Dragon Professional Individual 15.3, but it is certainly worth a try.

Hope that helps, Stephan

-------------------------

www.egs-vertrieb.de - www.spracherkennungscloud.de

 08/19/2020 03:18 PM
User is offline View Users Profile Print this message

Author Icon
R. Wilke
Top-Tier Member

Posts: 7235
Joined: 03/04/2007

Stephane,

what is so difficult about understanding that cancelling recognition doesn't entail shutting down the microphone?

The problem discussed in this thread most likely boils down to making sure that the microphone isn't listening when it shouldn't, and this is a 101 in my book which I have always emphasised in many postings, but probably not made clear enough.

Having used Dragon as a critical tool in my professional job for almost 2 decades, to get my job done, as opposed to whatever Stephane does for a living, if or whenever Dragon acted behaving like that, such as stalling or even crashing any old time, I definitely wouldn't have stuck with it until now.

-------------------------



No need to buy if all you want to do is try ...

DragonCapture KB Download (Latest)
DragonCapture Homepage

 08/24/2020 04:28 AM
User is offline View Users Profile Print this message

Author Icon
Mav
Advanced Member

Posts: 200
Joined: 10/02/2008

Hi Rüdiger!

Stephan made clear that turning off the microphone is a separate action from cancelling a running recognition.

Stephane, what is so difficult about understanding that cancelling recognition doesn't entail shutting down the microphone?

This is simply not true - please try for yourself.

 

Make sure the preview window is being shown, start a recognition and then click on the small "cancel"-icon in the top left corner of the preview window. Dragon cancels the running recognition and afterwards the microphone is OFF with my DMPE 4.3 (and I can't remember this to be any different in any other version since DNS 4 back in 2001, when I started my professional life with Dragon).

 

Since I also had occasions where Dragon would write something I said while the microphone definitively was OFF after I switched the mike on again, I guess in some situations cancelling the running recognition automatically before turning off the microphone doesn't work. The microphone is being displayed as off while in the background Dragon is still buffering audio and trying to cancel the running recognition.

 

When you then turn on the microphone again, Dragon remembers that it still has buffered audio to process and immediately starts recognizing this audio (which was recorded while the mike supposedly was off).

 

In earlier versions the Dragon Engine switch to "turn off the microphone immediately" controlled the behavior of Dragon when the mike was being turned off.

As you might remember, the long-time default was that a running recognition had to be complete before Dragon actually showed the microphone as off. That's why we always told our customers to be patient and not to hit the mike-toggle hotkey repeatedly if the microphone would not turn off immediately.

 

With the afforementioned switch set, a running recognition would be cancelled (instead of waiting for the process to complete) and then the microphone would be turned off, but that means that the last phrase might get mutilated or discarded if you turn off the microphone too early.

 

Nowadays I only seem to get the latter behavior, regardless of the engine switch.

 

Regards,

mav

 08/24/2020 02:00 PM
User is offline View Users Profile Print this message

Author Icon
R. Wilke
Top-Tier Member

Posts: 7235
Joined: 03/04/2007

Make sure the preview window is being shown, start a recognition and then click on the small "cancel"-icon in the top left corner of the preview window. Dragon cancels the running recognition and afterwards the microphone is OFF 

 

Mav, you are correct, and I was wrong. I just stumbled upon it, over the weekend, by chance, and hadn't been aware that, when cancelling the recognition like this, the microphone is shut off immediately also.

Sorry for the confusion.

 



-------------------------



No need to buy if all you want to do is try ...

DragonCapture KB Download (Latest)
DragonCapture Homepage

 08/19/2020 04:54 PM
User is offline View Users Profile Print this message

Author Icon
PG LTU
Top-Tier Member

Posts: 2072
Joined: 03/21/2007

To me it sounds like the USB power issue. You all seem to miss that OP said:

 

Originally posted by: android94301 I leave Dragon running but the microphone off.

 

So, what I would try is to disable the mic and then re-enable it one or a couple of seconds later (in the "Recording" tab of the "Sound" control panel applet usually accessible on the taskbar) and see if that allows immediate dictation recognition.  If so, search around for the computer power settings that allow the OS to put USB ports to sleep to save power.  When you find that, disable that function.

 

Hth,



-------------------------




PG





Remember folks, my comments and this forum are for entertainment value only, please, no wagering or other reliance on the contents herein.  I permit no commercial use of my ideas (whether expressions or embodiments) without my written consent.

 08/20/2020 09:22 PM
User is offline View Users Profile Print this message


Rapp
Senior Member

Posts: 102
Joined: 12/12/2007

You might consider removing the Dragon add-ins for your web browsers and for Excel to see if that helps if you have not already done so. Removing the Dragon add-ins for my web browsers has significantly improved the performance of Dragon on on my system.
 08/25/2020 08:22 PM
User is offline View Users Profile Print this message

Author Icon
TomDonovan
New Member

Posts: 8
Joined: 08/22/2020

I was having a similar issue and found that by unchecking the Dragon option on the Commands screen "Enable launching from the Start Menu", the problem went away. I found in the logs it was taking forever to parse the Start Menu and since I rarely launch a program by voice, the few I would launch I can create a custom command to do, and this made a world of difference for me. I also unchecked Enable Launching from the desktop, I don't think this was the culprit, but I don't use it, so just to be sure I unchecked it. Again when I did this, it was immediately a completely different and usable program.

As a side note, it does mean there is either something wrong in your start menu someplace or you just have way too many items in the start menu or a combination of the both.

-------------------------

Tom

 08/25/2020 10:26 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38002
Joined: 10/01/2006

+ Nice going Tom. It's been a few years but we remember other end-users running into a similar problem when their start folder was stuffed with shortcuts. The worst culprits were orphaned shortcuts because Dragon has a particularly hard time with dead ends because it tries to connect the dots and it only takes one. It might also be a good idea to clean out the start folder. Most housekeeping utilities and Windows include this feature. We've also noted that disabling Enable HTML support in the Dragon Commands/Options can help with sluggish browser behavior. Both of these problems sometimes go together.



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1

 08/26/2020 10:41 AM
User is offline View Users Profile Print this message

Author Icon
Edgar
Top-Tier Member

Posts: 915
Joined: 04/03/2009

Carefully look through all of the entries in the "All Apps" list (don't forget to expand all of the drop downs to expose subitems). If any have names (or words in names) which you think Dragon might have a problem recognizing add them to Dragon's and/or train them a few times. Do the same for all the tiles. Use Dragon to name EVERY single item on your desktop - applications, folders and shortcuts. This ensures that Dragon can recognize the name of every item. Don't forget, you might have "Hidden" items on your desktop which you rely on Dragon to deploy.

-------------------------

-Edgar
DPI 15.3, 64-bit Windows 10 Pro, OpenOffice & Office 365, Norton Security, Shure X2U XLR to USB mic adapter with Audio Technica DB135 vocal mic, Asus X299-Deluxe Prime, Intel Core i9-7940X (14 core, 4.3 GHz overclocked to 4.9 GHz), G.SKILL TridentZ Series 64GB (4 x 16GB) DDR4 3333 (PC4 26600) F4-3333C16Q-64GTZ, NVIDIA GIGABYTE GeForce GTX 1060 GV-N1060G1 GAMING-6GD REV 2.0 6GB graphics card with 3 1920x1080 monitors

 08/26/2020 01:33 PM
User is offline View Users Profile Print this message

Author Icon
android94301
Power Member

Posts: 45
Joined: 01/13/2015

I have been very busy the last week or two dealing with fallout from the California fires and smoke. But I did want to report back that one of these fixes actually has made a tremendous difference. I did all of them.

Here's what I did: for future reference for other people to fix the lag when I turn the microphone back on:

1. Say Data Options to open Dragon's options to the Data tab
2. Change Disk space reserved for playback to 0
3. Cross your fingers and click OK

Next: Unchecked the Dragon option on the Commands screen "Enable launching from the Start Menu. I also unchecked "Enable Launching from the desktop."

Next: We've also noted that disabling "Enable HTML support in the Dragon Commands/Options" can help with sluggish browser behavior.

That's all I did, and it seems to have fixed the problem completely. Now when I toggle on the microphone, Dragon responds instantly. I will try testing it with the sleep mode and see if that has imprroved as well. If I have some time, I will test each step to see what makes the difference, but for now, my little Dragon patient is cured!

Thank you thank you thank you thank you thank you thank you! This has mmade my life so much easier. I love this forum.. Anyone who uses Dragon without this forum is working too hard.



 08/27/2020 06:09 AM
User is offline View Users Profile Print this message

Author Icon
Mav
Advanced Member

Posts: 200
Joined: 10/02/2008

Hi!

Disabling start menu and desktop application commands might indeed be the remedy for Dragon lagging. Even though I didn't witness these lags directly, an observation from some time ago makes it a plausible fix/workaround.

 

In our integration we support variables (similar to what Dragon does with text inside [ and ], but much more elaborate and with the posibility to jump to variables by name) for navigation within the text.

In order to achieve this, a handfull of commands have to be updated everytime the list of available variables changed.

Initially, this all worked very fast, but after a while and many updates to the lists, Dragon got slower and slower, until you restarted. There seems to be a resource leak in Dragon's list handling somewhere.

 

Handling of start menu and desktop applications basically has to perform the same tasks: Create a voice command "Start <app>" and then fill the list <app> with all the application names found in the start menu and on the desktop.

In the beginning, this works fine, but Dragon also has to update the list and then chances are that this process suffers from the same detoriation of performance we could reproduce in our integration way back then.

 

We'll perform further tests as well, but now already a kudos for finding this connection!

 

mav

 09/24/2020 01:44 PM
User is offline View Users Profile Print this message

Author Icon
wristofdoom
Power Member

Posts: 58
Joined: 09/03/2020

Can somebody elaborate on what exactly is happening by making these changes?

 

I'm wondering what happens when the disk space for playback is brought down to zero. What are the negative consequences of doing this if any?

 

Also, I read in the Nuance documentation that if you turn off "HTML support" then the Dragon web extension for Chrome etc. doesn't work. That does not seem good....

 

https://www.nuance.com/products/help/dragon/dragon-for-pc/enx/professionalgroup/main/Content/DialogBoxes/options/options_dialog_startshut_tab.htm



-------------------------

Dragon Professional Individual v15.6. Windows 10. Knowbrainer 2017.

 09/24/2020 05:45 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38002
Joined: 10/01/2006

There is no negative side unless you wish to playback your dictation and even then, your dictation is temporarily buffered in RAM.


If you turn off HTML support, you lose Active Accessibility which shouldn't noticeably affect your speed but will prevent you from clicking on controls (links, buttons etc.) but doesn't prevent you from experimenting. 



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1



Statistics
31793 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 1 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 704 guests browsing this forum, which makes a total of 705 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2020 FuseTalk™ Inc. All rights reserved.