NATURALLYSPEAKING QUICK TIPS
(as of 05/21/2018)

WHAT TO DO BEFORE CALLING TECHNICAL SUPPORT
NaturallySpeaking Splash Screen Freezes when attempting to launch (Ver. 10-12)
Computer Recommendations
How to Fix USB Microphone Not Working after Installing Windows 10 1803 Update
How to Remedy Substandard Dragon 15 Accuracy
User Profile Cannot Be Opened Because You Lack Sufficient Windows Privileges
Error: The user profile you have selected cannot be accessed ~ Larry Allen
How to Enable Dictation in Non-Dragon Friendly Apps (Ver. 13/15) by Lindsay Adam
How to Install a Dragon Patch
How to Enable Automatic punctuation in DMPE 4 (which Nuance removed) ~ Rüdiger Wilkie
How to Change Dragon Wakeup Commands ~ Larry Allen
How to Prevent Dragon 15 From Automatically Saving Your Profile When Exiting ~ (contributed by Pascal)
How to prevent the Dragon Microphone from Toggling Off (disable auto-gain) 15
How to Disable Microphone Auto-gain 15
How to Stop Dragon From Opening MS Word Documents
Dictation Box Fails to Paste Text Into Remote Applications 12/13
Dragon Drops Letters When Dictating over a Citrix Network 11-13 (contributed by Mark Haimes)
Dragon NaturallySpeaking Setup Requires Elevation
Error 166, 168 and 174
How to Disable Smart Phone Support (Ver. 12/13) by Chuck Runquist & Stephan Kuepper
How to Reenable the Dragon Firefox Browser Extension 13-15
Problems with Dictating into Care360, eClinicalWorks and other EMRs (DMPE 2)
How to Make the Dictation Box Open Automatically in Non-Fulltext Control Applications (Ver. 12–15)
Every Time I Launch Dragon I Am Prompted to Activate Again
Prevent Windows 10 from Losing USB Connections
How to Reenable Launching Start Menu and Desktop Applications/Files/Folders (by Lindsay Adam)
Enabling Dictation in Thunderbird
How to Prevent Nuance Pop-up Advertising
How to prevent the Google Chrome black screen
How to Change the Ver. 13 Blue Microphone to Yellow (by Lindsay Adam)
Microsoft Word/Outlook/Excel Will Not Permanently Allow the Dragon Add-In
How to Delete a Dictation Source – 13 (by Stephan Kuepper)
Dragon InstallShield Fails (Ver 11-12)
How to Launch Dragon Automatically When Starting Windows
KnowBrainer Configuration Error (KnowBrainer fails to launch)
PowerMic II tab not recognized in Options (Medical Practice 10 – DMPE 2)
How to Prevent Antivirus and Anti-Malware Utilities from Blocking Dragon And Other Applications
Error 154 – (contributed by Stephan Kuepper)
Grammarly Add-in is not Dragon compatible
Dragon 14-15 Modern Toolbar Goes AOL
Microsoft Word Dictation Appearing As Red Formatted Green Highlighted Italicized Text
How to Prevent Microsoft Word from Selecting Unwanted Spaces When Selecting Text
What to Do When Dragon Won’t Launch a Start Menu Application
Medical Abbreviations like PRN (P.R.N.) appear as “when necessary” DMPE 2
How to Prevent DNS 12 from Prompting You to Perform needed User Profile Maintenance
Browser Error - Too Many Links on Page (Ver. 10-12)
How to Make Dragon Open Any Folder, Application, File or Utility
KnowBrainer 2016 Produces .NET Framework Initialization Error
How to Prevent Deployment of the Post to Twitter & Facebook commands Ver 11.5 by Lindsay Adam
Latency Issues Ver. 11.5
Naturally Speaking appears to be running Windows compatibility mode Ver 11/12
How Do I Stop My Voice From Coming Through My Headset Speakers
How Do Get AM/PM vs. am/pm
Error 1606 Prevents Installation
NaturallySpeaking Installation Error 1722
RPC S Server Unavailable, 1722
MSXML Installation Error 12
HOOKERR_NONOTIFYWINDOW error
A Referral was returned from the Server error when installing KnowBrainer or DNS
Samurai Command Mode
NaturallySpeaking Types the Same Single Syllable Word over and over Again
C++ 9.0 Installation Error on Windows 7 or Vista – Ver. 11
Failed to Launch 64-bit server – Ver. 11/12/13
C++ 8.0 Error Prevents DNS From Installing – Ver. 10
Error 1330 A file that is required cannot be installed because...
A Serious Error occurred while initializing the NaturallySpeaking speech engine – Ver. 10/11
Scheduled Accuracy Tuning Fails to Deploy – Ver. 10
Can’t Find dnstk10.dll error – Ver 10/11/12
Cannot Prevent Roaming Results Box – Ver 9.5 – 10
This Program Requires a Security Key
NaturallySpeaking Installation Produces a Cab Error – Ver. 10
How to Change the Size and Position of the Command Browser – Ver. 10 - 12
NaturallySpeaking System Requirements - Ver. 10/11
DOCOBJ.DLL Did Not Register itself error Ver. 9 - 11
Mouse Grid and Correction Box Coordinates are way off in Windows 7 - Ver. 10
Please Wait While Windows Configures NaturallySpeaking (repeatedly) – Ver. 9/10
Contents of Clipboard are Pasted along with Dictation – Ver. 10
How to Prevent ”The select previous variable hotkey was not installed...” Ver. 10.1 by Chuck Runquist
How to Prevent DNS From Adding Unwanted Vocabulary - Ver. 9
Run accuracy tuning and collect recognition data keeps asking for Windows login
How To Disable the DNS Delete, Copy and Cut Commands – Ver. 10/11
How to Prevent DNS from forcing you to choose a number when Selecting/Cutting/& Deleting Text – Ver. 11
How To Prevent DNS from Automatically Placing the Microphone in Sleep Mode – Ver. 11
Acoustic Optimizer Is Grayed Out on the Roaming User Profile
SDAPI Error 1: Error: [S:\mrrec17\11988\mrrecutil\realdf.cpp]185mrecutil\realdf 17]
NaturallySpeaking Briefly Displays the Splash Screen but Won’t Launch – Ver 9.5
NaturallySpeaking Insists that the processor speed is not adequate for running the installation Ver. 9/10
Erratic Behavior (including E-Fail error) Ver 6-11
Cannot Load Compatibility Module – V9/10
KnowBrainer Stops Running after a Minute or 2 on Vista SP 1 Error: Path not Found
KnowBrainer 2016 Installation error “this is not a valid Windows 32 bit application”
KnowBrainer Produces Runtime Error 429 (ActiveX Component Can't Create Object)
KnowBrainer Install Error: Cannot open file msvcr40.dll
Running the Acoustic Optimizer Produces Error Message: 0x80040154 class not registered – Ver 9
SDAPI Error 1: Error: \s:\mrec15\11115\sdapi\apist.cpp 393 sdapiapist 24] …
This program has been damaged possibly by a bad sector or a virus – Ver 9
Can’t See all of the Text or Buttons in the Training Window – Ver 7-10
NatSpeak Has Reached the Maximum Amount of Speech Data That Can Be Saved – Ver 7-10
When Saving Speech files error: “cold not copy aco.ini…file already exists”
DNS Prompts You to Activate Every Time You Launch
The following files were not registered successfully: "C:\Program Files…\msoe_agent.dll
Acoustic Model Optimizer works but Language Optimizer Fails
Prompted to Increase the Size of the Acoustic Archive Whenever Saving a User Profile - Ver 10.0
How to Stop Windows Explorer from opening “C:\Program Files|Common Files|ScanSoft\OCR – Ver 8
How to Turn Off the Automatic Update Features – Ver 8 - 12
Forced to Rerun the Audio Setup Wizard Each Time I Launch DNS
Outlook 2007 Dictation Appears in Word 2007
Dictation Appears Correctly in the Results Box But only Some of the Words appear in the Document
The Results Box displays “< ??? >” during General Training – Ver 8
The “undo that” command after a phrase with a period highlights the wrong selection – Ver 8
Dragon generates errors when analyzing Corel WordPerfect 11 documents – Ver 8
C:\WINDOWS\speech\speech.dll is version 4.0.x.xxxx. NaturallySpeaking requires version 4.0.4.2512
“Page Down” command scrolls down too far in IE6
Commands and dictation stop working in Internet Explorer
Uncorrected text remains on the screen after making a correction – Ver 7/8/9
Enabling the Text-to-speech Engine
Word Corrections Land in Front of Instead of Replacing the Selected Text
NaturallySpeaking Rolls Back Install Near the End Of The Installation V9
NaturallySpeaking Won’t Launch in Windows XP (msvcr.dll is incorrect version)
NaturallySpeaking Needs to Reboot To Continue Installing (but fails to finish)
NaturallySpeaking Needs to Reboot To Continue Installing SP2/2 (but fails to finish)
NaturallySpeaking 7 Will Not Install on Windows 98 - Error # 0x80070725
NaturallySpeaking 7 Will Not Install on Windows XP - Error # 0x80070725
NaturallySpeaking 7 Will Not Install on Windows 2000/XP (and keeps prompting you to reboot)
NaturallySpeaking 7 Refuses to Install a Windows XP with SP2
NaturallySpeaking Will Not Start and Displays an Msvcr.dll Error
NaturallySpeaking 7 Will Not Install on Dual Processor System – (with more than 1 Gig of RAM)
NaturallySpeaking 7 Will Not Install on a Computer with More Than 2 Gb of RAM
Error: 0x80040707 Dll function call crashed: DD10SHRD.RgyCorrectCLSIDs
NaturallySpeaking Will Not Launch - Error # DMFC6.DLL
How to Create a Roaming User Profile
SDAPI or Internal Recognizer Error
Cisco Security Agent Prevents NaturallySpeaking from Running
Soundcard & Microphone Test
Change Default Font Style & Size
Eliminate Excess Bootup Programs
Preset to Open Any User Automatically - courtesy of Chuck Runquist
Swap File Settings (Virtual Memory)
Formatting Numbers
Eliminate Start Up Items
Copying User Files
How to Use Your Backup User Files
Correction Command Changing Instructions by Joel Gould
Recommended Changes for Word XP
What version/respin of NaturallySpeaking is this?
When User Files Go Bad
Installing NaturallySpeaking 5 on Windows XP
What to Do When You Lose Select-&-Say in WordPerfect
What to Do When You Lose Select-&-Say in Microsoft Word
What to Do When You Lose Select-&-Say in Outlook
How to Remove the Microsoft Speech Engine
How to Speed up Windows XP
How to Find Static IP Address
How to Manually Remove NaturallySpeaking and Taskbar Items
Skipping or Temporary Loss of Audio
Testing Your Soundcard
Double Letters in MS Word
How to Perform a Clean Install
Updating KnowBrainer 20xx
How to Boost the Soundcard Input Gain
How to Boost Sound Input from within NaturallySpeaking
Where Are My Commands and Options Stored
How to Eliminate the Extra Space Before the :/colon
How to Fix Window Focus Problem
How To Change/Edit NaturallySpeaking's Hardcoded Commands by Joel Gould
How to Delete Specially Marked Words From the Vocabulary Editor
How to Utilize Pre-existing Microsoft Word Macros
Microsoft Word Types □ When I Say “Paste That”
Loss of Select-&-Say in WordPerfect – Turn off Auto Hyphenate
How to 86 dra Files - Ver 7 & 8
Splitting Up Your Text Vocabulary
How To Prevent Initial Capitalization Lock on (Title Case)
How To Prevent Extra Spacing From Occurring In Front of Punctuation
Increasing HTML Elements in Internet Explorer
Altering NaturallySpeaking's Number Formatting Scheme
How to Add an Optional Command to bring up “Spell That”
Relocating Your User Files to a Thumb Drive
How to Turn on the Microphone of a Digital Recorder User File – Ver 9-12
Why Don't HeardWord Scripts Work
USB Pod Fails to Work Properly with Port Replicators
Can’t Find the Serial Number (Install Key)
What to do if the Acoustic Optimizer is Grayed out or if NaturallySpeaking Refuses to allow Windows to Exit (Tablet PCs) "0x5eddee78"
Jumping Cursor
Jumping Cursor problem in Outlook
Disappearing Cursor in Microsoft Word
Reverse Caps Problem When Dictating Over A Network (Remote Dictation)

Loss of IE 6 Command Capability

How to Dictate Curly Quotes (Smart Quotes) Instead of Straight Quotes

How to Dictate Superscripts 1, 2 & 3


SAPIDLL.DLL Does Not Register Itself Ver 7/8/9/10

How to Create Your Own Training Text by David P. & Joel Gould

Modifying the Default User File Location

Can't See All Of The Training Texts

Pdm.dll error

NaturallySpeaking Doesn't Capitalize the First Word after A Period

“dd10edit” Error

Error 75

NaturallySpeaking Refuses to Properly Format Currency

Philips Speech Mic Refuses to Turn on

NaturallySpeaking Won’t launch because Speech.dll Version 4.0.4.2128 is out of Date

How to Prevent “cASE rEVERSAL” in Terminal Services

Can’t Get Past the Audio Setup Wizard

Windows Restore Destroyed My User Files - switch to your backup user-files V11

NaturallySpeaking Crashes When Attempting to Use Internet Explorer

Adobe Acrobat 7 Crashes when DNS 8 is Open

CTSysVol.exe has encountered a problem and needs to close

NaturallySpeaking Slows to a Crawl in Long Documents

WordPerfect Select-&-Say Correction Is Several Characters Off

Adobe Acrobat crashes when NaturallySpeaking is running

Enabling Select-&-Say in a Citrix Client Environment (Pro 9 and higher only)

Transcribing Lectures

Hanging Results Box

NaturallySpeaking is unable to find the USB soundcard

Internet Explorer 7 or Windows Explorer Freezes

COM returned an unexpected error code: Details are E_FAIL

Data Collector Utility Closing with Errors

Commands are recognized by Dragon NaturallySpeaking but not executed

Where is the Dragon Log

My archive size box is greyed out

DNS Medical 9.52 Update Patch (For DNS Medical 9 ONLY)

Keyboard Shortcuts (hotkeys for Windows) http://www.keyxl.com/
When Waking from Hibernation I receive the following error: CloseDSXWarning_UttsPurged
RPC_E_DISCONNECTED
How to Copy Command Names from the NaturallySpeaking or KnowBrainer Command Browsers
How to Prevent the Wandering Results Box
SDAPI Error When Opening User Files
Sluggish Dictation in Remote Desktop Window
Single Hard Drive with Multiple Partitions
"Windows installer" stating "preparing to install" When DNS is Fully installed
How to Prevent a NaturallySpeaking Command from Accidentally Deploying
Why Does DNS Display “Restoring Speech Files” When I Switch Documents
Error 1935
Acquiring Senior Administration Rights in Windows Vista or Windows 7
DNS Advanced Scripting Commands Do Not Work Reliably over a Virtual Private Network (VPN)
Cursor Jumps to the Beginning of Outlook 2007 Messages with each new Utterance
How to Install DNS and on Multiple Languages
“Can't Run in Elevated Mode” error when attempting to launch DNS Ver. 9/10/11/12
DNS Will Run on a Mac Computer in Boot Camp but not Parallels or vice versa
This Application Requires Administrative Rights to Overwrite Some of the OLE Files error
Vista Soundcard Stops Working after running an Audio Check for another program like Live Messenger
Installing DNS 9.5 on Vista 64-bit (not endorsed or recommended by Nuance or KnowBrainer)
How Do You Stop DNS From Processing a very long utterance A Long Utterance
Error: DgnUseDll failed with the error code -1...wav.dll /mobile.dll /dd10shrd.dll” during installation
DNS Will Install - Error 1500 - Another Installation Is in Progress
Outlook Crashes When NaturallySpeaking Is Running
Text Appears in Yellow Results Box but Doesn't Always Transfer to My Document
Where is the System.dvc Master Command File - (contributed by Larry Allen)
Spell That Correction Box Makes Corrections but leaves the existing text in Microsoft Word
Slow Dictation in Thunderbird
How to Raise NaturallySpeaking’s Default 200 HTML Elements on a Web Page
When Saying Click Link DNS Inserts Little Useless Graphics Instead of Numbers
NaturallySpeaking Closes and Displays a Run Time Error When You Click the Microphone
Vanishing Text in Word 2007 during dictation and correcting
Available DNS Languages
Formatting Numbers (contributed by Chuck Runquist)
Dragon Medical 10 Insists on Substituting “disfunction” for “dysfunction”
Server Busy Error
How to Eliminate the Extra Space at the Beginning of an Excel Cell
DNS Crashes Every Few Minutes
DNS Types Dysfunction as Disfunction and Dysphagia as Disphagia – Medical 10 (Only)
Internet Explorer Doesn’t Display Proper Arrows and Icons
How to Prevent the “You Have Reached the Maximum Amount of Speech Data” - Standard 10 (Only)
Every Time I Launch NaturallySpeaking It am Prompted to Finish the Installation – Ver. 9/10
NaturallySpeaking Crashes When Using Spell That correction
DNS Ignores the Cap <next word> command
NaturallySpeaking Will Not Allow Importing Personal Commands into an Older Version of DNS
NaturallySpeaking 9.5 Does Not Permit Dictation in Microsoft Outlook Web Access
Olympus DSS Player Software Doesn't Work Well on a Mac Computer
NaturallySpeaking Won't Run in Lotus Notes
Why Doesn't NaturallySpeaking Work in All Applications ~ courtesy of Chuck Runquist
NaturallySpeaking Pastes the Contents of the Clipboard Twice
Low System Resources
How to Enable Full Text Control in Jarte
Philips SpeechMike Programmable Buttons Failed to Work
Before Calling Technical Support

Most NaturallySpeaking problems can be solved by 1 of the following 5 options. Make sure that you first exit NaturallySpeaking. The options are listed in order of preference:

Option #1
Reboot your computer

Option #2
1. Double-click on Add/Remove Programs in the Control Panel
2. Double-click on the Change/Remove button of Dragon NaturallySpeaking 10
3. When the Installation software launches choose Repair

Option #3
Repeat Option #2 but select Uninstall NaturallySpeaking instead of Repair (preserve your user files). After you uninstall NaturallySpeaking, reboot your computer, reinstall NaturallySpeaking and reboot again.

Option #4
Use your backup user files
1. Make sure Dragon isn't running
2. Rename your current folder, which is located at ~C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking1x\Users\(Your User Name)\current to "old" in Windows XP. The Windows Vista or Windows 7/10 address is ~C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username)\current
3. Launch Dragon

Note: You will not be able to locate the Application Data folder if your computer is set to the default manufacturer settings which are to hide hidden files and folders. In order to view your hidden files in Windows Vista/7, open any folder or Windows Explorer, select Folder Options from the Tools menu, click the View tab, click on "Show hidden files and folders" and press the OK button. If you’re using Windows 8, open any File Explorer folder, click the View menu, click Options, click the View, check "Show hidden files and folders" and press the OK button

Option #5
Create a new user

Option #6
Radical Procedure
1. Copy your user files, via Windows Explorer/File Explorer, to your desktop so that you can easily locate them later. Your user files are located at ~C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking15\Users\(Your User Name)\ in Windows XP. The Windows Vista or Windows 7/8/10 address is ~C:\ProgramData\Nuance\NaturallySpeaking15\Users\(Your User Name)\.

2. Do a complete uninstall of NaturallySpeaking. When prompted to save your user files say "No" to uninstall everything.


4. Reinstall NaturallySpeaking

5. Use Windows Explorer to move your previously copied "old user files" from the desktop to C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\ in Windows XP. The Windows Vista or Windows 7/8/9 address is ~C:\ProgramData\Nuance\NaturallySpeaking13\Users\.

   Note: If you do not receive the message asking you to verify that you are copying one folder over the top of another then you have copied your folder to the wrong address.

If the previous 6 Options fail then you may need to contact KnowBrainer Tech Support at 615-884-4558. Our technical support hours are Monday through Friday at 10 a.m. to 5 p.m. Central Standard Time.

NaturallySpeaking Splash Screen Freezes

Problem:
Dragon NaturallySpeaking fails to launch or takes an unusually long time to launch with the splash screen typically freezing for about 10 minutes.

Cause:
This temporary problem is being caused by a communications issue with a recent change made to the Nuance update service.

Pre-Solution:
To manually stop the Update Service Agent:

1. Open the Windows Task Manager by right-clicking on the Windows Toolbar at the bottom of the screen and selecting "Start Task Manager".
2. Navigate to the "Processes" tab.
3. Locate "agent.exe" under the Image Name heading.
4. Select "agent.exe" and click "End Process".
5. Launch the Nuance Desktop application.

Permanent Solution (until Nuance fixes the Update Service):
Disable Check for Updates in Dragon NaturallySpeaking:

1. Close your user profile (not NaturallySpeaking) by clicking Profile/Close User Profile
2. Click "Tools > Administrative Settings".
   - Note: Windows administrator rights are required to access the Administrative Settings dialog.
3. Navigate to the "Miscellaneous" tab.
4. Disable the "Check for product updates at startup" option.
5. Click "OK" to apply the changes.

**Computer Recommendations**

The following recommendations should only be considered as a starting off point. You will find additional detailed computer information on the KnowBrainer [Computer Forum](http://www.mtechlaptops.com):

We do not currently recommend AMD processors because they are lagging too far behind Intel.

We recommend Windows 7/8.1 64-bit and minimally 8 Gb of RAM. We prefer Intel-based quad core i7 or i5 Haswell (4th generation) or Ivy Bridge (3rd generation) processors and if this is a new computer, we recommend 16 Gb of RAM for upcoming technology. New computer RAM is relatively inexpensive. The actual speed of the processor is not important but the amount of cache plays a significant role. Our favorite computer company is M-Tech [http://www.mtechlaptops.com](http://www.mtechlaptops.com). If an i7 isn't in the budget an i5 quad core will do but we do not recommend an i3 or dual cores.

If there is a little extra money in the budget, we additionally recommend a 256 Gb or higher solid-state hard drive for improved performance and durability.

Note that DNS Ver. 10 will not run on Windows 8 and you may experience some issues with Ver. 11. Only Ver. 12.5 and higher are completely Windows 8.1 compatible.

If you are planning on installing Ver. 10/11/12 on an older computer make certain that your computer supports SSE2 instructions. NaturallySpeaking 10/11/12 requires that the processor support SSE2 in order to run properly. To determine whether or not your computer supports SSE2 click [http://cpuid.com/cpuz.php](http://cpuid.com/cpuz.php). You will also need to install SP 3 if you are using Windows XP. Note that Dragon 13 and DMPE 3 require Windows 7 or higher. Windows XP is no longer supported.

**How to Fix USB Microphone Not Working after Installing Windows 10 1803 Update**

1. Press Windows Key and type **settings**
2. Click **Settings** (top of the screen) to open Windows Settings
3. Click the **Privacy** icon
4. Click **Microphone** (on the left side)
5. Toggle **Let apps use my microphone** to the **On** position
How to Remedy Substandard Dragon 15 Accuracy

End-users with non-mid continental North American English accents may not immediately achieve acceptable Dragon 15 accuracy. Nuance has completely eliminated the ability to train Dragon. Fortunately there is a workaround.

1. If you are using KnowBrainer 2017, say Data Options. If you are not using KnowBrainer 2017, click the Dragonbar Tools/Options/Data tab and change Save recorded dictation with document from NEVER to ALWAYS. Nuance default setting is ALWAYS but we typically recommend choosing NEVER to prevent Dragon from wasting hard drive space. See following:

2. Open Microsoft Word and minimally dictate 100 lines of text. We recommend reading your dictation from other documents, in your writing style, to ensure smooth dictation rather than dictating off the top of your head (stuttered dictation).

3. Save your Microsoft Word document (which will also include an embedded Dragon .dra recording)

4. If you are using KnowBrainer 2017, say Launch Accuracy Tuning. If you are not using KnowBrainer, click the DragonBar/Audio/Launch Accuracy Tuning menu as follows:

5. Click the following Start button:
Note: Once you are satisfied with Dragon’s accuracy, you might consider changing the Dragon Data options Save recorded dictation with document from ALWAYS back to NEVER to conserve disk space.

How to Enable Automatic punctuation in DMPE 4

Add PunctuationGuesserOn=1 (on a separate line) to enable automatic punctuation (commas and periods) in the C:\ProgramData\Nuance\NaturallySpeaking15\Users\Medical\current\options.ini file. This can be particularly helpful when transcribing digital recordings.

How to Install a Dragon Patch

If, when launching Dragon, you are prompted to install a patch or update, we recommend the following steps:

1. Download the patch to a location you can easily find, such as your desktop.
2. Reboot Windows. Under no circumstances should you try installing the patch without rebooting.
3. After rebooting Windows, make certain that Dragon isn’t launching in QuickStart mode. You will need to open the Task Manager to the Processes tab and verify that natspeak.exe isn’t running. If it is running, select it and click the End Process button.
4. Install the patch and launch Dragon (you should not need to reboot).

Note: If you make the mistake of attempting to install a patch while Dragon is running, even if you think you have closed Dragon without rebooting, you may wind up corrupting the entire installation. If you find yourself in this situation you may need to reinstall Dragon from your original disk. If the reinstallation fails, you will have to run DNS13 Remover, DNS12 Remover, DNS11 Remover or DNS10.1 Remover depending on which version of Dragon you are using. Note that the Remover utility removes every piece of Dragon from your computer including the registry and your ~ C:\ProgramData\Nuance\NaturallySpeaking\[your username] folder. If you wish to preserve your user profiles, move them to a safe location like your desktop but note that you won’t be able to view your user profile folder unless you change Windows default settings to view Hidden Files. You will find a step-by-step, on this process, under the previous hyperlink. If you find this process to be a bit exasperating, you can optionally purchase a full copy $20 Backup DVD of the latest version of Dragon.

How to Change Dragon Wakeup Commands
Begin by opening the C:\ProgramData\Nuance\NaturallySpeaking15\Data\Enx\dvcu\general\system.dvc file. You might consider making a backup copy 1st but if you are unfamiliar with editing the system.dvc file, consider consulting with a Dragon professional. Note that the new commands will not become functional until you relaunch Dragon. If you are using a different version of Dragon such as Ver. 12 or 13, simply change the address. For example the DMPE 2.2 address is C:\ProgramData\Nuance\NaturallySpeaking12\Data\Enx\dvcu\general\.

Note: The previous procedure works in Dragon Professional 10 - 13, DPG and DLG but requires a 2nd step in DPI 15/15 and DLI 15/15. You will additionally have to open the C:\ProgramData\Nuance\NaturallySpeaking15\nssystem.ini file in NotePad and change Enx Base DVC Directory=dvce to Enx Base DVC Directory=dvcu. You won’t be able to save your changes to the nssystem.ini file unless you run NotePad in Administrator mode reboot Windows (before starting Dragon) or install TakeOwnership which we recommend installing because it will give you administrator rights over any folder by right clicking on the folder and selecting Take Ownership to take back your rights.

How to Prevent Dragon 15 From Automatically Saving Your Profile When Exiting

6. Open the C:\ProgramData\Nuance\NaturallySpeaking15\Users\(Your User Name)\current\Options.ini file
7. Place your cursor at the end of the 1st line which says [Options]
8. Press {Enter} to create a new line and type Automatically Save Speech Files On Shutdown=0 and save and close the Options.ini file.

How to Disable Microphone Auto-gain ~ DMPE 4, DPG 15 and DLG 15

1. Click the DragonBar Settings/Choose Microphone menu
2. Remove the default checkmark from Automatically adjust the microphone level as I speak
3. Click Settings/Check Microphone and follow the remaining prompts to manually adjust your volume input settings

How to Disable Microphone Auto Gain ~ DPI 15 (only)

1. Open the C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username)\current\options.ini file
2. Add the following text on a separate line, below [Options]
3. Enable Automatic Gain Control=0 and save your changes

How to prevent Dragon from opening Word docs

Problem:

Protected MS Word documents may refuse to open when running Dragon

Solution:
Turn off Protected View by going through Trust Center > Trust Center Settings > Protected View Settings and uncheck everything:

**Dictation Box Fails to Paste Text Into Remote Applications**

This problem is caused sluggish networks not being able to keep up with Dragon pasting the text. The solution is to slow the transfer of text via the following 3 steps:

Ver. 13

1. Open the Dictation Box
2. Click Settings
3. Check Simulate keystrokes and click OK
4. Say Click Transfer to transfer your text from the Dictation Box

**DMPE**

1. Open the DragonBar Tools/Options and click the Dictation Box tab
2. Check Simulate keystrokes and click OK
3. Say Click Transfer Text to transfer your text from the Dictation Box

**Dragon Drops Letters When Dictating over a Citrix Network**

**Problem:**
Dragon drops letters when dictating over a Citrix network

**Solution:**
Begin by running the [Citrix Receiver clean-up remover tool](#) to clean up your system. The key issue to get functionality with Dragon use is to have the Program Neighborhood Agent (PNA) included. The Citrix Receiver 4.2 (15.2.0.10) does not have this and does not play well with Dragon. However, the Citrix Receiver for Windows 3.4 Cumulative Update 4 includes the PNA, and was released December 12, 2015. Upon downloading and extracting, two applications are presented, the CitrixReceiver and the CitrixReceiverEnterprise. Note that this is a zip file that should be extracted to your desktop.

**Dragon NaturallySpeaking Setup Requires Elevation**

**In Windows 10:**

1. Press Windows Start Key
2. Click Search (magnifying glass)
3. Type UAC into the Search field and press {Enter}
4. Click Settings
5. Click Change User Account control settings
6. Move the Slider all the way down to Never notify.
7. Click Yes to allow the change. You will not have to reboot
   Note: If you received this error during the Dragon installation process (after disabling the UAC) and Dragon refuses to install, browse the Dragon DVD and double-click setup.exe rather than NaturallySpeaking12/13/15.msi to install.

In Windows 8:
9. Hover the mouse over the bottom right corner of the screen
10. Click Search (magnifying glass)
11. Type UAC
12. Click Settings
13. Click Change User Account control settings
6. Move the Slider all the way down to Never notify.
7. Click Yes to allow the change. You will not have to reboot
   Note: If you received this error during the Dragon installation process (after disabling the UAC) and Dragon refuses to install, browse the Dragon DVD and double-click setup.exe rather than NaturallySpeaking12/13/15.msi to install.

In Windows 7:
1. Click the Start button (Windows logo)
2. Type UAC and Press {Enter}
3. Move the Slider all the way down to Never notify.
4. Follow the Prompt to Reboot Windows before installing Dragon or KnowBrainer

Error 166, 168 and 174

This error, most commonly 166, refers to a corrupted user profile. You will need to switch to your backup user profile. See Switching to Backup User Files for additional details on this process.

How To Disable Smartphone Support

Option #1:
Go to the following location: C:\Program Files (x86)\Nuance\NaturallySpeaking13\Program\ and locate the following three files:

dnsspserver.exe.config
dnsspserver.exe
dnsspsregister.exe

And rename them as follows (my preference but you can do it anyway you want. I just do it to keep from losing track of the filenames).

dnsspsserver_old.exe.config
dnsspsserver_old.exe
dnsspsregister_old.exe

Option #2:
1. Open C:Users[Windows username]AppDataRoaming\Nuance\NaturallySpeaking1x\nsuser.ini
2. Smartphone Server Launch=0 should be typed at the end of the [Settings] list
How to Reenable the Dragon Firefox Browser Extension

Click FireFox Extension

Problems with Dictating into Care360, eClinicalWorks and other EMRs

Go to the DragonBar Tools/Options/Commands tab and remove the checkmark from Enable HTML support

With eCW you may need to rerun cwreg.bat or contact eCW support

How to Make the Dictation Box Open Automatically in Non-Fulltext Control Applications (when you speak)

Dragon 12/13:
Click Tools/Options/Miscellaneous (tab) and put a checkmark in Use Dictation Box for unsupported applications. Note that in Ver. 13/14/15, checkmark is the default setting.

DMPE 2.3:
Click Tools/Options/Dictation Box (tab) and put a checkmark in Anchor Dictation Box to application

Every Time I Launch Dragon I Am Prompted to Activate Again

Reenable Windows WMI and don’t deactivate it again.

How to prevent the Google Chrome black screen

1. Press Alt+f or mouse click the upper right menu to open the Google Chrome menu.
2. Click Settings
3. Click Show advanced settings link at the bottom of the page
4. Remove the checkmark for Use hardware acceleration when available (near bottom of page).
5. Restart Chrome

Prevent Windows 10 from Losing USB Connections

In Control Panel, go to power options and uncheck "turn on fast start up"

Also, In control panel, go to device manager, and then to USB controllers. Right-click on USB hubs, click on properties, then click on power management and uncheck "allow computer to turn off this device to save power. Do this for each USB help.
Enabling Dictation in Thunderbird

1. Open Thunderbird
2. In Dragon 13, open C:\ProgramData\Nuance\NaturallySpeaking1x\nsapps.ini
3. You should see the following entry near the end of the file
   [thunderbird]
   Key Delay=3
4. Change Key Delay=3 to Key Delay=0 as follows and save your changes. If you don’t see the following entry add it to the end of the file.
   [thunderbird]
   Key Delay=0

How to Prevent Nuance Pop-up Advertising

1. Close your Dragon Profile
2. Click the Dragonbar Tools/Administrative Settings menu
3. Remove the checkmark from Automatically check for updates on Windows start

How to Change the Ver. 13 Blue Microphone to Yellow ~ Lindsay Adams

The following steps will allow you to return the Dragon microphone icon coloration and behavior to the previous versions of Dragon which are better in this regard. Instead of a blue icon you will now see a yellow icon.
1. Completely closed Dragon NaturallySpeaking.
2. Rename the file in the following folder: "C:\Program Files (x86)\Nuance\NaturallySpeaking13\Program\dd10renx.dll" To something like "dd10renx_orig.dll"
3. Then copy dd10renx (after unzipping of course) to the same folder above and restart Dragon.

You should have an orange microphone icon for sleeping again instead of blue.

Microsoft Word/Outlook/Excel Will Not Permanently Allow the Dragon Add-In

Problem:
You followed the step-by-step on enabling the Dragon add-in for Microsoft Word, Outlook or Excel, when you looked up “What to Do When You Lose Select-&-Say” (here in this document) but when you reopen Microsoft Word, Outlook or Excel, the Dragon add-in was disabled.

Solution #1:
Right click on a Microsoft Word shortcut and choose “Run as Administrator”. When you reenable the add-in, as you did previously, it should become permanent.

Solution #2:
Perform a Repair of Dragon 14/15. If you do not have an option to Prepare Dragon, simply reinstall and when prompted, choose Repair.

Solution #3:
Disable the UAC. You will find this process outlined if you look up “UAC”.

Solution #4 (Courtesy of Stephan Kuepper):
This registry setting determines how the add-in is loaded in the application.

Caution should be exercised when modifying a computer’s registry. A backup of the registry should be made prior to modification. Only qualified personnel should modify the registry settings.

1. Open the registry editor. (To do this, open your Windows Start menu and type "regedit").
2. There are two (2) registry locations to check (individual Windows user and computer overall):

   [Computer]
   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\Dragon.Word2000Support.1
   "LoadBehavior"=dword:0000000N

   [User]
   HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\Dragon.Word2000Support.1
   "LoadBehavior"=dword:0000000N

   **Note:** The User setting overrides the Computer setting. Meaning, if the Computer setting is disabled, but the User setting is enabled, then the add-in will be loaded.

   The “LoadBehavior” values can be 0, 1, 2, 3, etc.
   ·   =dword:00000002   (Disabled)
   ·   =dword:00000003   (Enabled)

   ![Registry Editor](image)

   Note what the "LoadBehavior" is set to. If the LoadBehavior is anything other than "3", follow the steps below.

3. Close Word and verify the "winword.exe" process is not running in the Windows Task Manager.
4. Open the registry editor again. Double-click the same registry key to edit it.
5. Change the Load Behavior to "3" and close the registry editor.
6. Re-open the registry editor to ensure "3" is still there.
7. Open Microsoft Word.

How to Delete a Dictation Source

To delete a dictation source in Dragon 13/15, locate your user profile in Windows Explorer (Windows 7)/File Explorer (Windows 10). This is typically in C:\ProgramData\Nuance\NaturallySpeaking15\Users\[your user name]. Open the folder “current”. You will find several pairs of folders, typically called 2_1, 2_1_container; 2_2, 2_2_container. Other numbers are possible. Each pair corresponds to one dictation source. To find out which one, open the file 2_x_container\aoptions.ini, where the source is listed by its friendly name, e.g. Philips SpeechMike III. To delete a source, simply delete the corresponding pair of folders.
Note that you will also have to delete all references of any deleted dictation source from the accompanying aco.ini, acoustic.ini and options.ini files (in the same folder). Delete any folder that begins with “tb”

How to Reenable Launching Start Menu and Desktop Applications/Files/Folders

1. Open C:\Users\YOUR WINDOWS USER\NAME\AppData\Roaming\Nuance\NaturallySpeaking15\nsuser.ini file in WordPad or NotePad. If you are using the latest release of KnowBrainer Professional 2017, you can optionally say Open NS User.
2. Look for the following entry

   [.Global\Compatibility Module Status]
   Global Dictation=0

   You need to change this to Global Dictation=1 (just change the 0 (which means off) to 1 (which means on). Note that you can do this while Dragon is running and you won’t even need to relaunch Dragon.

Solution #2:
If solution #1 fails, reinstall or perform a Repair of Dragon

User Profile Cannot Be Opened Because You Lack Sufficient Windows Privileges

Problem:
When attempting to open your user profile you may be presented with a message to the effect of “the user profile cannot be accessed. This could be because you do not have sufficient privileges to use it or because it is currently being accessed by another program”

Solution #A:
1. Begin by rebooting Windows to ensure that Windows isn’t the culprit. If that doesn’t solve the problem, follow the remaining steps.

2. Use Windows Explorer to open your user profile directory which is ~C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username). Note that you will not be able to view this folder unless you change Windows default settings to show hidden files and folders.

3. Right click on your username and select Properties

4. Click the Security tab and make certain that you have a checkmark in Full control under the Permissions for Users.

Solution #B: If Solution A fails, move your user profile to the desktop where you always have full Windows rights. When you go to open your user profile, remember to browse to the desktop.

Solution #C (our new favorite): Click Take Ownership to take back your Windows rights with a free How-To Geek hack. You will find step-by-step instructions on the previous website but after you download the zip file, double-click InstallTakeOwnership.reg to install. The next time Dragon can’t open your user profile, simply right-click on your C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username) folder and choose the Take Ownership menu.
Dragon InstallShield Fails (resulting in failure to install Dragon)

Dragon has a couple of requirements that do not always install on their own. Fortunately, you can manually install them as follows:

1. Browse the Dragon DVD to the ISSetupPrerequisites folder
2. Open both dotNetFramework.exe and MSXML 4.0 SP2.exe folders and double click to install both utilities.

How to Launch Dragon Automatically When Starting Windows

Windows 8

1. You will need to begin by putting a check mark in File Explorer Show hidden files, folders and drives. If you haven’t already done this, you will find a step-by-step when you perform a search for “Hidden files” within this document.
2. If you are using KnowBrainer 2016 or VoicePower, place a shortcut to KnowBrainer or VoicePower in the C:\Users\(your computer name)\AppData\Roaming\Microsoft\Windows\Startmenu\Programs\Startup folder. If you are now using KnowBrainer 2016 or VoicePower, copy the Dragon desktop short cut to the Startup folder. If there is already a shortcut to Dragon in the Startup folder, it may be from putting a checkmark in Launch Dragon in QuickStart mode. Delete the existing shortcut (which doesn’t completely launch Dragon) and replace it with your new shortcut. Do not put the NaturallySpeaking shortcut in the Startup folder if you already have a shortcut to KnowBrainer or VoicePower.

Windows Vista/7/10

1. You will need to begin by putting a check mark in Windows Explorer Show hidden files, folders and drives. If you haven’t already done this, you will find a step-by-step when you perform a search for “Hidden files” within this document.
2. If you are using KnowBrainer 2016 or VoicePower, place a shortcut to KnowBrainer or VoicePower in Windows Startup folder. By clicking the Windows Start button, All Programs, Right-click Startup and select Open. If you are now using KnowBrainer 2016 or VoicePower, copy the Dragon desktop short cut to the Startup folder. If there is already a shortcut to Dragon in the Startup folder, it may be from putting a checkmark in Launch Dragon in QuickStart mode. Delete the existing shortcut (which doesn’t completely launch Dragon) and replace it with your new shortcut. Do not put the NaturallySpeaking shortcut in the Startup folder if you already have a shortcut to KnowBrainer or VoicePower.

KnowBrainer Configuration Error (KnowBrainer fails to launch)
KnowBrainer 2016/2017 fails to launch and produces the following error:

1. Close KnowBrainer Professional (uninstalling is optional)
2. Delete the `C:\Users\YOUR WINDOWS USER NAME\AppData\Local\KnowBrainer` folder
3. Restart KnowBrainer Professional which will require you to go through the original prompts (choose your favorite skin and whether or not to import your previous commands).

PowerMic II tab not recognized in Dragon Medical Practice

Solution: Create a new sound source to an existing user or create a new user and choose PowerMic II instead of USB microphone, when prompted to choose a sound system.

How to Prevent Antivirus and Anti-Malware Utilities from Blocking Dragon And Other Applications

Certain anti-malware and antivirus utilities, like McAfee, are known to block Dragon and other applications. Most antivirus and anti-malware utilities include a Setting menu. When you open the Setting menu, you should see a Exclusions menu where you will find the option to add a file or folder to the your utilities Exclusion settings. For example, if you’re using McAfee, you will probably need to exclude the entire `C:\Program Files (x86)\Nuance` and `C:\Program Files (x86)\KnowBrainer` folders.
Error 154

Typically occurs when the Roaming master profile is corrupted

1. Restore your user profile as a standard profile
2. Rename the profile
3. Reopen the profile as a Roaming profile

Grammarly Add-in is not Dragon compatible

If you are using Microsoft Outlook or Microsoft Word with the Grammarly Add-in, Outlook is known to crash when running Dragon because the 2 utilities are incompatible. Fortunately you can disable and reactivate Grammarly at the push of a button and it will need to be disabled when using Dragon.

Dragon 14-15 Modern Toolbar Goes AOL

The Dragon 14+ modern toolbar may occasionally disappear in Windows 7. This solution is not verified but we believe it is because Windows 7 includes .Net Framework 5 while Windows 10 includes .Net Framework 6 which we believe is required by the DragonBar. We recommend downloading and installing (upgrading) .Net Framework 6 on Windows 7 computers.

Microsoft Word Dictation Appearing As Red Formatted Green Highlighted Italicized Text

When your Microsoft Word dictation looks something like the previous text, you are dictating Dragon’s “Voice Notation” mode. A Voice Notation would be additional information you might want to temporarily add to a document. Voice Notations can be added by holding down the {Esc} Key as you dictate. Pressing the {Esc} Key will also toggle you out of Voice Notation mode. You can optionally delete Voice Notations by using Microsoft Words Except/Reject change functionality feature. To change how Microsoft Word displays Voice Notations, click Microsoft Word’s Review menu followed by clicking Except or Reject.

How to Prevent Microsoft Word from Selecting Unwanted Spaces When Selecting Text (by Larry Allen)

Turn off Microsoft Words “smart cut and paste option” which can be found under the Options/Advanced menu.

What to Do When Dragon Won’t Launch a Start Menu Application

Open Windows Control Panel, click Indexing Options, click Advanced and click the Rebuild button.
DMPE Medical Abbreviations like PRN (P.R.N.) appear as “when necessary”

1. Click on the DragonBar Tools/Auto-Formatting Options/Miscellaneous Tab. Removing the checkmark from Expand Dosage Abbreviations will give you p.r.n.
2. If you wish to eliminate the periods, add a checkmark and Remove periods from dosage abbreviations.

How to Prevent DNS 12 from Prompting You to Perform needed User Profile Maintenance

1. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\nssystem.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking12\nssystem.ini in Windows Vista or Windows 7/8/10
2. Create a blank line below the [Settings] section of the nssystem file.
3. Add the following 2 lines of code on 2 separate lines

```
enx EncourageRunningLMOonSaveInDays=0
enx EncourageRunningLMOreminderInDays=365
```

The following recommendation comes from Adobe but has not been tested so use with caution:

Adobe recommends disabling Protected Mode until a fix comes out that is resolving the issue. The company highlights that it highly recommends to enable Protected Mode again once the troubleshooting is complete.

To disable Protected Mode you need to edit the mms.cfg file located in one of the two directories:

Windows 32bit: C:\windows\system32\macromed\flash
Windows 64bit: C:\windows\syswow64\macromed\flash

Just open the file with a text editor and add the following line to the mms.cfg file:

```
ProtectedMode = 0
```

If the file does not exist, create it first. You can alternatively download a version from the blog post linked above. To enable Protected Mode again simply delete the line that you have added to the config file.

There are other options besides disabling Protected Mode in Adobe's Flash Player. You can for one disable Flash completely which will work as well. What you should not do however is to go back to a previous version of Flash as it is insecure and likely to be exploited in the near future.

Additional information can be found at http://www.ghacks.net/2012/06/10/flash-player-update-fix-freezes-crashes-in-firefox/
Browser Error - Too Many Links on Page

Problem: Dragon is limited to numbering up to 50 hyperlinks, buttons and controls. If you have more than 50 hyperlinks, you will receive an error message to the effect of “too many links on page”.

Solution:

1. Open Windows Explorer.
2. Use Notepad to open C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username) current\options.ini file.
3. Move your cursor to the end of the file and create a new line
4. Type Number Of Enumerated Html Elements=500
5. Save and close file. Relaunch Dragon and note that you can increase 500 if necessary.

How to Make Dragon Open Any Folder, Application, File or Utility

If you only need to open a few files, programs, applications etc., simply create a shortcut on your desktop. Note that you will probably want to remove “shortcut to” or anything you don’t want to say because in order to open these applications/files, you will need to say Open, Start or Launch <name>. For example, if you would like the convenience of being able to open your Microsoft Word letterhead by saying Open Letterhead or Start Letterhead, place a shortcut to your letterhead on your desktop. Make sure that you don’t have Windows set in the non-default option of displaying extensions like .docx and remember to delete any unnecessary words because you must say the entire name of the shortcut in order to launch it. If you may find your Windows desktop getting too cluttered or you simply have too many shortcuts, you can clean up your desktop by moving shortcuts, that you would like to launch my voice, to the C:\ProgramData\Microsoft\Windows\Start Menu\Programs\ folder. Another option would be to create Advanced-Scripting command in Dragon Professional or edit the existing KnowBrainer 2016 Open <files> command.

KnowBrainer 2016 Produces Microsoft .NET Framework Unhandled exception error

KnowBrainer 2016 must be installed on the operating system drive, typically Drive C.

How to Prevent Deployment of the Post to Twitter and Facebook commands – Contributed by Lindsay Adams

1. How to turn off the “Post to Twitter” and “Tweet <anything>” voice commands with NaturallySpeaking 11.5

Go to the following location with Vista and Windows 7:
C:\ProgramData\Nuance\NaturallySpeaking11\Data\enx\Dat

And with XP:
c: \Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Data\enx\Data

Rename the file dragonbarisnctwittergrammar.dat to dragonbarisnctwittergrammar_old.dat

2. **You can turn off the Facebook commands**, e.g. “Post to Facebook”, by renaming the file:

   dragonbarisncgrammar.dat to
dragonbarisncgrammar_old.dat

Then reload DNS user profile.

You will need to change the name of the language folder above for other languages than English, enx (English), deu (German) etc.

This is not an official Nuance technical note but just a hack to get round the problem if it annoys you as much as it annoys me.

Finally you will probably now get the following line in your Dragon log:

23:17:30 Error: Failed to load Intuitive Twitter Commands Grammar

or

23:17:30 Error: Failed to load intuitive Facebook Command Grammar

This is normal, don’t worry.

**Latency Issues**

If you experience unusually long delays in your dictation landing in your document or during correction, try moving the **Pause required before commands** under the Commands Tab of your DNS Options to the third notch as follows:

![Options](image)

NaturallySpeaking appears to be running Windows compatibility mode message appears when launching

**Problem:**

After starting **Dragon** NaturallySpeaking, the following message appears:
"NaturallySpeaking appears to be running Windows compatibility mode, which may result in errors. We recommend disabling Compatibility Mode for the natspeak.exe program."

Option #1

1. Right click on the Dragon NaturallySpeaking icon on the Windows Desktop and select “Properties.”
2. Click on the “Compatibility” tab.
3. Remove the checkmark for “Run this program in compatibility mode for”
4. Click “OK.” Note that you will need to make this change to any Dragon shortcut.

Option #2

IMPORTANT: This article contains information about editing the registry. Before editing the registry, make sure you understand how to restore it if a problem occurs. Follow the steps below to back up the registry:

1. Open the Registry Editor by clicking "Start button, type "regedit" without the quotes and click "OK".
2. Export a backup copy of the Registry in case problems occur during the following procedures by clicking "File > Export".
3. Save this file to the Windows Desktop and name the file "backup". (Keep "backup" for a few days and if all is well, this file can be deleted.)

Modify the following registry key to launch Dragon NaturallySpeaking:

1. Open the Registry Editor by clicking "Start > Run". Type in "regedit" without the quotes and click "OK".
2. Navigate to the following registry keys:
   - Windows XP or Vista
     - HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
     - HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
   - Windows 7
     - HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Windows\CurrentVersion\AppCompatFlags\Compatibility Assistant\
3. In the left panel, right click on "Layers" and select "Delete".
4. Close the Registry Editor.
5. Restart Dragon NaturallySpeaking.

How Do I Stop My Voice From Coming Through My Headset Speakers

1. Right Mouse click on the little white speaker icon in the Windows Taskbar
2. Select Recording Devices
3. Left Mouse click on your speech recognition microphone/soundcard icon
4. Left Mouse click on the Properties button
5. Left Mouse click on the Listen tab
6. Remove the checkmark from Listen to this device and click OK

How Do Get AM/PM vs. am/pm

Dragon receives its date and time formatting settings from Windows Language settings. You can edit the settings by opening Windows Control Panel and clicking on Region and Language. Note that if you’re using KnowBrainer 2017, you can simply say Start Region. The Additional date, time, & regional settings will allow you to edit date and time settings.

Error 1606: Unable to locate network location

Problem:

During the installation of Dragon NaturallySpeaking 11, the following error appears:

Error 1606: Unable to locate network location. 'C:\Program Files\Microsoft Office\Office'

Cause:

This issue occurs when an older version of Microsoft Office is or was previously installed on the computer.

Solution:

IMPORTANT: This article contains information about editing the registry. Before editing the registry, make sure you understand how to restore it if a problem occurs. Follow the steps below to back up the registry:

1. Open the Registry Editor by clicking "Start > Run". Type in "regedit" without the quotes and click "OK".
2. Export a backup copy of the Registry in case problems occur during the following procedures by clicking "File > Export".
3. Save this file to the Windows Desktop and name the file "backup". (Keep "backup" for a few days and if all is well, this file can be deleted.)

Part 1: Installing Dragon NaturallySpeaking 11

Modify the following registry key to complete the installation of Dragon.

1. Open the Registry Editor by clicking "Start > Run". Type in "regedit" without the quotes and click "OK".
2. Navigate to the following registry key:
   • HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0 (32-bit)
   • HKEY_LOCAL_MACHINE\Software\WOW6432NODE\Microsoft\Office\8.0 (64-bit)
3. Right-click on the "8.0" key and select "Rename", then rename it to "8.0_".
4. Close the Registry Editor.
5. Install Dragon NaturallySpeaking 11.

Part 2: Restoring Access to older version of Microsoft Office

Modify the following registry key to reverse the operation.

1. After the installation completes, open the Registry Editor again.
2. Navigate to the following registry key:
   • HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0_ (32-bit)
   • HKEY_LOCAL_MACHINE\Software\WOW6432NODE\Microsoft\Office\8.0_ (64-bit)
3. Right-click on the "8.0_" key and select "Rename", and rename it to "8.0".
4. Close the Registry Editor.

Note: If the error re-appears during a repair or reinstall Dragon NaturallySpeaking 11, please follow the steps in part 1.

NaturallySpeaking Installation Error 1722

Problem: Windows Installer Error

Solution:
1. Click on the Windows Start Menu, then open the Control Panel.
2. Click “Classic View”.
4. On the “System Properties” dialog box, click on the “Advanced” tab.
5. Click the "Settings" button in the "Performance" section.
6. Click the "Data Execution Prevention" tab.
7. Click on "Turn on DEP for essential Windows programs and services only".
8. Click "OK" to apply the changes, then reboot the system.
9. Install Dragon NaturallySpeaking.

**RPC_S_Server_Unavailable, 1722**

The RPC Server is a Windows component responsible for communication between applications. An example of this error is 1722 which might display if Microsoft Word crashes and NaturallySpeaking is still attempting to communicate with it. If anything prevents NaturallySpeaking from communicating with an application such as an application crash, utility or Windows malfunction, you may experience error 1722. Unfortunately there are a numerous reasons for this error which include a corrupted Windows installation. If the problem doesn't occur more than once a week, we recommend ignoring it.

**MSXML Installation Error**

**Problem:**

Dragon refuses to install by producing an MSXML error.

**Solution:**

Navigate to the \ISSetupPrerequisites folder on your Dragon installation disk where you will see 2 additional folders within the ISSetupPrerequisites folder, which are:

**MSXML4.0 SP2**

**dotNetFramework**

Open each of these folders and run both the dotNetFx40_Full_x86_x64.exe the msxml4.msi files that are contained within them. Both of these files are Prerequisites that need to be installed on your system. Once you have these installed, attempt another installation of Dragon Naturally 12 on your computer.

**HOOKERR_NONOTIFYWINDOW or c0000005 (EXCEPTIONAL_ACCESS_VIOLATION)**

**Problem:**

While dictating using Dragon NaturallySpeaking, the following errors may appear when using select and say commands or making corrections:

- "Sendkeys_Canceled" or
- "Sendkey: Invalid Key" or
- "Com return an unexpected error code HOOKERR_NONOTIFY"

**Cause:**

This issue may occur if Adobe Reader X is installed on the system or Adobe Flash update 11.5.502.110.

**Solution:**
Part 1: Disable Protected Mode in Adobe XI:

To avoid this conflict, use the following steps to disable “Protected” mode within Adobe Reader X:

1. Start Adobe Acrobat XI.
2. Go to “Edit > Preferences > General Tab”.
3. Uncheck “Enable Protected Mode at startup”.

Note:

• Disabling the Protected Mode at startup should resolve this issue. With Protected Mode disabled, some Assistive Technologies may not be able to read certain document content.
• If not, we recommend removing Adobe Reader XI and installing an older version by going to http://get.adobe.com/reader/othersversions.

Part 2: Disabling the Adobe Flash Plugin within the Web Browser:

• Steps for FireFox:
  • Select the “FireFox” menu and go to “Add-ons > Plugins”.
  • Select the “Shockwave Flash” plugin and select “Disable”.
  • Close and restart FireFox.

• Steps for Internet Explorer:
  • Within Internet Explorer, go to “Tools > Internet Options > Programs > Manage add-ons > Show: All add-ons”.
  • Select the “Shockwave Flash” plugin and select “Disable”.
  • Close and restart Internet Explorer.

Notes:

• The conflict with flash version 11.3.300.257 should not occur in Dragon NaturallySpeaking 12.

#3 Download any other PDF reader such as Nitro PDF Reader

A Referral was returned from the Server error when installing or launching KnowBrainer
You may also see the following error when launching KnowBrainer:

Run-time error '5'
Invalid procedure call or argument

This error is caused by Windows Vista and Windows 7 UAC (User Account Control) which should be turned off because the UAC is a completely unnecessary Windows utility which can cause all kinds of problems.

In Windows 7:
4. Click the Start button (Windows logo)
5. Type UAC
6. Press Enter
7. Move the Slider all the way down to **Never** notify.
8. Reboot

![User Account Control Settings](image)

**In Windows Vista:**
1. Open the Control Panel
2. Click User Accounts and Family
3. Click User Accounts
4. Click Turn User Account Control on or off
5. Remove check mark from use user account control (UAC)...
6. Reboot

**Samurai Command Mode – Ver. 11**

**Problem:** When attempting to dictate into a non-Select-&-Say (non-Full Text Control) application, NaturallySpeaking may produce undesirable results even when dictating entire paragraph. These results can reproduce on unwanted Internet search, desktop search or an unwanted e-mail.

**Solution:** To prevent this type of behavior you can remove the following 4 checkmarks from the DNS Tools/Commands Tab search options as follows:
NaturallySpeaking Types the Same Single Syllable Word over and over Again

**Problem:** Unwanted repetitious single syllable words like “Him him him” appearing in your dictation. Unwanted dictation is usually caused by some form of interference which can range from substandard shielding to a frayed microphone cable.

**Solution:** Unfortunately interference can be difficult to track down because there are so many variables so we recommend the following steps:

1. You can rule out windage (breathing) by removing your microphone, if it is a headset model, and setting it on your desktop in a quiet environment. If NaturallySpeaking repeatedly types the same single syllable word, like “him him him”, “and and and” etc. you can move on to step #2. If the problem goes away when you remove your microphone, simply reposition the microphone element off to the corner of your mouth and possibly further away.

2. To test for a broken cable or loose connection, rerun the Audio Setup Wizard (renamed Microphone Check in Ver. 11) and swing the microphone cable back and forth as you read the text. When you reach the last stage, press the Play button before pressing the Finish button so that you can listen for possible interference. If you hear the occasional nonconstant scratching sound, you may have a frayed cable or loose connection.

3. If you hear a constant 60 Hz hum, when pressing the Play button, you're probably suffering from some form of AC interference which, on a notebook computer, you can verify by temporarily running off from batteries. AC interference can also be caused by your microphone, computer or soundcard being too close to a microwave, wireless phone, fluorescent light and a host of other possibilities. If you suspect AC interference, try moving your computer to a different location or even a different address.

If none of the previous steps produce a viable solution, you may have a defective microphone or even an
oscillating chip on the motherboard of your computer. However, before blaming your computer, try another microphone and USB soundcard. For test purposes, your backup microphone doesn’t have to be stellar quality but it does have to be good enough to pass the NaturallySpeaking Microphone Check.

C++ 9.0 Installation Error or Failed to launch UI Automation – Ver. 11

See: Defeating UAC

Failed to Launch 64-bit server – Ver. 12/13

Begin by disabling the UAC (User Account Control) See Defeating UAC for detailed instructions

Ver. 13/15 Browse your Dragon Installer disk/download for the ISSetupPrerequisites\dotNetFramework folder. Open the folder and double click double click dotNetFx40_Full_x86_x64.exe to launch.

Ver. 11 as follows:

- Unregister and reregister this dll file from an Administrator command prompt. "UIAutomationCore.dll"
- regsvr32 /u "C:\Windows\System32\UIAutomationCore.dll“ to unregister
- regsvr32 "C:\Windows\System32\UIAutomationCore.dll“ to reregister
- Go to the location
- C:\Program Files (x86)\Common Files\Nuance\NaturallySpeaking12\x64\dgnuiasvr_x64.exe”
- check that there are no permission issues for the users to that folder or exe file. Give the user account full access to that location for testing purposes also.
- Unregister and reregister this dll file from an Administrator command prompt.
- regsvr32 /u " C:\Program Files (x86)\Common Files\Nuance\NaturallySpeaking12\x64\dgnuiax_x64.dll“ to unregister
- regsvr32 " C:\Program Files (x86)\Common Files\Nuance\NaturallySpeaking12\x64\dgnuiax_x64.dll“ to reregister

Failed to Launch 64-bit server – Ver. 11

Problem:
After installing Dragon NaturallySpeaking on a Windows 64 bit operating System, launching Dragon causes error "Failed to launch 64-bit server”.

Solution:
Repair the Visual C++ 9.0 Runtime for Dragon NaturallySpeaking 64-bit (x64) and reboot the computer to resolve this error message during launch.

To repair this component please follow the steps below.

1. Close all open applications or open windows.
   2. Browse the Dragon Naturally Speaking installation disc or installation files for "ISSetupPrerequisites\VCRuntime“ folders.
3. Double click "vcruntime_x64.exe".
4. Choose "Repair" and click "Next".
5. Click "Install" and let the repair finish.
6. Reboot the computer.

C++ 8.0 Error Prevents DNS From Installing

Note: If this is a laptop using biometrics technology, make sure NOT to disable the item for that.

Microsoft Visual C++ is a pre-requisite before installing Dragon NaturallySpeaking. If Dragon is installed prior to Microsoft Visual C++, the error occurs.

So you must first uninstall all Dragon NaturallySpeaking programs in your computer:
1) Click Start > Control Panel.
2) Double-click Add or Remove Programs or Programs and Features on Windows Vista.
3) Select Dragon NaturallySpeaking 10 and click the Uninstall button.

After uninstalling successfully, you need to install Microsoft Visual C++ manually by:
1) From your installation media / CD, look for a folder named ISSetupPrerequisites and double-click on VCRUNTIME.exe
2) If you do not have an installation CD and just a download, check on your temporary folder (C:\Documents and Settings\username\Local Settings\Temp) or the location where you extracted the download for the files of NaturallySpeaking and look for the ISSetupPrerequisites folder and double-click on VCRUNTIME.exe to install it.

Once Microsoft Visual C++ is installed, you may start installing Dragon by running the Autorun.exe file from the installation disc or source files.
Microsoft Visual C++ is a pre-requisite before installing Dragon NaturallySpeaking. If Dragon is installed prior to Microsoft Visual C++, the error occurs.

So you must first uninstall all Dragon NaturallySpeaking programs in your computer:
1) Click Start > Control Panel.
2) Double-click Add or Remove Programs or Programs and Features on Windows Vista.
3) Select Dragon NaturallySpeaking 10 and click the Uninstall button.

Secondary Problem:
You may also receive an error message that goes something like this “you have a pending installation of DNS etc. and you will need to reboot”. This error is particularly common in Windows Vista or Windows 7 which just doesn't like to give up a partial installation.

Solution:
Open the Task Manager to the Processes tab, select msiexec.exe (there may be more than one) and click End Process. Then try reinstalling NaturallySpeaking.

Last Resort: If nothing else works you may need to contact Nuance Technical Support directly at (800) 654-1187 M-F 9AM - 8PM EST/EDT
Error 1330 A file that is required cannot be installed because…

This is a fairly common problem among notebook computers and some desktop computers. It is usually caused by the DVD drive not being able to keep up with the installation. We recommend copying the contents of your DVD to a folder on your hard drive and installing from the hard drive folder. Assuming you have already installed the C++ portion of the installation (which you probably have if you were seeing the 1330 error), you should have no trouble installing from a desktop folder but if you haven't managed to install the C++ portion then you may have difficulties.

A Serious Error occurred while initializing the NaturallySpeaking speech engine

Cause:

Typically, this means that the processor (CPU) of the computer does not support SSE2 instructions. Dragon NaturallySpeaking 10 requires that the processor support SSE2 in order to run properly.

Solution:

Purchase a new computer or return your software because NaturallySpeaking cannot run without SSE2 instructions. To determine whether or not your computer supports SSE2 click [http://cpuid.com/cpuz.php](http://cpuid.com/cpuz.php)

Scheduled Accuracy Tuning Fails to Deploy or warns you that it didn't deploy

If you schedule the Acoustic and Language Model Optimizer to run at a pre-determined time, you must make certain that your computer is on but NaturallySpeaking isn’t running. If your computer isn’t turned on when the optimizing is scheduled to run, you'll receive an error message stating that NaturallySpeaking’s failed to perform the task. If you change your mind and would like to eliminate scheduled optimization do the following:

1. Close out of your user profile
2. Click Administrative Settings under the DNS tools menu
3. Put a checkmark in Let the user choose when to run the Accuracy Tuning and Data Collection which will effectively remove the other 2 checkmarks.

Can’t Find dnstk10.dll

Problem

When launching DNS, an error message appears "Dragon isn't installed completely. Please try reinstalling. Can't find the file C:\WinNT\Speech\Dragon\dnstk10.dll" The message may refer to the dnstk10.dll file or any of the files located in the Dragon folder under C:\Windows\Speech or C:\WinNT\Speech

Cause:
The Dragon folder or its contents have been damaged or corrupted.

Solution:

Rename the Dragon folder as follows:

1. Click Start>Programs>Accessories>Windows Explorer.
2. Expand the C: directory (or whichever directory your Windows Operating System is installed to).
3. Expand the Windows directory
4. Expand the Speech folder.
5. Right-click the Dragon folder and delete it.
6. Reboot, insert the Dragon CD-ROM and select the repair option.
7. When the repair completes, reboot and launch Dragon. The error should not reappear.

Cannot Prevent Roaming Results Box

1. Open your personal user C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\Users\(Your User Name)\Current\Option.ini file " in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username)\Options.ini
with NotePad or WordPad.
2. Delete the line: Results Box Position= <###, ###, ###, ###> and replace it with: Results Box Pinned=1.

This Program Requires a Security Key

Problem:

When installing and/or launching a Nuance application, the following error message may appear:

"This program requires a security key. If you have one, select OK to enter it. After entering a valid key, you will not be prompted again."

An "Enter Key" dialog similar to the following will appear.

Note: The Hardware fingerprint will be different, this is an example.

Solution:

This dialog will appear if a hardware change has occurred while a Nuance application was installed on the system. The appropriate Name and Key must be entered to fix this problem. Follow these steps:
1. In the name field, enter the serial number exactly as you received it. Include all dashes/hyphens. There are only Zero's in the serial number, there are no O's (Ohs).

2. To get the Key, open the following webpage:
   - [http://activation.scansoftcom/us](http://activation.scansoftcom/us)

3. On the activation webpage, enter the serial number exactly as was entered in step 1.

4. On the activation webpage, enter the Hardware Fingerprint exactly as shown on the "Enter Key" dialog into the "Machine Fingerprint" field.

5. Click "Generate Activation Key" to create a Key.

6. Copy the Activation Key provided by the webpage into the Key field on the "Enter Key" dialog.

7. Click "OK" to complete the activation process.

**NaturallySpeaking Installation Produces a Cab Read Error (Error 1311)**

**Problem:**

NaturallySpeaking may produce a Cab read error during installation and roll the installation. Large DVD installations more difficult than CD installations and some desktop computers; not to mention most notebook computers, include small left than stellar DVD drive which can result in preventing NaturallySpeaking to install.

**Solution:**

1. Create a new empty folder on your desktop and name it something easily recognizable like DNS 10.
2. Use Windows Explorer to browse your DNS installation DVD
3. Copy the contents of your DNS installation DVD into your desktop folder
4. Double-click setup.exe to initiate installation from your desktop folder.

**How to Change the Default Size and Position of the Command Browser**

Open C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\(Your UserName)\current\options.ini in Windows XP or C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\current\options.ini in Windows Vista/7/8

Open the options.ini file in notepad and replaced the current entry for the Command Browser with the following entry: Command Browser Size And Position=169,209,1015,809. Experiment with different sizes and positions by changing the numbers.

**NaturallySpeaking System Requirements - Ver. 10/11**

The manufacturer minimum requirements for NaturallySpeaking are a 1.4 GHz processor with 512 Mb of RAM (Windows XP) and 1 Gb of RAM for Windows Vista or Windows 7/Windows 7. The SSE2 extension is also required. However, we feel that Nuance’s minimum requirements are far too minimum. Our ideal recommendations for NaturallySpeaking 10 are a 2.4 dual core (or core 2 duo) GHz processor with 2 Gb of
RAM for Windows XP and 4 Gb of RAM for Windows Vista or Windows 7/Windows 7. To determine whether or not your computer supports SSE2 click [http://cpuid.com/cpuz.php](http://cpuid.com/cpuz.php) and download the free diagnostic tool.

**DOCOBJ.DLL Did Not Register itself**
This error only occurs on computers where Microsoft Office 97 was previously installed but not fully removed. Since Office 97 is incompatible with newer versions of NaturallySpeaking and the DOCOBJ.DLL is no longer used, simply perform a search for this file and rename or delete it.

**Mouse Grid and Correction Box Coordinates are way off in Windows 7 - Ver. 10**

If you change Windows 7 display settings to anything other than the default small view, this will throw a number of Windows off including NaturallySpeaking MouseGrid and Correction Dialog Boxes. To return Windows 7 to its default display settings, open the Control Panel, click **Appearance and Personalization**, followed by clicking **Make text and other items larger or smaller** (under **Display**), put checkmark in Smaller-100% and click **Apply**.

If you need to make the text larger on your desktop (and who doesn't), right-click on your computer Desktop, select **Screen resolution** and lower your screen resolution which will effectively make everything larger.

**Please Wait While Windows Configures NaturallySpeaking (repeatedly) – Ver. 9/10/11**

**Problem:**

A dialog box may appear each time Dragon is launched or each time the computer is started that says "Please wait while windows configures Dragon NaturallySpeaking...".

**Note:** It is normal for this dialog box to appear when reinstalling or repairing the application, but it is not normal for this dialog to repeatedly appear every time the application is launched or every time the computer starts up.

**Solution:**

This may be caused by a conflict with the InstallShield Update Service (ISUS).

Removing the InstallShield Update Service with the tool provided below may resolve this issue. This tool is also known as the "Acresso Connect Manager Uninstall" tool. After running the tool, no application which previously used the InstallShield Update Service will be able to check for updates, either manually or automatically.

**Follow these steps to remove the InstallShield Update Service:**

1. Uninstall Dragon NaturallySpeaking through Add or Remove Programs (Programs and Features on Windows Vista or Windows 7).
2. Click [here](http://cpuid.com/cpuz.php) to download the "FLEXNet Connect Manager Uninstall" tool.
3. Save the file to the Windows Desktop.
4. Double click on the file.
5. Click "Next" on the Welcome screen.
6. Click "Yes" when asked "Are you sure you want to remove the FlexNET Connect Software Manager?".
7. Click "Finish".
8. Reinstall Dragon NaturallySpeaking.

Note: Any application which uses the InstallShield Update Service Program Manager or Macrovision Software Manager must be reinstalled to restore that program's ability to check for updates.

Contents of Clipboard are Pasted along with Dictation

Problem:
While dictating, NaturallySpeaking occasionally deposit the contents of the clipboard with the dictation.

Solution:
Turn off “Use Insert key for paste” option in MS Word 2007.

How to Prevent DNS From Adding Unwanted Vocabulary

1. Open your personal user C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username)\Current\Options.ini with NotePad or WordPad.
2. Add the following 2 lines:
   Automatically Add Words=0
   Add Words on Correction=1
   Note: This change will prevent DNS from automatically adding words to your vocabulary such as misspellings and an unwanted vocabulary that appears in Select-&-Say documents. You will be able to add words from your vocabulary via the Add Word feature, the Vocabulary Editor and Spell That correction.

How to Prevent "The select previous variable hotkey was not installed..."

Option #1

1. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\nsdefaults.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking12\nsdefaults.ini in Windows Vista or Windows 7
2. Create a blank line below the exiting text and type [options.ini Options]
3. Under that heading add the following lines, save and close the nssdefaults.ini file

   Clear Variable Delimiters Hot Key= 0,0
   Select Next Variable Hot Key=78,5
   Select Previous Variable Hot Key=0,0

Option #2
NaturallySpeaking Briefly Displays the Splash Screen but Won’t Launch or Prompts you for a Security Code

Problem:

When attempting to launch NaturallySpeaking 9.5 the splash screen appears briefly but fails to launch the program. You may also be prompted for a non-existent security code. The problem seems to be isolated to a new driver that supports a PowerMic in tablet computers.

Solution:

Rename the C:\Program Files\Nuance\NaturallySpeaking10\Program\micaudio.dll file micaudio.old and re-launch NaturallySpeaking.

Run Accuracy Tuning and Collect Recognition Data Keeps Asking for Windows login

Unfortunately you cannot schedule the Language Model Optimizer (accuracy tuning) to run unless you are utilizing the Windows logon password option. Scheduling any activity in Windows is a potential security risk so Windows requires the use of a user ID and password in order to run any schedule tasks. If you do not use a password to log onto Windows you will need to run this utility manually. However, you might consider skipping this process entirely because of DNS 9 and 10 learn as you go.

How To Disable the DNS 11 Delete, Copy and Cut Commands

Problem:

How do you prevent DNS from cutting, copying or deleting your previous dictation when you begin a phrase with the work Cut word/s, Cut through word/s, Copy word/s, Copy through word/s, Delete word/s, Delete through word/s etc…

Solution:

A. Preface your command with the word Cap or No-Caps Cut, Copy or Delete to prevent DNS from interpreting your dictation as a command

B. You can optionally rename these commands via the following steps:

4. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\nssystem.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking10\nssystem.ini in Windows Vista or Windows 7

5. Create a blank line below the [Settings] section of the nssystem file.

6. Add

enx Delete XYZ Command=extigit
enx Delete From XYZ Command=extigit
enx Cut XYZ Command=clippyfit
enx Bold XYZ Command=pinguid
enx Underline XYZ Command=underskid
enx Correct XYZ Command=rectifit
enx Correct That Command=rectifit
enx Compound XYZ Command=restrigit
enx Compound That Command=restrigit

on separate lines

7. Save, close and re-launch the DNS for the changes to take effect.
8. If you prefer to disable these commands

Do Delete XYZ Command=0
Do Delete From XYZ Command=0
Do Cut XYZ Command=0
Do Bold XYZ Command=0
Do Underline XYZ Command=0
Do Correct XYZ Command=0
Do Correct That Command=0
Do Compound XYZ Command=0
Do Compound That Command=0

on separate lines

9. Save, close and re-launch the DNS for the changes to take effect.

How to Prevent DNS from forcing you to choose a number when Selecting/Cutting/& Deleting Text (courtesy of Stephen Kuepper)

4. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\nssystem.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking12\nssystem.ini in Windows Vista or Windows 7
5. Create a blank line below the [Settings] section of the nssystem file.
6. Add Show disambiguation numbers=0 (on a separate line)

How To Prevent DNS from Automatically Placing the Microphone in Sleep Mode

1. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\nssystem.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking12\nssystem.ini in Windows Vista or Windows 7
2. Create a blank line below the [Settings] section of the nssystem file.
3. Add Time Before Mic Sleep With No Sound=0 (on a separate line)
4. Save, close and re-launch DNS for the changes to take effect.
Acoustic Optimizer Is Grayed Out on the Roaming User Profile

**Problem:**

The option to run the Acoustic Optimizer and Language Model Optimizer on grayed out on the Roaming user profile

**Solution:**

The Acoustic and Language Model Optimizers can only be run on the MASTER (original) Roaming User.

SDAPI Error 1: Error: [S:\rnrec17\11988\rnrecutil\realdf.cpp1845mrecutil\realdf 17]

**Problem:**

This is a Windows Registry error which is often caused by installing/uninstalling too many applications.

**Solution:**

1. Begin by moving your ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username) folder (DNS user files) to a safe address such as your desktop.
2. Uninstall NaturallySpeaking to prevent the loss of one of your 10 activations.
3. Run DNS10.1 Remover (for Ver. 10 only) which will not only remove the DNS parts that the uninstall program missed but more importantly, remove the registry entries.
4. Reinstall NaturallySpeaking.
5. Move your user profile back to its original location and launch NaturallySpeaking. You'll be prompted to rerun the Audio Setup Wizard but with a little luck, everything should work.

NaturallySpeaking 9/10 Insists that the processor speed is not adequate for running DNS 9/10 during installation

**Problem:**

When installing Dragon NaturallySpeaking 9/10 you are presented with a message stating that NaturallySpeaking requires a faster processor (even though your notebook/tablet computer is a PIV or equivalent).

**Solution:**

Because the idling speed in notebook/tablet computers is so low, NaturallySpeaking is misinterpreting the speed of your computer. Do the following:

1. Mouse Right-click on your desktop
2. Click Properties
3. Click Screensaver
4. Click the Power button
5. Click Power Schemes
6. Click Always on
7. Click both OK buttons
8. Turn your computer completely off and then on again (cold boot) which should allow NaturallySpeaking to install.

Erratic Behavior (including e-fail error)

Problem:

NaturallySpeaking behaves erratically, sometimes only partially obeys commands etc.

Solution for DNS 10/11 – By default, this problem is handled automatically in Windows 7/8.1 & Vista but in Win XP:

1. Close the current user via the NaturallySpeaking or Dragon Menu
2. Click Tools/Administrative Settings/Miscellaneous
3. Put a checkmark in Disable Windows advanced text services

Solution for DNS 9 in Windows Vista or Windows 7:

1. Click Start > msconfig (in the default Search box) and press {Enter}
2. Click the Startup Tab
3. Uncheck ctfmon.exe and click OK. The changes won’t take effect until you reboot.

Solution for DNS 9 in Windows 2000/XP:

1. Close out of all Microsoft applications. Open Task Manager, click the Processes Tab and End Task “CTFMON.exe”
2. Close all open applications, including AntiVirus software
3. Click "Start > Settings > Control Panel> "Add/Remove Programs" > "Install/Uninstall" tab, select "Microsoft Office
4. Click the "Change" button to access the Microsoft Office installer.
5. In the next screen, choose "Add or Remove Features," and click "Next
6. If using Microsoft Word 2003; place a “check” in the “Choose advanced customization of applications” option and click “Next.”
7. 10a. If using Microsoft Word 2007 click on the office button in the upper left-hand corner. At the bottom of the Office button drop-down list, click the "Word Options button”. In the "Word Options” dialog, click "Proofing." Under the heading "When correcting spelling and grammar in Word," remove the checkmarks from the checkboxes for "Check spelling as you type" and "Mark grammar errors as you type.” Then click OK.
8. Expand “Microsoft Office Excel”, click the symbol next to “Text to Speech”, and then click “Not Available”.
9. Expand “Office Shared Features”.
10. Expand “Alternative User Input”.
11. Click the symbol next to “Speech”, and then click “Not Available
12. Click the symbol next to “Microsoft Handwriting Component”, and then click “Not Available”.
13. Expand “Proofing Tools”.
14. Expand “French”, click the symbol next to “English - French Translation”, and then click “Not Available”.
15. Expand “Spanish”, click the symbol next to “English - Spanish Translation”, and then click “Not Available”.
16. Click Update
17. Click "Start > Run."
18. In the Run dialog box type:

   regsvr32 /u msimtf.dll

   Click "OK."
   Click "Start > Run."
19. In the Run dialog box type:

   regsvr32 /u msctf.dll

   Click "OK."

   Confirm that CTFMON.exe is not showing as a process when you press Control+Alt+Esc (Task Manager).

   Note #1: Turning off advanced text services will disable handwriting recognition

---

Cannot load compatibility module support

Problem:

When launching Dragon NaturallySpeaking 9 or when opening a user profile the following error message appears: "cannot load compatibility module support (GUID = {DD100203-6205-11cf-ab61-0000e8a28647})"

Solution #1:

Remove the bad reference from the Windows Desktop. The bad references we have currently found are:

HP Share-to-Web

IMPORTANT: This section contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. Follow the steps below to back up the registry:

1. Click the Start button, type regedit and press {Enter} in Vista. In Win XP you will need to additionally click Run before typing regedit. Navigate to the following Windows Registry Location:

   HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\n
2. Look through the reference code Registry keys (folders) on the left under "NameSpace", while viewing their description on the right. The following known good references codes may exist for:

   - My Computer
   - Network Neighborhood
   - My Documents
- Internet Explorer
- Microsoft Outlook

3. Locate and remove any registry keys (folders) on the left under "NameSpace" that point to bad references as noted above. Registry keys can be deleted by right clicking on them and choose delete.

Solution #2:

5. Double click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\nssystem.ini in Windows XP or ~ C:\ProgramData\Nuance\NaturallySpeaking10\nssystem.ini in Windows Vista or Windows 7
6. Create a blank line anywhere below the 3rd line of code
7. Type the following on a separate line Create Start App Command=0
8. Save and close the file
9. Reboot your computer

KnowBrainer Stops Running after a Minute or so on Vista. Error: **Path not Found**

KnowBrainer stops functioning after a minute or 2 running Windows Vista or Windows 7 on computers with dual boot operating system or if you're using the default setting of Vista Junior Administrator. In this situation you will need to acquire Senior Administrator rights in Windows Vista or Windows 7 as follows:

1. Open the Control Panel
2. Click User Accounts and Family
3. Click User Accounts
4. Click Turn User Account Control on or off
5. Remove check mark from use user account control (UAC)...
6. Reboot

KnowBrainer 2016 Installation error “this is not a valid Windows 32 bit application”

**Problem:** When attempting to install KnowBrainer 2016 from the disk, you receive the error: “this is not a valid Windows 32 bit application”

**Solution:** Close the error and browse the disk to the executable and installed by double-clicking on KnowBrainer 2016.exe or KnowBrainer Medical 2012.exe

KnowBrainer Produces Runtime Error 429 (ActiveX Component Can't Create Object)

This can occur after uninstalling some programs in Windows XP.
In Windows XP, you will find SCRRUN.DLL in the C:\WINDOWS\SYSTEM32 directory. To register this file press the <Windows> key (next to ctrl key) and <R> key together. Once you do this the Run box should open and then you should type in the following:
Regsvr32.exe "C:\windows\system32\Scrrun.dll"

Type this exactly or cut and paste, then hit Enter. If you get the "Dlregister Server in C:\windows\system32\Scrrun.dll succeeded" it should have worked ok.

KnowBrainer Install Error: Cannot open file msvcr40.dll

Problem:
This problem typically occurs when attempting to install KnowBrainer 2010/11 and you are presented with an error message: Cannot open file C:\Windows\system32\msvcr40.dll. This error is caused by your msvcr40.dll file not being properly registered.

Solution:
Rename the C:\Windows\system32\msvcr40.dll to mdvcr40.dll to mdvcr40.old and reinstall KnowBrainer.

Running the Acoustic Optimizer Produces Error Message: 0x80040154 class not registered

The simplest solution is to not run the Acoustic Optimizer because it's no longer needed. DNS 9 introduces a new "SilentAdapt" algorithm which updates your Acoustic Model as you dictate. As long as you save your corrections, your acoustic model will be updated automatically and it's no longer necessary to run the Acoustic Optimizer.

Note: If you are using a third-party command utility like KnowBrainer, you must exit KnowBrainer before you can run the Acoustic Optimizer.

SDAPI Error 1: Error: [s:\mrec15\11115\sdapi\apist.cpp 393 sdapi\apist 24] SDWord_GetName: SDhVoc 0x00000000ffffffff

The user speech files may have become corrupt. Possible causes may include aggressive Anti-Virus settings, lack of system resources (low memory) or power surges (especially when saving speech files). Your system may behave erratically if it has insufficient memory or insufficient space on the hard disk.

A problem with insufficient memory can be permanent or temporary. It may occur only if a certain product is running, updates are installing while Dragon is running, or the problem may seem to occur randomly.

Note: Running a Windows System Restore can also result in user file corruption. We recommend closing Dragon and backing up the user files before running a system restore.

Solution: Make sure you have ample disk space, consider temporarily dis-engaging your antivirus software and create a new user. You should also make sure you have a minimum of 1 Gb of RAM and try closing as many programs as possible.

This program has been damaged possibly by a bad sector or a virus
This error is typically caused by Computer Associates 2007 Internet Security Suite which is also part of AOL “Safety and Security Center”. You will need to uninstall Internet Security Suite because NaturallySpeaking is incompatible with this utility.

Can’t See all of the Text or Buttons in the Training Window

1. Right-click on your Windows Desktop and select **Properties**.
2. Click the **Settings** tab
3. Click the **Advanced** button
4. Change the DPI setting back to **Normal size (96 DPI)** and click both **OK** buttons

When Saving Speech files error: “cold not copy aco.ini…file already exists”

Open your ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\(your username)\tb folder in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\tb folder, delete the **tb** folder (temporary backup) and try saving again.

DNS Prompts You to Activate Every Time You Launch

This error is caused by NaturallySpeaking not properly registering itself in the Windows registry. Use **DNS10 Remover** to remove every trace of NaturallySpeaking and reinstall. **Note: Remover 10.exe will also remove your user files so if you wish to preserve them, back them up in a safe location before running Remover.**

The following files were not registered successfully: "C:\Program Files…msoe_agent.dll"

This file is only necessary if you are using Outlook Express and if you are, click the Start button, select Run from the Start Menu, type `regsvr32 "C:\Program Files\Nuance\NaturallySpeaking12\Program\msoe_agent.dll"` in Windows XP or “C:\ProgramData\users\nuance\NaturallySpeaking12\users” in Windows Vista or Windows 7 and press the **OK** button. If you receive an error message than NaturallySpeaking failed to install file. You will need to reinstall NaturallySpeaking.

NatSpeak Has Reached the Maximum Amount of Speech Data That Can Be Saved

Click the Data Tab in NaturallySpeaking's Options menu. Change the “Disk space reserved for playback” from the default setting of 40 to 250 Mb. It also helps if you change the “Save recorded dictation with document” option from **Ask Me** to **Never**.

Acoustic Model Optimizer works but Language Optimizer Fails

Problem defined:
The Language Optimizer will not run until there is sufficient data (corrections and dra files) in the Acoustic and Language Model Optimizer in order for it to run. To further complicate the issue, NaturallySpeaking’s default settings do not support the Language Optimizer.

Solution:
1. Open NaturallySpeaking’s Tools/Options to the **Data** tab
2. Click the **Advanced** button
3. Put a check mark in **Always preserve wave data** and click both **OK** buttons
4. You will need to wait approximately 3 weeks for NaturallySpeaking to save enough data to effectively run the Language Optimizer.

**Prompted to Increase the Size of the Acoustic Archive Whenever Saving a User Profile**

If you are receiving an error to increase your acoustic archive whenever you attempt to save your user profile this is a Ver. 10.0 bug that was fixed in a service release patch and Ver. 10.1. Creating a new user profile in Ver. 10.1 will eliminate the problem but if you installed Ver. 10.1 over the top of Ver. 10, you will continue to receive this error. Although the error is harmless you will have to either click yes or use your KnowBrainer Save User command, as a workaround.

**How to Disable the Update Service and How to Stop Windows Explorer from opening “C:\Program Files\Common Files\ScanSoft\OCR**

**Problem:**

When restarting the computer a Windows Explorer window opens to “C:\Program Files\Common Files\ScanSoft\OCR” (Version 8) every time the computer is restarted.

**Solution:**

Disable the Dragon NaturallySpeaking Update and Spamming Service to stop this folder from appearing.

**Windows ME, XP & Vista/Windows 7:**

1. Click “Start > Run” (skip Run in Vista).
2. Type “MSCONFIG” without the quotes and click “OK”.
3. Select the “Startup” tab.
4. Look for the entry “SSBkgdupdate”.
5. Remove the check next to this entry.
6. Click “Apply > OK”
7. Restart the computer.

**Note:** In **Windows Vista or Windows 7** the process is the same but in Step #1 just click the Start button and type MSCONFIG. Vista doesn’t have a Run menu.

**Windows 2000:**

1. Click “Start > Run”.
2. Type “REGEDIT” without the quotes and click “OK”.
3. Export a backup copy of the Registry in case problems occur during the following procedure. To accomplish this, click the “Registry > Export Registry File…” or “File > Export Registry”, then choose a file name and location to save the backup to.
4. Browse to the following Registry key:
   - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
5. Locate the entry in the right pane labeled “SSBkgdupdate”.
6. Right click on the entry labeled “SSBkgdupdate” and select “Delete”.

48
7. Click “Yes” to confirm the deletion of the “SSBkgdupdate” entry.
8. Exit the Registry.
9. Restart the computer.

Note: Removing this item will disable the ability of Dragon NaturallySpeaking to automatically look for updates on the system. Click “Help > Check for Updates” to manually check for updates.

Forced to Rerun the Audio Setup Wizard Each Time I Launch DNS

Problem: This problem is usually caused by a registry error but can also be caused by the end-user creating a user file but not bothering to train during the current session which can result in registry corruption.

Solution:

Option #1

Create a new user profile with a new name.

Option #2

1. Move your ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username) folder to a temporary safe location such as your desktop. If you can't find your user folder it's probably because you still have Windows default setting of hidden files and folders turned on. Click Hidden Files for a manual step-by-step.
2. Uninstall NaturallySpeaking so that you don't lose an activation.
3. Use DNS10 Remover to remove every trace of NaturallySpeaking from your system including the registry entries.
4. Reinstall NaturallySpeaking.
5. Move your user files back to their original location and launch NaturallySpeaking. You may be prompted to run the Audio Setup Wizard one last time but it shouldn't happen again.

Outlook 2007 Dictation Appears in Word 2007

Problem: When dictating in Outlook 2007 dictation mysteriously appears in Microsoft Word 2007. This problem usually occurs when you launch Outlook 2007 before launching NaturallySpeaking or close and re-launch NaturallySpeaking while Outlook 2007 remains open.

Solution: Close and re-launch Outlook 2007.

Dictation Appears Correctly in the Results Box But only Some of the Words appear in the Document
Another process, such as your antivirus software, spyware checker or various other utility is performing a scan of your hard drive and taking precedence over NaturallySpeaking.

This is not unusual when your antivirus software or spy checking software is performing a daily or weekly scan of your hard drive. Disabling the scan, when using NaturallySpeaking, will usually eliminate the problem.

If you don’t see an obvious utility scanning your hard drive, the preferred solution is to use the process of elimination to locate the culprit under the Processes tab of the Task Manager as Chuck recommended but if you are unable to find the source of the problem, you can optionally right-click on NatSpeak.exe (under the Task Manager/Processes tab) select Set Priority and change it from Normal to Above Normal or High. HOWEVER, this should only be done as a last resort and will only last as long as NaturallySpeaking is running in the current session. Once you close and re-launch NaturallySpeaking it will return to Normal priority.

How to Turn Off the Automatic Update Feature

1. Right-click on the taskbar microphone and select File/close User
2. Right-click on the taskbar microphone again and select Tools/Administrative Setting
3. Uncheck “Check for product updates at startup” and Click OK

The Results Box displays “< ??? >” during General Training and the phrase “Welcome to general training” may not be recognized

Close the current user before starting the enrollment process for a new user.

Dragon generates errors when analyzing Corel WordPerfect 11 documents

Close WordPerfect 11. Additional Note: Make sure you are using the latest patches which you will find at http://www.wpwriter.com/Links/Updates___Patches/updates___patches.html

C:\WINDOWS\speech\speech.dll is version 4.0.x.xxxx. NaturallySpeaking requires version 4.0.4.2512 or “Unable to find the file: C:\Windows\Speech\VCMD.exe”

1. Click here to download the file "spchapi.exe". This file is also available on the Dragon NaturallySpeaking 7 CD in the "Redist" folder (but not version 8 or higher).
2. Close out of all open applications running on your system.
3. Double-click the file "spchapi.exe" to start the installation.
4. Reboot your computer.

“Page Down” command scrolls down too far in IE6

Substitute “Down <1-20>” or “Move Down <2-20>”
Commands and dictation stop working in Internet Explorer

Install Windows XP SP2 (if not already installed) and run an anti-spy software package like Ad-Aware or Spybot.

Uncorrected text remains on the screen after making a correction

To resolve this situation, do the following:

1. Launch Microsoft Word.
2. Go to “Tools > Options > Edit”. In Word 2007 click Menu/Word Options button/Advanced
3. On the “Edit” tab, check the box in front of: "Typing replaces selection".

The “undo that” command after a phrase with a period highlights the wrong selection

Use either the “scratch that” command to undo dictation that contains a “period” or to make the edit manually.

Enabling the Text-to-speech Engine

Option #1
Double-click on “Add or Remove Programs” in your Control Panel. Select “Dragon NaturallySpeaking 7 and press the “Change” button. When prompted, insert your NaturallySpeaking CD and select the “Modify” option. You should see a checkbox option entitled ”Text-to-Speech”. Make sure it is checked and proceed from there.

Option #2
1. Browse the Dragon NaturallySpeaking CD and locate the file \redist\realspeakenx.msi.
2. Double-click on realspeakenx to install the text-to-speech engine. If you receive an erroneous message that goes something to the effect of “You Do Not Have Administrator Rights etc.” close out of that window and choose Option #3

Option #3
1. Insert the KnowBrainer CD and Browse to _:\KnowBrainer 7 Extras\KB Utilities\Mary.exe and double-click. You may be prompted with a message from Microsoft stating that “Newer versions of these .DLL’s already exist on your system. Do you wish to overwrite them”? The answer is YES; overwrite the existing files. Note: If you do not have a KnowBrainer CD you can download the text-to-speech engine from the Free Utilities section of our web site.
2. You may still need to initialize the text-to-speech engine. The following steps will explain this:
   a. Say “Text-to-speech Options” ~ to open NaturallySpeaking’s options menu and switch to the Text-to-Speech Tab
   b. Press the ”Read Text” button ~ to initialize the speech engine
Note: On some NaturallySpeaking installations the text-to-speech engine fails to install but occasionally NaturallySpeaking will additionally fail to install the text-to-speech tab on the options menu. If you only see 6 tabs in your options menu, instead of the usual 7, then you are the victim of a partial installation. The only viable solution, we have found, is to completely uninstall NaturallySpeaking and then reinstall. If you have already created user files you will not have to uninstall your user files. When uninstalling NaturallySpeaking simply agree to the default option which is to preserve your user files. Completely uninstall and then reinstall NaturallySpeaking. Then reinstall KnowBrainer. You will not have to say the "Tweak My Computer" command began.

**Word Corrections Land in Front of Instead of Replacing the Selected Text**

When correcting in MS Word the correction lands in front of the selection instead of replacing the selected word or phrase.

Open your Word options menu and check **Typing Replaces Selected**

**NaturallySpeaking Rolls Back Install near the End Of the Installation or presents Error 1155**

When coming to the end of the installation process, Dragon may prompt the error: "The Wizard was Interrupted . . ." or Dragon may roll back at the end of the install.

**Solution:**

This problem has more than one cause, so more than one solution is provided. To fix the problem, try each of the following solutions in the order that they appear.

**To check for the SFPCA Cache folder**

1. In Windows Explorer, open the following folder:

   C:\Program Files\Common Files\Microsoft Shared\

2. If the “SFPCA Cache” subfolder exists, continue with the "To check the status of Msxmlx.inf" section of this document.

3. If the “SFPCA Cache” subfolder does not exist, create it.

   **Note:** The folder name is case-sensitive.

4. Continue with the "To install MSXML" section of this document.

**To check the status of Msxmlx.inf**

1. Confirm that Windows is configured to show hidden and system folders.

   Windows Vista/7
   To see hidden files:
   1. On the “Tools” menu in Windows Explorer, click “Folder Options”.

52
2. Click the “View” tab.
3. Under “Hidden files and folders”, click “Show hidden files and folders”.

Windows 8
To see hidden files:

1. On the View menu in File Explorer
2. Click Options
3. Click View
4. Click Show Hidden Files, Folders and Drives

- On the Windows taskbar, click Start > Search > For Files or Folders.

  • Under "Search for files or folders named," type the following text: “msxmlx.inf”
  • Click “Search Now” and wait for the search to finish.
  • In the right pane, right-click each instance of “Msxmlx.inf”, and then click “Properties”.

  Note: If Msxmlx.inf is not found, then install MSXML.

2. If “Read-Only” is checked, uncheck it, and then click “OK”. Repeat steps 5 and 6 for any remaining instances of Msxmlx.inf.

To install MSXML

1. Before installing Msxml.msi, remove any other versions from Add Remove Programs.
2. Go to Start > Settings > Control Panel and open Add Remove Programs.
3. From the list of installed programs, search for “MSXML 6.0 Parser” or “MSXML Parser” and uninstall them.
4. Reboot
5. Download and run the Msxml.msi file from the Microsoft Download Center.
6. The link to download the Msxml.msi file is:


   Note: The Microsoft Tech Note title is “MSXML 4.0 Service Pack 2 (Microsoft XML Core Services)”. The file is named MSXML.MSI and is approximately 5MB.

7. After installing MSXML, restart the computer.
8. Reinstall Dragon.
NaturallySpeaking Won’t Launch in Windows XP

5. Right click on the Dragon NaturallySpeaking icon on the Windows Desktop and select “Properties.”
6. Click on the “Compatibility” tab.
7. Place a check next to “Run this program in compatibility mode for.”
8. Click the down arrow and select “Windows 2000.”
9. Click “OK.”

NaturallySpeaking 7 Needs to Reboot to Finish the Install but Fails

1. Delete your temporary files which are located at
   A. C:\Documents and Settings\Local Settings\Temp or C:\Temp(Win2000/XP)
   B. C:\Windows\Temp (Win98/ME)
   C. C:\WINNT\Temp (WinNT)
2. Click the Start button
3. Click Run
4. Type “regedit” (minus the quotes) and press the {Enter} Key to open the registry
5. Click File/Export to make a backup copy of the registry to your desktop
6. Click on the following in the left pain ~
   Hkey_Local_Machine\System\CurrentControlSet\Control\Session Manager\
7. Right-click on "PendingFileRenameOperations" (minus the quotes) in the right pain and select Delete
8. Close out of regedit and save the file
9. If the previous 8 steps fail install JV Power Tools (available on your KnowBrainer CD at
   _\KnowBrainer 7.xx\KnowBrainer 7 Extras\KB Utilities\JV 16 Power Tools. If you don’t have a
   KnowBrainer CD you can search for “JV Power Tools” on the Internet
10. Remove the C:\Windows\Speech\Dragon folder (which may disable Version 6 if you are upgrading)

NaturallySpeaking 7 SP1 or SP2 Needs to Reboot to Finish the Install but Fails

1. Click the Start button
2. Click All Programs
3. Double Click Startup
4. Delete the NaturallySpeaking shortcut from the Startup folder
5. Double Click SP1 or SP2 again to finish installing the service release patch

NaturallySpeaking Will Not Install (usually a Windows 98 problem)

NaturallySpeaking may suffer from a partial install or simply won't install. You may receive the following error:

Error Number; 0x80070725 – Description: Incompatible version of the RPC Stub

This error is caused by a DLL that was installed on the system, such as Oleaut32.dll, Olepro32.dll, Asycfilt.dll, Stdole2.tlb, or others that are not compatible with that system. For example, version 3.50 of Oleaut32.dll is installed and used only by Windows XP and so causes this error if it is installed on a machine running any other operating system. To repair this problem try the following:
Explore your KnowBrainer CD and double-click on .D:\KnowBrainer 7 Extras\KB Utilities\RPCrepair.exe and install the software. This will replace the out-of-date Install Shield.dll.

*Note:* You may need to run the NaturallySpeaking Repair. Insert the NaturallySpeaking 7 CD and simply follow the prompts.

**Unable to install Dragon NaturallySpeaking 7 and receive 0x80070725 error**

**Problem:**

After starting the Installation of Dragon NaturallySpeaking 7, the following error may appear: “Error Number: 0x80070725 Description: Incompatible version of the RPC stub. Setup will now terminate"

**Cause:**

This error is caused by an incompatible version of a DLL that was installed on the system.

**Solution:**

The following information is addressed in Install Shield’s article Q105810:

There are two possible resolutions for this error. Choose the appropriate method for your computer.

- **Microsoft Office 2000 and/or Office 2000 Component **IS** Installed on Your Computer**
  
  If you have Microsoft Office and/or Office 2000 component installed, [install the Office 2000 Service Release 1](https://support.microsoft.com).

- **Microsoft Office 2000 or an Office 2000 Component **IS NOT** Installed on Your Computer**
  
  If you do not have Office 2000 or an Office 2000 component installed on your computer, download and install the [mcrepair.exe tool](https://support.microsoft.com). When it prompts you to overwrite newer files, make sure you click YES for each file. References

Microsoft addresses this issue in Knowledge Base article 321915 "Incompatible Version of the RPC Stub" Error Message with the InstallShield Program.

**NaturallySpeaking 7 Will Not Install on Windows 2000/XP (setup keeps prompting you to reboot the system to update system files)**

**Option #1:**

On Windows 2000 the problem file is probably located at C:\WINNT\System 32\Pdm.dll.
On Windows XP the file is probably located at C:\Windows\System32\Pdm.dll but may be located at C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG. Simply rename the Pdm.dll file to Pdm.old and continue to install NaturallySpeaking 7.

**Option #2:**
If you are using a network version of Panda antivirus you may need to completely uninstall the software.

Option #3: Follow these steps for Windows NT/2000/XP:

1. Open the Windows Registry Editor by clicking "Start > Run." Type in "regedit" without the quotes and click “OK.”
2. Export a backup copy of your Windows Registry in case problems occur during the following procedures by going to:
   - Registry menu > Export registry file (WinNT/98/ME/2000)
   - File > Export Registry File (WinXP)
3. Save this file to the Windows Desktop and name the file "backup". (You can keep "backup" for a few days and if all is well, this file can be deleted.)
   - Locate the following registry key (folder on the left).
   - Hkey_Local_Machine\System\CurrentControlSet\Control\Session Manager\

   **Note:** Do not delete the "Session Manager" Registry Key (folder on the left). Removing the "Session Manager" key can cause serious errors with the Windows Operating System, including not being able to boot.
4. Locate the following value (entry on the right), right-click on it and choose “Delete.” Please choose “Yes” when prompted to delete this value.
   - PendingFileRenameOperations
5. Close out of the Windows Registry Editor.

NaturallySpeaking 7 Refuses to Install on Windows XP with SP2

1. Browse to ~ C:\Program Files\InstallShield Installation Information\{6675E71B-9843-4971-BC15-18AB52801134\}setup.ilg and double click setup.ilg
2. Cancel when prompted to insert the CD
3. You may also have to kill the hung InstallShield at the end of this install which may take up to an hour but everything should work

NaturallySpeaking Will Not Start Because of an Out Of Date mscvrt.dll

Option #1

1. Right click on the Dragon NaturallySpeaking icon on the Windows Desktop and select “Properties.”
2. Click on the “Compatibility” tab.
3. Place a check next to “Run this program in compatibility mode for.”
4. Click the down arrow and select “Windows 2000.”
5. Click “OK.”

You should now be able to open Dragon NaturallySpeaking without the msvcrtd.dll error message.
**Note:** You will need to do this for all Shortcuts used to open Dragon NaturallySpeaking.

Option #2

Double-click the self executable mscvrt zip file from your KnowBrainer CD at `_:\KnowBrainer 7 Extras\KB Utilities\mscvrt`

**NaturallySpeaking 7 Will Not Install on Dual Processor System with more that 1 Gig of RAM**

1. Click the Start button
2. Click Run
3. Type MSConfig and press {Enter}
4. Click the BOOT.INI Tab
5. Click the Advanced Options button
6. Place a Checkmark in `/MAXMEM=` box
7. Type 1024 and press the OK button
8. Press the System Configuration OK button

Note: Once you have finished installing NaturallySpeaking you should be able to undo the previous steps to gain back additional RAM.

**Error: 0x80040707**

Option #1

1. Insert the Dragon NaturallySpeaking CD. If the installation begins automatically, click the "Cancel" button to exit out of the installation.
2. Create a new folder on the Windows Desktop.
3. Open "My Computer", right-click on the CD-Rom drive and choose "Open".
4. Select the entire contents of the CD and copy it to the new folder created in step 1.
5. Download the appropriate zip file (these are specific to the version and edition and will not work with any other product) or copy from your KnowBrainer CD at `_:\KnowBrainer 7 Extras\Error 0x80040707`:
   - Dragon NaturallySpeaking 7 Legal Solutions
   - Dragon NaturallySpeaking 7 Medical Solutions
   - Dragon NaturallySpeaking 7 Professional
   - Dragon NaturallySpeaking 7 Preferred
   - Dragon NaturallySpeaking 7 Standard
   - Dragon NaturallySpeaking 7 Essentials
6. Extract the file "setup.inx" using an extraction program (for example WinZip) to the new folder created in step 1. Overwrite the file that exists in this location.
7. Open the new folder and double-click the file "setup.exe" to install Dragon NaturallySpeaking. You should no longer receive this error message.

Option #2

**If you are upgrading from a previous version of NaturallySpeaking:**

After this error occurs, do the following:
1. Click “OK” on the error message, which will close out of the Dragon NaturallySpeaking 7 installation process.
2. Using Windows Explorer, navigate to the Dragon NaturallySpeaking installation directory that you are upgrading from:
   - C:\Program Files\Dragon\NaturallySpeaking\ - V6 default
   - C:\Program Files\Dragon Systems\NaturallySpeaking\ - V5 default

3. Your user files from the previous version may have been copied into a folder called “OldUsers0”. If this folder exists, look at its contents to see if the user files have been moved into this folder. If they have, delete the “Users” folder from the Dragon NaturallySpeaking installation directory and rename the folder “OldUsers0” to “Users”. Backup this new “Users” folder to another location on your computer.
4. Reboot your computer.
5. Reinstall the previous version of Dragon NaturallySpeaking on your computer.
6. Launch this version of Dragon NaturallySpeaking and make sure that all of the user files are working properly.
7. Exit out of Dragon NaturallySpeaking.
8. Navigate to the installation directory and go into the “Users” folder and then into the first user’s folder in the list.
9. Remove all of the folders in this location except for the folder “current.”
10. Open the “current” folder and delete all of the folders that have the following temporary folder name:
    - t< letter >< number >.< number >
    - For example: ta1.0

11. Repeat steps 9 and 10 for all of the users folders that exist under “Users”.
12. Reboot your computer.
13. Install Dragon NaturallySpeaking 7. This error message should no longer appear.

**Note:** In some cases you may need to re-run the Audio Setup Wizard and/or do additional training before you will be able to use the upgraded users.

**NaturallySpeaking Will Not Launch**

If you receive the following message: “This application has failed to start because DMFC6.DLL was not found. Reinstalling the application may fix this problem.” Ignore the part about reinstalling NaturallySpeaking because it probably won’t work. One of the reasons for this error message is the existence of 2 installed NaturallySpeaking software packages. One might be Pro 5 and the other Pro 7. Even a copy of Preferred 6 and Pro 6 can cause this error. The solution is as follows:

1. Make sure you have completely exited NaturallySpeaking. Press {Ctrl+Alt+Del} to bring up the Task Manager and make sure that “NatSpeak.exe” isn’t running from within the Processes tab. Do not look for NatSpeak in the Applications tab.
2. Copy your ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(Your User Name)\current folder in Windows XP. The
Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username)\current to the desktop.
3. Delete the following directories ~ C:\Program Files\ScanSoft\ and C:\Program Files\Dragon\ 
4. Reinstall NaturallySpeaking & SP2 if you do not have a full copy of Version 7.3
5. Start a new user but ignore training
6. Exit NaturallySpeaking and replace the current folder from your desktop with the one you just created
7. Reinstall KnowBrainer
8. Reboot your computer and launch NaturallySpeaking. You will be prompted to run the Audio Setup Wizard but you will not have to retrain.

Note: We have only used this procedure on Windows XP. You may additionally need to manually remove NaturallySpeaking from the registry. The easiest way to remove unwanted registry entries is to use JV Power Tools which is available on your KnowBrainer CD at ~ D:\KnowBrainer 6 Extras\KB Utilities\JV Power Tools.exe

How to Create a Roaming Profile in Dragon NaturallySpeaking

You can "Map" a drive letter either directly to your Roaming user folder, or to the drive that contained your roaming user folder.

Information:

In order to use Roaming User Profiles with Dragon NaturallySpeaking, it must first be determined where on the network the Master Roaming User Profiles should be located. Before enabling and configuring the Roaming feature on individual machines, set up the network location(s) for the Master Roaming User Profiles. Each location chosen must be accessible to all computers where Roaming User Profiles will be used. The steps below outline the configuration process needed to enable Roaming User Profiles, along with customization options that are available.

Notes:

• Dragon allows storage of a Master Roaming User Profiles on a networked machine that is not a server, also on a Windows server, or on an HTTP server with or without SSL-allowing access to the Master Roaming User Profiles over the Internet. It is also possible to create multiple network storage locations as well as subdirectories for Roaming User Profiles.

• The Dragon Roaming User Profiles feature is only available in Dragon NaturallySpeaking Professional editions and up.

To set up the network location for the Master Roaming User Profile:

1. If choosing to use a networked machine or Windows server, please determine where the Master Roaming User Profiles will reside.

    The Roaming feature supports the following types of:
- **Mapped Drives**: Connects to a shared network folder that has a drive letter assigned to it.

- **UNC Paths**: Connects to a shared network folder using the Universal Naming Convention (UNC) to locate a User Profile. Format is: \\<servername>\<sharename>\<path>\<filename>.

- **HTTP (http):** Connects to machine on the Internet or a local intranet. Format is: http://<myserver.com>/<webdav>

- **HTTP with SSL (https):** Connects to machine on the Internet or a local intranet with SSL. Format is: https://<myserver.com>/<webdav>

2. The location(s) that is being selected must be accessible to all computers where users will dictate with a **Roaming** User Profile. Each location must have adequate storage space for **Roaming** User Profiles.

3. If using an HTTP server, choose one of the supported Web servers:
   - Microsoft Internet Information Services (IIS) 6.0
   - Apache HTTP Server 2.0.54 and higher

4. After the type of machine has been chosen to store the Master **Roaming** User Profiles on, determine the following information so that Dragon can be told how to connect to the HTTP server:

   **Information about the Web Server:**
   - The network location: The URL address of the HTTP server is needed.
   - HTTP settings: For http (or https) connection the authentication, firewall, and proxy server information is needed.

After determining the kind of network node desired to store the Master **Roaming** User Profiles make sure it has enough storage space.

**Important Note:** Be sure to set permissions on the directory that stores Local **Roaming** User Profiles on each work-station to read/write/modify access for all Windows user accounts of Dragon users that will be dictating.

**Enable the Roaming User Profile feature:**


   - **Note:** If a User Profile is open, the Close User Profile to Proceed dialog box opens. Click "Proceed" and Dragon automatically closes the User Profile and opens the Administrative Settings dialog box.

2. On the "Roaming" tab, check "Enable".

3. Click "Apply" to save the changes and keep the dialog box open.

**Note:** With the **Roaming** User Profiles feature enabled, the Open User Profile dialog box later displays only User Profiles in the **Roaming** User Profile storage locations. To let the users open both local (non-Roaming) and **Roaming** User Profiles, check the "Allow non-Roaming User Profiles to be opened" option in the "Administrative Settings" dialog box. Clearing this option prevents users from
dictating with a non-Roaming (local) user by mistake, but please check it if it is needed to ensure users can open existing local User Profiles so that they can be converted to Roaming User Profiles.

**Set location of Master Roaming User Profiles:**

On each computer where users are dictating with Roaming User Profiles, the Master Roaming User Profiles location must be specified (and if necessary, created).

After selecting “Enable” on the “Roaming” tab:

1. Click “Add”. The Roaming User Network Location dialog box displays. Use the “Roaming User Network Location” dialog box to define the network location of the Master Roaming User Profiles that was identified during the “To set up the network location for the Master Roaming User Profile” steps.
2. Set the “Display Name” to the way the name of the directory should display in other product dialog boxes.
   - Note: The display name later appears in the “Roaming” tab of the “Administrative Settings” dialog and the “Location of User Profiles” text box of both the “Open User” and the “Manage Users” dialog boxes.
3. Set the “Network Location” to be used.
4. If a Web server is being used to store Master Roaming User Profiles, click the “HTTP Settings and SSL Settings” (if using HTTPS) button to set information about the HTTP and HTTPS connection, and proceed with HTTP Settings and SSL Settings for further information. After entering the “HTTP” and “SSL Settings”, use the “Test Connection” button to make sure your settings are correct.
5. Click “OK” in the “Roaming User Network” Location dialog box.

**Note:** You cannot create a non-Roaming User Profile on an HTTP connection. You can only create Roaming User Profiles on an HTTP connection when Roaming is enabled

**Set location of Local Roaming User Profiles:**

When a user opens a Master Roaming User Profile, Dragon transfers a copy of that User Profile to the local machine. That local copy is called the “Local Roaming User Profile”. This is the location on the computer where changes made during a dictation session (such as corrections or new acoustic data) are stored before they are synchronized with the Master Roaming User Profile. It is possible to set this location (called <Roaming Local>) from the Administrative Settings dialog box.

To accept the default <Roaming Local> location (which Nuance recommends), click “OK” on the Administrative Settings dialog box. A prompt to create the default directory if it does not already exist will be presented. When this message is presented click “Yes”.

The default location of <Roaming Local> is:

- C:\Program Data\Nuance\NaturallySpeaking11\RoamingUsers\<display name>\<username>
- C:\Program Data\Nuance\NaturallySpeaking12\RoamingUsers\<display name>\<username>
- Where:
• The <display name> is defined for the Master Roaming User Profile location.
• The <username> is the name of a local copy of the Master Roaming User Profile, which becomes the Local Roaming User Profile.

To change the default location of Local Roaming User Profiles:

1. Use the "Browse for Folder" dialog box to open a location where you want to store the Local Roaming User Profile.
2. If the directory does not exist, click "Make New Folder" and type a name for the new folder.
3. Click "OK".

Set Roaming User Profile options:

The "Administrative Settings" dialog box also contains several options that affect how this feature works. Select the options that indicate how it is desired for the Roaming User Profile to function at each Roaming User Profile location.

In Dragon, it is possible to set an option to display a dialog box to save the User Profile to the local cache or the master location. The dialog appears when the User Profile or Dragon is closed.

Note: If dictating with a Roaming User Profile, the "Acoustic and Language Model Optimizer Scheduler (Accuracy Tuning)" is disabled on the local user's machine. The "Acoustic and Language Model Optimizer" must be run on the machine where the Master Roaming User Profile is located, or it can be run from an administrator's workstation.

Information on Roaming Options in Dragon NaturallySpeaking

Information:

The "Administrative Settings" dialog box contains several options that you can choose from to indicate how you want the Roaming feature to function at each Roaming User Profile location.

Display Classic Open User Profiles dialog: Enable this option to display the Classic Open User Profile dialog box. The setting configures the dialog box to display only folders that contain actual Dragon User Profiles in the Location of User Profiles box.

Note: For faster performance at large sites with Roaming User Profile directories, Nuance recommends using the default appearance for the Open User Profile dialog box. Displaying the Classic Open User Profile dialog box takes longer because Dragon first verifies that directories contain valid Dragon User Profiles. Directory structures do not display with the Classic setting.

Allow non-Roaming User Profiles to be opened: Select this box if you need to open non-Roaming (local) User Profiles. Nuance recommends clearing this option to prevent anyone from dictating with a non-Roaming (local) User Profile by accident.

Merge contents of vocdelta.dat into network User Profile when file is full: Select this box to copy the contents of the local "vocdelta.dat" file to the Master Roaming User Profile without running the Acoustic and Language Model Optimizer. If you check this
setting, Dragon monitors the size of the "vocdelta.dat" file. When the "vocdelta.dat" file reaches 90% of its maximum size (500 KB), Dragon copies the contents of the "vocdelta.dat" to the local cache and then to the Master Roaming User Profile and subsequently deletes the contents of the local "vocdelta.dat" file. This operation occurs when you open the local Roaming User Profile and can take some time.

**Note:** Selecting this option can increase how long it takes to open a Roaming User Profile.

**Access network at User Profile open/close only:** Select this box to synchronize changes made to the local Roaming User Profile to the Master Roaming User Profile only when a local Roaming User Profile opens or closes. These changes include the changes a user makes locally from the Options dialog box. If this box is not selected, then these local changes are immediately transferred to the Master Roaming User Profile.

**Note:** If you experience excessive network slowdowns, checking this option may solve the problem by limiting the number of times the Local and Master Roaming User Profiles are synchronized.

**Ask before breaking locks on network User Profiles (recommended for UNC and mapped drives):** Select this box to keep the option of maintaining or breaking a network lock when opening a Roaming User Profile. Normally, network locks prevent anyone from opening a Roaming User Profile at the same time someone else is opening that User Profile. While this process does not take a long time, network problems can cause a lock to become "stuck" and not release when the opening process is completed. When this happens, the next time anyone tries to open that User Profile, Dragon displays a message stating that the User Profile is locked and giving them the option of overriding it. If you do not want this message displaying and always want to break a network lock in this situation, you can clear this option to prevent the message from appearing. Because the presence of a lock can indicate a problem that needs to be addressed, Nuance recommends that you enable this option.

**Notes:**

- This option is valid for users connecting to the Master Roaming User Profile location using a mapped drive or UNC drive, but is not supported for users connecting over HTTP.
- Be careful when breaking a locked Roaming User Profile. For example, if you break a lock when another user is writing to the Master Roaming User Profile, breaking the lock may corrupt the Master Roaming User Profile.

**Set audio levels on each machine (recommended):** Select this box to run the "Check Your Microphone" option from the "Accuracy Center" window before your first session with a Roaming User Profile. This includes the "Volume Check" and the microphone "Quality Check". Check this option if your users are dictating on different machines or on a single machine, like a laptop, in many different locations. When a user changes machines or locations, the audio setup data can vary depending on differences in the microphone and sound card, as well as differences in ambient sound levels of each Roaming User Profile location. In situations where Dragon detects a significant difference between operating systems, sound cards, microphones, or other hardware, the program prompts you to run "Check Your Microphone" even if you do not have this option selected.

**Save acoustic information:** Select this box to make sure that your acoustic information is saved along with your local User Profile. By saving the acoustic information, you make sure that any corrections you make will be available after you close and re-open the User Profile. This option also makes sure that these corrections will be synchronized between the Local and Master Roaming User Profile if you also enable the "Always copy acoustic information to network" option.
**Note:** This option is turned on by default.

**Copy Dragon Log to Network:** Select this box to copy the Dragon.log file from the local workstation to the Master **Roaming** User Profile location whenever the program synchronizes the local and Master **Roaming** User Profile. The Dragon.log contains information that can help to diagnose problems that users may encounter using Dragon.

**Note:** The Dragon.log file will not be copied once the maximum size is reached in the "Disk space reserved for network archive" option. Selecting this option can increase how long it takes to close a **Roaming** User Profile.

**Always copy acoustic information to network:** Select this box to copy the User Profile’s acoustic information to the Master **Roaming** User Profile location.

**Note:** If you chose not to copy the User Profile’s acoustic information to the network, corrections you make on one machine will not be available on other machines used by that particular **Roaming** User Profile until you run the “Acoustic and Language Model Optimizer” on the Master **Roaming** User Profile location, which will synchronize the Local and Master **Roaming**. By always copying the acoustic information to the Master **Roaming** User Profile location, you ensure these corrections are always available and will be automatically synchronized when the Master **Roaming** User Profile is opened from another location.

The Local **Roaming** User Profile acoustic information is stored in:

- **Windows XP:**
  - Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking11\RoamingUsers\<display name>\<username>\current\voice
  - Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\RoamingUsers\<display name>\<username>\current\voice

- **Windows 7, Vista and Server 2008:**
  - C:\ProgramData\Nuance\NaturallySpeaking11\RoamingUsers
  - C:\ProgramData\Nuance\NaturallySpeaking12\RoamingUsers

  Where the `<display name>` is the name you assigned the Master **Roaming** User Profile location and the `<username>` is the name of the individual Master **Roaming** User Profile.

**Prompt before saving to network location:** Select the "Prompt before saving to network location" option to display a dialog box that lets you choose where to save your user profile. Dragon displays the dialog box when you attempt to close Dragon, close a user profile, or shut down the operating system. The dialog box displays an estimate of the time required to save the profile to the local cache or the master location. This option is turned off by default.
• To save the user profile to the local cache, in the dialog box, select “Save Locally”. If you are on a slow network, you can save the user profile to the local cache to avoid waiting for the profile to synchronize with the master profile in the master location.

• To save the user profile to the master location on the network, in the dialog box, select “Save to Network”. Nuance recommends that you save a user profile to the master location for accuracy improvement and to ensure that updates to the profile are available on other computers.

**Conserve archive size on network**: Select this box to prevent the copying of ".DRA" files (files that contain the acoustic data from the latest dictation session) to the Master **Roaming** User Profile location when the program synchronizes the Local and Master **Roaming** User Profiles. Leaving this box unchecked allows the local ".DRA" files to synchronize with the Master **Roaming** User Profile, which makes the ".DRA" files available to the "Acoustic and Language Model Optimizer" when it is run on the Master **Roaming** User Profile locations and provides increased accuracy.

However, because ".DRA" files can be large, if you experience excessive network slowdowns, checking this option may solve the problem by eliminating the copying of these files each time the Master and Local **Roaming** User Profiles synchronize. You can still run the "Acoustic and Language Model Optimizer" on the Master **Roaming** User Profile, but since it will not have the ".DRA" files to process, the accuracy gains will be less.

**Note**: The ".DRA" files will not be copied once the maximum size is reached in the "Disk space reserved for network archive" option.

**Disk space reserved for network archive**: Use this option to specify the maximum size of the network directory containing the acoustic data available to the "Acoustic Optimizer". By default the network archive size is 500 MB per dictation source for **Roaming** User Profiles. To conserve space, you can reduce the default size and select the "Conserve archive size on network" option.

---

**Converting a local Dragon user profile to a roaming Dragon user profile**

To save an existing user profile to a **roaming** user profile:

1. Launch Dragon.
2. Click "Tools > Administrative Settings".
3. Check the box named "Enable".
4. Click "Add" and add the location desired to store the **roaming** profile.
5. Choose a display name.
6. Click "OK".
7. Check the box named "Allow non-Roaming User Profiles to be opened".
8. Click "Apply" then "OK".
9. Click "Profile > Manage User Profiles..." in the Dragon bar.
10. Change "Location of user profile:" to the default local user profile location.
11. Select the local Dragon user profile from the list above.
12. Click "Advanced > Save to **Roaming**".
The local Dragon profile has now been configured as a Roaming user profile. The "Location of user profile" should then be set to the roaming display name in order to open the roaming user profile.

Note: If it is desired to prevent users from logging into Dragon with a non-Roaming user profile please click "Tools > Administrative settings" and uncheck "Allow non-Roaming User Profiles to be opened".

Cisco Security Agent Prevents NaturallySpeaking from Running

Cause:

If Cisco Security Agent is running, this problem occurs. To find out whether Cisco Security Agent is running, look for an icon in the Windows taskbar whose tool tip reads "Cisco Security Agent" when the mouse is placed over it.

Solution:

Note: Before performing these steps, make sure that your system will display all hidden files and folders. Also make sure that file extensions are shown. These options are available by going to “My Computer > Tools Menu > Folder Options > View” tab.

Part 1: Deleting all *.exe.local files created by Dragon NaturallySpeaking

1. Click “Start > Find > Files and Folders” or “Start > Search > Files and Folders” to open the Find window.
2. Make sure that “Find” is set to search the primary hard drive (usually drive C) and that “Include All Subfolders” is selected.
3. Search for all of the files with the extension “*.exe.local”
4. Look through the search results for the following files: (All *.exe.local files in the Dragon NaturallySpeaking Program directory (by default this is c:\Program Files\ScanSoft\NaturallySpeaking\Program))
   - Winword.exe.local
   - iexplore.exe.local
   - wpwin.exe.local
   - Excel.exe.local
   - Natspeak.exe.local

5. If these files are found, delete or rename them. Do not delete any .exe.local files other than the ones listed in the previous step.

Part 2: Changing the natspeak.exe to run in NT4 compatibility mode (otherwise it refuses to start due to absence of natspeak.exe.local).

1. Click “Start > Find > Files and Folders” or “Start > Search > Files and Folders” to open the Find window.
2. Make sure that “Find” is set to search the primary hard drive (usually drive C) and that “Include All Subfolders” is selected.

3. Search for “natspeak.exe” that is located in the Dragon NaturallySpeaking install folder. (by default this is in c:\Program Files\ScanSoft\NaturallySpeaking\Program)

4. Right-click on natspeak.exe and choose “Properties”.

5. Click on the “Compatibility” tab, check "Run this program in compatibility mode" and choose "Windows NT 4.0 (Service Pack 5)".

SDAPI or Internal Recognizer Error

![Dragon NaturallySpeaking Error Message]

Your current user-files are corrupted. Click the Close button and switch to your backup user-files (Option #4)

Testing Your Microphone and Soundcard for Speech Recognition Usability

This test works on any Windows 95, 98, NT, 2000 & XP OS computer. Some menu items or dialog boxes slightly differ in the various operating systems.

FOLLOW THESE STEPS:

Start Windows Sound Recorder:
1. Start Button – Programs – Accessories – Multimedia or Entertainment (depends on version of Windows) – Sound Recorder.

2. Change the Audio Format to CD-Quality or 48,000 kHz for Windows XP via the following: File (Menu) – Properties – Convert Now – Drop Down list by “Name” – CD-Quality or 48,000 kHz mono 16 bit for Windows XP.

3. Make a short recording by pressing the Red Button and say something profound like, “I can't believe I paid so much for this software and it still doesn't work right.”

4. Click the button with the black rectangle to stop the recording.

5. Click the middle button with the right facing black arrow to initiate Playback.

6. Listen carefully by using good headphones or high-quality external speakers.

EVALUATING THE TEST

- If the playback sound was clear with no electronic noise or static, your hardware is probably fine for using speech recognition software.

- If there was any electronic noise, you should repeat the test. Make sure the Audio Format remained on CD-Quality. On most versions of Windows the Audio Format defaults to a lower quality each time you begin a new recording.

- Repeat the test using a different microphone, if available. Although the microphone that came with the speech recognition software is not the best, it should be sufficient for this test. If two different microphones yield electronic noise, the likely culprit is the soundcard. You have several choices which are described later on.
WHAT IF NOTHING WAS RECORDED?
1. Make sure the microphone input plug is in the microphone input outlet of the soundcard. Make sure the On/mute switch, if there is one, is in the On position.
2. Double click, not single click, the Yellow Speaker icon in the System Tray. The System Tray is the lower right Taskbar area of your desktop. This brings up the Volume Control(s) for Audio Output.
3. The Microphone Output Control should have a check mark in the “Mute” box. This prevents your voice dictation from feeding back to the earphone/speakers while dictating.
4. If there is an Advanced Button, click it. If not, click the Options Menu and select Advanced if it is available (skip the following if there is no Advanced Option). Many soundcards have a choice to increase the output. This is can be called Microphone Boost, Microphone Gain, +20dB, etc. If the option is available, select it.
5. Next, click the Options menu, click Properties, select the Recording option under Adjust volume. Make sure the Microphone is selected with a checkmark in the box that says, “Show the following Volume Controls.”. Click OK. Then adjust the microphone slider within one notch of the top. Make sure the box to Select the microphone is checked. Make another Windows Sound Recorder Test.

Changing DragonPad's Default Font Size

The Windows Vista, Windows 7/8 address is ~ C:\ProgramData\Nuance\NaturallySpeaking13\Users\(your username)\current\Options.ini

Type (on 2 separate lines)

enx Default Font=Times New Roman
enx Default Font Size=240

The above is an example of how to set font to 12 point. Multiply the desired point size by 20, e.g. 15 point would be 280 and 16 point would be 320. Click on File, Save.

Eliminate Excess Bootup Programs in Windows:

Select "Start"~ "Run" msconfig
After it opens click the "Startup" tab
Uncheck anything that appeals to you

Preset to Open Any User Automatically:

Option #1:
If you are using KnowBrainer Professional 2017 simply double-click the KnowBrainer shortcut on your desktop which will open KnowBrainer 2016, launch NaturallySpeaking, automatically choose your most recent user profile (if you have more than one to choose from) and select your most recent vocabulary (if you have more than one). If you’re not using KnowBrainer, see options are

Option #2:
1. Open the Dragon Options dialog and select "Launch Dragon in QuickStart mode when Windows starts" from the Miscellaneous tab.
2. Go to the Windows Startup folder (Start menu | All Programs | Startup).
3. Highlight or select the Dragon NaturallySpeaking icon, right-click, and select properties.
4. In the text entry for the Target: Text box, Remove /Quick and replace it with /User "username" (remembering to put the username in quotation marks and not to alter any other portion of that line, as well as making sure that "User" is capitalized – title case and also remembering that the username must be entered exactly as it is in the user folder name. That is, if the username is not correct, then Dragon will not load it automatically.)
Note that if you are using a 64 bit OS the previous address is "C:\Program Files (x86)\Nuance\NaturallySpeaking12\Program\Natspeak.exe" /user "Your user name" and you won’t need the last set of quotes if your user name is a single word like Dave or Dave23.

5. Click on the Apply button (just a safety measure) and then click OK.
6. The next time you boot, your user profile will be loaded along with Dragon automatically.

This works for both Windows XP and Windows Vista/Windows 7/8. It isn't necessary to unselect the "Launch Dragon in QuickStart mode on Windows startup" from the Dragon options | Miscellaneous tab because this is handled automatically once you make the changes in the Startup folder. That is, it's automatically unchecked anyway once you make the changes. The reason that works for all versions of Windows is that the Target: Text box line is accessible and modifiable in all cases when the QuickStart shortcut is entered in the Startup folder. If the user drags and drops or otherwise copies the shortcut on the desktop to the Startup folder, they won't be able to access anything to make the appropriate changes. In other words, this approach is a one-size-fits-all so that you don't have to make a distinction between Windows XP and Windows 7/Windows Vista.

Swap File Settings for NatPro:

**Windows XP:** Click "My Computer", "Control Panel", "System". Click on the "Advanced" tab, click on Settings in the Performance section, Click the "Advanced" tab, Click the "Change" button and Click “Custom size” The minimum/maximum must be exactly the same size. Otherwise the Swapfile is not Permanent and files Swapped out to disk can be placed in any random area. We suggest 756 for 512 megs of RAM, 1134 for 768
megs of RAM, 1536 for 1 Gb of RAM, 3072 for 2 Gb of RAM, 4608 for 3 Gb or RAM and 6154 for 4 Gb of RAM. Click the “Set” button and then Click OK.

**Windows Vista or Windows 7:** "Control Panel", "System", Advanced System Settings. Click on the "Advanced" tab, click on Performance “Settings”, "Advanced" tab, Click the “Change” button and Click "Custom size" The minimum/maximum must be exactly the same size. Otherwise the Swapfile is not Permanent and files Swapped out to disk can be placed in any random area.. We suggest 756 for 512 megs of RAM, 1134 for 768 megs of RAM, 1536 for 1 Gb of RAM, 3072 for 2 Gb of RAM, 4608 for 3 Gb or RAM and 6154 for 4 Gb of RAM. Click the “Set” button and then Click OK. Note: You also have the option of clicking **No Paging file** which will force everything into RAM but this may produce other problems so proceed with caution if you choose this option.

**Formatting Numbers:**

Check under Options|Dictation and see if there is check mark by "Format numbers, telephone numbers,........automatically." Also if dictate "one two three" and Nat types "one two three" - if you then say "Format That Numbers" Nat will change the typed "one two three" to "123" - conversely if you dictate "one two three" and Nat types "123" say, "Format That Spelled Out"

**Eliminate Start Up Items**

Start/Run /MSConfig
Select “Selective Startup”
Select items from within the “Startup” tab

**Copying User Files from One Computer to Another**

Option #1 (Manufacturer Recommendation):

1. Say or choose Manage Users
2. Click Advanced
3. Click Export to export a copy of your user files
4. Copy the exported folder to a thumb drive and reverse the process (chose Import) on your second computer

Option #2 (Windows Explorer):

1. Copy the following folder on your host computer In Win XP your user folder is at ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\(Your User Name)\ folder and in Win
Vista/7 it is at ~ C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\ folder onto a flash drive or over a network.
2. Create a new user, with the same name, on the new computer.
3. Exit NaturallySpeaking without completing training.
4. Replace computer ~ C:\Documents and Settings\All Users\Application Data\ Nuance \NaturallySpeaking12\Users\(Your User Name)\ folder with the folder from your flash drive and launch NaturallySpeaking.

**Note: Note: You will not be able to locate the Application Data folder if your computer is set to the default manufacturer settings which are to hide hidden files and folders. In order to view your hidden files in Windows Vista/ 7, open any folder or Windows Explorer, select Folder Options from the Tools menu, click the View tab, click on "Show hidden files and folders" and press the OK button. If you’re using Windows 8, open any File Explorer folder, click the View menu, click Options, click the View, check "Show hidden files and folders" and press the OK button.**

**Switching to Backup Speech Files:**

**Option #1:**
1. Left-click Manage User Profile under the DragonBar Profile menu
2. Select the defective user profile and left-click on the Advanced button
3. Select Restore and follow the remaining prompts

**Option #2:**
1. Go to your ~ C:\Documents and Settings\All Users\Application Data\ Nuance \NaturallySpeaking12\Users\(your username)\current folder in Windows XP. The Windows Vista or Windows 7/8/10 address is ~ C:\ProgramData\Nuance\NaturallySpeaking13\Users\(your username)\current
2. Rename the "current" folder to "old"
3. Rename the "backup" folder to "current" ~
4. Relaunch NaturallySpeaking.

**Note #1:** If the problem is in your user file rather than NaturallySpeaking then renaming the backup" folder to "current" tells NaturallySpeaking that you want to use a backup copy of your user files that is only 5 saves out of date. By default, NaturallySpeaking overwrites the backup folder once every 5 times you save your user files. With a little luck, your backup user files have not been contaminated.

**Note#2:** Note: You will not be able to locate the Application Data folder if your computer is set to the default manufacturer settings which are to hide hidden files and folders. In order to view your hidden files in Windows Vista/ 7, open any folder or Windows Explorer, select Folder Options from the Tools menu, click the View tab, click on "Show hidden files and folders" and press the OK button. If you’re using Windows 8, open any File Explorer folder, click the View menu, click Options, click the View, check "Show hidden files and folders" and press the OK button.

**Error: The user profile you have selected cannot be accessed**

1. Reboot Windows because is the path of least resistance and should free of any temporary Windows rights issues.
If, after rebooting, if Windows continues to prevent you from opening your user profile use go to C:\ProgramData\Nuance\NaturallySpeaking13\Users. **Note that you will not be able to view the ProgramData folder unless you have previously changed Windows default Folder Options to view hidden files and folders. You may also have to log onto your system as an Administrator to do this, but make sure that your Windows**
user has full access to this folder. Navigate to this folder with Windows Explorer/File Explorer, right-click and choose Properties, then go to the Security tab to review and probably modify the permissions.

How to Enable Dictation in Non-Dragon Friendly Apps

1. Open C:\Users\YOUR WINDOWS USER NAME\AppData\Roaming\Nuance\NaturallySpeaking15\nsuser.ini file in WordPad or NotePad. If you are using the latest release of KnowBrainer Professional 2017, you can optionally say Open NS User.

2. You should see similar entries near the end of the document

```
[.Global\Global Dictation Level]
EXCEL7=0
_WwG=-2

[iexplore|11.00]\Compatibility Module Status]
Global Dictation=1

[dragonbar|15.00]\Compatibility Module Status]
Global Dictation=1

[OUTLOOK|16.0]\Compatibility Module Status]
Global Dictation=1

[chrome|59.0]\Compatibility Module Status]
Global Dictation=1

[.Global\Compatibility Module Status]
Global Dictation=1

[QHSafeTray|9,2,0,1000]\Compatibility Module Status]
Global Dictation=1

[waterfox|54.0]\Compatibility Module Status]
Global Dictation=1

[ONENOTE|16.0]\Compatibility Module Status]
Global Dictation=1

[chrome|60.0]\Compatibility Module Status]
Global Dictation=1
```

Change any Global Dictation=0 entries to Global Dictation=1 (just change the 0 (which means off) to 1 (which means on). Note that you can do this while Dragon is running and you won’t even need to relaunch Dragon.

Fdisk

Insert Windows Boot Disk or Startup disk

1. Type: A: fdisk
2. Press {Enter}
3. Choose Opt #3 - Delete Primary Partition
4. Press {Esc}
5. Choose Opt #1 - Create Primary Partition
6. Press {Esc} twice
7. Reboot to floppy
8. Type A:/format C: {Enter}
9. Insert Windows CD to reinstall Windows

Plan B (our new favorite): Click Take Ownership to take back your Windows rights with a free How-To Geek hack. You will find step-by-step instructions on the previous website but after you download the zip file, double-click InstallTakeOwnership.reg to install. The next time Dragon can’t open your user profile, simply right-click on your C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username) folder and choose the Take Ownership menu.

Correction Command Changing Instructions:

The following instructions will allow you to change the phrase which you have to speak for most of the correction commands. Please note that KnowBrainer already offers several alternatives to numerous problem commands.

A common example of where this feature is useful is in the case of the command "Correct That". Some users complain that when they say "Correct That", the system selects the word "that" or “at” in their document and displays the Correction Dialog for that word, instead of displaying the Correction Dialog for the last word(s) they spoke. To get around this problem, we recommend changing the command which brings up the Correction Dialog from "Correct That" to something different like "Correct That Please".

Additions can be made in the user options.ini file. There is one options.ini file for each voice file you have on your system. To change the command associated with the action "Correct That" do the following with NatSpeak NOT loaded:

1. Locate and open the options.ini file that is associated with the voice file you wish to make a change in the command. As an example, here is the path/file to the options.ini file for one of my voice files named Lunis: C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\Users\Lunis\current\options.ini in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\<your user name>\Options.ini
2) Go to the bottom of the document (you can press {Ctrl+End} to get there) and add the following on a line all by itself:
enx Correct That Command=Correct That Please

When you change any of the correction commands, you are changing it for only one user at a time - you must go through the exercise for each options.ini for each user.

The following table lists all the correction commands which you can change by adding the information to the options.ini file. NOT ALL HAVE BEEN TESTED AS OF 5/19/99 The first column reflects the command name - the second column shows the current command that you speak and is the one that you may change.

<table>
<thead>
<tr>
<th>Scratch That Command</th>
<th>Scratch That</th>
</tr>
</thead>
</table>

74
When replacing any of the correction commands, the change will not take effect until you restart Dragon NaturallySpeaking.

If you introduce your own correction words, do not include any backslash or hyphen characters as this will confuse Dragon NaturallySpeaking.

In some of the commands, the default value includes the string "%1". If you replace these commands (like "Select %1"), then you must remember to include the string "%1" at the end or the command will not work properly.

Remember, these are hacks, if you screw up there is no error checking and the likely effect is that the command you change will not work properly.
Recommended Changes for Word XP

1. Change the security level or macro virus protection to medium or low by going to Tools/Option/Security/Macro Security/Low
2. Some KnowBrainer commands cannot function until Word is set in Full Menu Mode. This is accomplished by going to Tools/Custom/Options and placing a check mark in the Always Show Full Menus box.

What version/spin of NaturallySpeaking is this?

There are two ways of finding out which spin/version of NaturallySpeaking you're using:

Right click on C:\Program Files\ScanSoft\NaturallySpeaking\programs\natspeak.exe, select Properties and click on the Version tab. The latest version of NaturallySpeaking Professional will be 12.

When User Files Go Bad

It's common for an error to occur in the personal user files because it is accessed so frequently. Because of this, NaturallySpeaking automatically creates a backup user which is overwritten every 5 times that you save your user files. If your user files become damaged try the following:

1. Make sure NaturallySpeaking isn't running
2. Rename your current folder, which is located at ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(Your User Name)\current in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username)\current to "old"
3. Rename your backup folder, which is located at ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(Your User Name)\backup to "current"
4. Launch NaturallySpeaking

Installing NaturallySpeaking 5 on Windows XP:

1. Insert the NaturallySpeaking installation CD
2. Exit the NaturallySpeaking auto installation program
3. Browse to the following address on your CD-ROM ~ <CD Drive>:\dns50\redist\spchapi.exe and install the SAPI 4.0.
4. Install NaturallySpeaking

Alternatively you can download SAPI 4 directly from Microsoft by clicking on the following hyperlink ~ http://www.microsoft.com/speech/AppHelp(SAPI4)/sapi4.asp and downloading file #1 "Microsoft speech API 4.0 a".

Note: Do not download file #2 "Microsoft English Text to Speech engine.

What to Do When You Lose Select-&-Say in WordPerfect 8 – X8

Do a search on your computer for dgnwp9.dll. If you already have this file, you'll need to rename it to something like dgnwp9.old; then perform a Repair of NaturallySpeaking via the Add/Remove utility in the Control Panel.

You may additionally have to edit your registry.
• Look in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Corel\WordPerfect\17\Third Party.
• You can search the registry using the regedit provided by Windows by clicking on the Start button, selecting run, and entering regedit in the textbox to the right of "Open:" simply follow the keys by clicking on the + next to HKEY_LOCAL_MACHINE, then SOFTWARE, then Corel, then WordPerfect, then 17, then Third Party. Don't go to WordPerfect Suite because that key does not contain anything relative to Select-and-Say. You will see an entry which has a key name beginning with DLL followed immediately by a number (DLL1, DLL2, DLL3, DLL4... etc.) each one of these entries will be relative to an add-in for WordPerfect. Look to the right under the "Data" column. What you're looking for is the following entry:
• C:\Program Files\Nuance\NaturallySpeaking15\Program\dgnwp9.dll.
• If it does exist, then Select-and-Say IS enabled for WordPerfect X7 (17). If it does not exist at this location (registry key), then Select-and-Say IS NOT enabled for WordPerfect X7 (17). If it is missing, performing a Repair or complete reinstall of DNS will automatically add this entry to that registry key. 

Special thanks to Chuck Runquist for this tip

Note: If after making the previous changes, you are still unable to dictate or utilize Full Text Control in WordPerfect and are using PC Law, you will need to contact PC Law Technical Support for a solution as it is most likely the culprit.

Enabling Select-&-Say in Multiple Word XP Documents

• Say "Options" from within Microsoft Word
• From the View tab uncheck "Windows in Taskbar"

What to Do When You Lose Select-&-Say in Microsoft Word XP & 2003

1. From within Microsoft Word click on Help/About Microsoft Word/Disabled Items/
2. Click on Addin Microsoft Word 2000 support dll (dgnword.dll)
3. Press the Enable button and close the remaining 2 Windows
4. You'll need to close and re-launch Word before this fix will take effect

If the previous steps fail you may want to additionally delete or relocate Microsoft Word's normal.dotm template. If you do not write Microsoft Word macros it is perfectly safe to exit Microsoft Word, delete this template and then re-launch Word. When you reopen Microsoft Word it will re-create the template from a clean backup. You will probably find the normal.dot template at "C:\Documents and Settings\(your user name)\Application Data\Microsoft\Templates\normal.dot"

What to Do When You Lose Select-&-Say in Microsoft Word 2007 - Word 2016

Option #1
1. From within Microsoft Word press {Alt+f} or click the File menu.
2. Click on the Options button.
3. Click Add-Ins from the options on the left side of the Word Options dialog. You should see Manage COM Add-ins displayed at the bottom of the page. If it’s not displayed, make the appropriate change.
4. Click the Go button. Put a checkmark in NatSpeak Word Addin, in the following window, click OK and close and relaunch MS Word. If you find an existing checkmark for NatSpeak Word Addin, remove the checkmark and click OK. Then repeat steps 1 through 3.

If the previous steps fail you may want to additionally delete or relocate Microsoft Word's normal.dot template. If you do not write Microsoft Word macros it is perfectly safe to exit Microsoft Word, delete this template and then re-launch Word. When you reopen Microsoft Word it will re-create the template from a clean backup. You will probably find the normal.dot template at C:\Documents and Settings\(your user name)\Application Data\Microsoft\Templates\normal.dotm in Windows XP. In Windows 7/8/10 you will find it at C:\Users\(your username)\AppData\Roaming\Microsoft\Templates\normal.dotm.

Option #2
If #1 fails, click Microsoft Word/Outlook/Excel Will Not Permanently Allow the Dragon Add-In

What to Do When You Lose Select-&-Say in Microsoft Word 2000

1. Click on your Microsoft Word Tools menu
2. Click on "Templates and Addins" and make sure that Addin: natspeak word addin (dgnword.dll) is displayed and checked

How to Disable the Microsoft Speech Engine in Office XP

Go into your Control Panel, click Start > Control Panel and then double-click "Add/Remove Programs". When this window opens scroll down to Microsoft Office and click on it to highlight it. Click the "Change Button". This will open the Add/Remove wizard. Click the radio box next to "Add/Remove Features" and click "Next". In the next window click the "+" sign next to "Office Shared Features" then click the "+" sign next to "Alternative User Input". You will see "Speech" in this list. It should have a "X" next to it. If it does not, click the icon next to "Speech" and select "X - Not Available". Then click the "Update" button located at the bottom.

How-to speed up Windows XP

1. Open the Windows Control Panel
2. Double-click on System
3. Click on the Advanced Tab
4. Click on the Settings button in the Performance section
5. Place a check mark in the "Adjust for Best Performance" and click "Okay"

Windows will lose some of its eye-catching appeal but the bump in performance is noticeable

How to Find Static IP Address in Windows 2000/XP

1. Start/Programs/Accessories
2. Click on Command Prompt
3. Type ipconfig
4. Or… just say “Find Local IP Address” (if you are using a router) and if you are not using a router but are connected to the internet say “Find My IP Address” to locate your REAL IP address

**How to Find Static IP Address in Windows 95/98/ME**

Start/run/winipcfg

**How to Manually Remove NaturallySpeaking and Unnecessary Taskbar Items**

This procedure will conduct a thorough manual uninstall of Dragon NaturallySpeaking.
As you will be asked to make some edits to the registry, it is advised that you make a backup of the Registry before step 17.

1. Go to START => RUN, and type in the word “msconfig” (without the quotes). Press the ENTER key.
2. Go to the STARTUP tab, and remove all of the checkmarks except for the one next to System Tray and the one next to Scan Registry.
3. Click APPLY, and OK, and choose to reboot when asked.
If the user has a version older than Dragon NaturallySpeaking version 5, then…
4. Open C:\NATSPEAK and make a copy of the USERS folder if one exists otherwise, go to step 7.
5. Rename the copy of the USERS folder to “users-v3”
6. Move the USERS-V3 to the MY DOCUMENTS folder.
If the user has version 5, then
Note: Version 6 uses Dragon instead of Dragon Systems
7. Open C:\PROGRAM FILES\DRAGON SYSTEMS\NATSPEAK and make a copy of the USERS folder if one exists otherwise, go to step 10.
8. Rename the copy of the USERS folder to “users-v6”
9. Move the USERS-V6 to the MY DOCUMENTS folder.
10. Go to the Add/Remove Program Control Panel, and remove all entries beginning with the word “Dragon.”
11. Reboot.
12. Uninstall Microsoft Office in order to remove all components which were installed by NaturallySpeaking versions.
13. Reboot.
14. Delete C:\NATSPEAK.
15. Delete C:\PROGRAM FILES\DRAGON SYSTEMS.
16. Remove C:\WINDOWS\SPEECH\DRAGON.
17. Go to START => RUN, and type in the word “regedit” (without the quotes). Press the ENTER key.
18. Go to HKEY_LOCAL_MACHINE\Software, and remove any entries beginning with the Word “Dragon”, “Dragon Systems”, or “ELAN.”
19. Exit the registry editor.
20. Run a Disk Cleanup (removing all temporary files), a Scandisk, and a Defrag.
22. On your desktop, create a folder called INSTALL.
23. Insert the Dragon NaturallySpeaking version 5 disk into the CD reader, and copy the contents to the newly created INSTALL folder.
24. Remove the Dragon NaturallySpeaking CD from the drive.
25. Install Microsoft Office, and reboot.
26. Run SETUP.EXE from the INSTALL folder on the desktop.
27. Reboot.
Skipping or Temporary Loss of Audio

Skipping is caused by the NIC (network interface card) searching for packets even when not connected to the network. The simplest way to handle this is to disable the NIC while dictating. Go to Device Manager, click on the plus sign next to Network Adapters and then right click on the Xircom. Choose Disable in the pop up list.

Making a Windows Sound Recorder Recording

2. Click the File Menu - Properties - Convert Now button.
3. In the Name drop down list select 48, 000 16 bit Mono or CD Quality. Each time you make a new recording it will default back to the previous setting.
4. Click back to Sound Recorder.
5. Click the Edit Menu - Audio Properties. Make sure the Preferred Recording device in the drop down list is selected for the sound card or USB pod your microphone is connected to. Check the Volume and or Advanced settings to adjust more or less audio input. Some microphones require you place a check in the box (if you have one) for Microphone Gain or Boost. Only use this Gain setting if your recording level is very low.
6. Click out to Sound Recorder.
7. Make a recording by clicking on the Red button. Dictate for 5 seconds. If you have an On/mute switch make sure it is in the "On" position. As you record, the flat green line should show bubbles as the sound comes through. Hit the rectangular black button to stop recording, then hit the playback arrow to play back the sound. Sound playback should be clear and free of static or electronic noise. If not, check that you have set CD-Quality for the Audio Format and record again. If there is noticeable noise, you may need another sound card or need to use a USB sound pod.

Note: Different versions of Windows may have slightly different settings.

Eliminate Double Letters in MS Word

Try disabling “Spelling as you Type”

To Perform a Clean Install of NaturallySpeaking do the following:

1. Press the Start button
2. Select Run from the Start menu
3. Type “msconfig” (minus the quotes) and press the OK button
4. Check Selective Startup
5. Uncheck Load Startup Items
6. Click the OK button
7. Click the Restart button

Note: After you successfully finish and test your installation, perform the previous steps in reverse order.

Updating KnowBrainer

Say “Download KnowBrainer” to download the latest version of KnowBrainer for Windows XP-Windows 8
Say “What's New in KnowBrainer” to see the latest KnowBrainer updates

*Note: The commands can only work if you are connected to the internet*

**How to Boost the Soundcard Input Gain (not available on USB pods)**
1. Click the Start Button/All Programs/Accessories/Entertainment/Sound Recorder
2. Click Edit/Audio Properties
3. Click the Sound recording Volume button
4. Click Advanced
5. Place a checkmark in the 1 AGC box (Automatic Gain Control)

If you can open Windows Sound Recorder, go to the Edit Menu, Audio Properties. Click the Volume button for Sound Recording Preferred device. Then in the Wave In control, click the Advanced button. Then put a check mark in 1 AGC Depending on your operating system, there may be some variations on the instructions to get the boost activated.

**How to Boost Sound Input from within NaturallySpeaking**

Add the following line:
 MicBoostState=01000000

To your ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(your user name)\current\audio.ini in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\audio.ini file

**Where Are My Commands and Options Stored**

If you need to create a new user you can copy your previous settings (options) and personal commands from your old user. They are located at ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(Your User Name)\current in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\current Just copy the “Options.ini” and “MyCmd.dat” files from your old current folder to your new user current folder.

**How to Eliminate the Extra Space Before the :/colon**

1. Say "Open Vocabulary Editor"
2. Scroll up until you locate the colon command.
3. Click the properties button
4. Select "Insert Spacing and Capitalizes the Following Word"
5. Press the OK button

**How to Fix Window Focus Problem**

Open Windows System Registry
Set the following key to 1
HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundFlashCount
Set the following key to 0
HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundLockTimeout
Reboot Windows 7/8.1

HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundLockTimeout

How To Change/Edit NaturallySpeaking's Hardcoded Commands
Example: You can change the name of the "Correct That" via the following:

1. Exit NaturallySpeaking
2. Double-click on C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\(Your User Name)\Current\Option.ini file " in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking12\Users\(your username)\Options.ini and when prompted to chose a program to open with, chose WordPad or NotePad.
3. Add the following line to the middle of this file (anywhere between [Options] and [Server Overrides] on a separate line:
   enx Cap That Command=Capitalize That
   enx Correct That Command=Fix That Please
   enx no caps That Command=No Capitalize That
   enx all caps That Command=All Capitalize That
   enx Insert Before Command=Before %1
   enx Insert After Command=After %1

4. Save the file and relaunch NaturallySpeaking.

You'll no longer be able to say "Correct That" button you will be able to say "Oops" which tends to be less prone to error. If you prefer some other phrase feel free to substitute it. Note: “Correct” works quite well and is already included in KnowBrainer.

If you would like to change other hardwired commands please note the following formulas:

<table>
<thead>
<tr>
<th>Scratch That Command</th>
<th>Scratch That</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cap That Command</td>
<td>\Cap That</td>
</tr>
<tr>
<td></td>
<td>NOTE: &quot;\Cap&quot; is the name of the word, you do not need to use a backslash if you replace this word.</td>
</tr>
<tr>
<td>Cap Selection Command</td>
<td>\Cap Selection</td>
</tr>
<tr>
<td></td>
<td>NOTE: See comments for &quot;\Cap That&quot;</td>
</tr>
<tr>
<td>No Caps That Command</td>
<td>\No-Caps That</td>
</tr>
<tr>
<td></td>
<td>NOTE: &quot;\No-Caps&quot; is the name of the word, if you replace this with a different</td>
</tr>
</tbody>
</table>
word, do not use a backslash or a hyphen.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Caps Selection Command</td>
<td><code>No-Caps Selection</code></td>
<td>NOTE: see comments for &quot;\No-Cap That&quot;)</td>
</tr>
<tr>
<td>All Caps That Command</td>
<td><code>All-Caps That</code></td>
<td>NOTE: see comments for &quot;\No-Cap That&quot;)</td>
</tr>
<tr>
<td>All Caps Selection Command</td>
<td><code>All-Caps Selection</code></td>
<td>NOTE: see comments for &quot;\No-Cap That&quot;)</td>
</tr>
<tr>
<td>Compound That Command</td>
<td><code>Compound That</code></td>
<td></td>
</tr>
<tr>
<td>Compound Selection Command</td>
<td><code>Compound Selection</code></td>
<td></td>
</tr>
<tr>
<td>Hyphenate That Command</td>
<td><code>Hyphenate That</code></td>
<td></td>
</tr>
<tr>
<td>Hyphenate Selection Command</td>
<td><code>Hyphenate Selection</code></td>
<td></td>
</tr>
<tr>
<td>Select Again Command</td>
<td><code>Select Again</code></td>
<td></td>
</tr>
<tr>
<td>Select XYZ Command</td>
<td><code>Select %1</code></td>
<td>NOTE: The command must end in &quot;%1&quot; to work properly. The &quot;%1&quot; will be replaced at run time with text from the screen.</td>
</tr>
<tr>
<td>Correct That Command</td>
<td><code>Correct That</code></td>
<td></td>
</tr>
<tr>
<td>Correct XYZ Command</td>
<td><code>Correct %1</code></td>
<td>NOTE: see comments for &quot;Select %1&quot;)</td>
</tr>
<tr>
<td>Press Button</td>
<td><code>Click %1</code></td>
<td>NOTE: see comments for &quot;Select %1&quot;)</td>
</tr>
<tr>
<td></td>
<td>EXAMPLE: Press Button=Check %1</td>
<td></td>
</tr>
</tbody>
</table>

Some Working Examples:

```plaintext
enx Correct That Command=Nope
enx Correct XYZ Command=Fix %1
enx Default Font=Times New Roman
enx Default Font Size=240
```

How to Delete Specially Marked Words From the Vocabulary Editor in Ver. 7.3 (not required in DNS 8 or above)

1. Double-Click on ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\nssystem.ini
2. Place the Cursor on the end of the first line
3. Press the {Enter} Key to create a new line
4. Type “Allow All Deletions=1” (minus the quotes)
5. Close and save the changes
Or Just say “Allow Vocabulary Deletions”

**How to Utilize Pre-existing Microsoft Word Macros**

Use NaturallySpeaking's Advanced-Scripting technique and add the following line of code:
"Word.Application.Run 'macroname'"

**Microsoft Word Types □ When I Say “Paste That”**

Commands that require the use of the {Ctrl} Key sometimes move too quickly for MS Word. You can either edit or create a new command such as the following example:

Replace `SendKeys "{Ctrl+c}"` with `SendSystemKeys "{Ctrl+c}"` or simply unselect the MS Word Option “Use Smart Cut and Paste” via Tools/Options Edit Tab. However, we recommend that you substitute KnowBrainer commands for NaturallySpeaking commands when using Microsoft Word. Example: substitute the KnowBrainer "Paste" command for NaturallySpeaking's “Paste That” command.

**How to 86 dra Files**

**V7**

To prevent dra files from accumulating say "Miscellaneous Options", click on the Advanced button and place a checkmark in "Conserve Disk Space Used by the Speech Files (for Portability)".

**V8**

To prevent dra files from accumulating say "Data Options" and place checkmark in "Conserve Disk Space Used by the Speech Files (for Portability)"

**Splitting Up Your Text Vocabulary**

1. Export your vocabulary as a text file via Words/Export to the desktop
2. Right mouse click on the vocabulary and select *Copy*
3. Right-click on an empty area of the desktop and select *Paste*
4. You will now have 2 carbon copies of your vocabularies.
5. Double-click on either one of the files and move the cursor down the page until you get to the first word that begins with the letter "M".
6. Make sure that the cursor is at the very beginning of the word and then press {Ctrl+Shift+End} which should highlight the last half of the document.
7. Press the {Delete} key, save the remaining half of the document and exit the program.
8. Double-click on the other document and move the cursor down the page until you get to the first word that begins with the letter "N"
9. Make sure that the cursor is at the very beginning of the word and then press {Ctrl+ Shift+Home} which should highlight the first half of the document.
10. Press the {Delete} key, save the remaining half of the document and exit the program.
11. Import either one of your 2 vocabularies via the Words/Import menu item. After NaturallySpeaking finishes importing the first vocabulary, move onto the second. If the second vocabulary fails to import (which occasionally happens), exit and relaunch NaturallySpeaking. Relaunching NaturallySpeaking will reinitialize
NaturallySpeaking’s settings which should permit an error-free import of the second half of your vocabulary.

How To Prevent Initial Capitalization Lock on (Title Case)
This is a NaturallySpeaking bug that has been around since Version 6. Although you cannot prevent this problem from occurring you can easily work around it by using a handful of commands in KnowBrainer 7.23 or higher. When you want to make a correction via the drop-down Select-&-Say correction feature or the Spell That Correction Dialog Box substitute “Pick <1-9>” for “choose <1-9>”. Example, if you say "Pick 3" KnowBrainer will choose the third word/s, move the cursor to the end of the current paragraph and turn off Title Case. If you decide to dictate your correction and wish to move the cursor to the end of the current paragraph, line or document say “End of Line”, “End of Paragraph” or “End of Document”. These commands also contain a script to turn off Title Case. Do not say the native NaturallySpeaking ”move to end of paragraph” command because the Title Case problem will return.

How To Prevent Extra Spacing From Occurring In Front of Punctuation
Version 7 and 7.2 of NaturallySpeaking frequently introduce an extra unwanted space before punctuation. Frequently when you make a correction NaturallySpeaking will also insert an extra space. The simplest solution is to ignore the problem until you finish dictating your entire document. Then say "Repair Punctuation" to eliminate the unwanted spacing.

Increasing HTML Elements in Internet Explorer
By default, Dragon processes only the first 200 HTML elements on a page. Links beyond the first 200 elements cannot be reached by voice, and text areas beyond the first 200 elements cannot be dictated into. This restriction exists to limit the amount of time that Dragon uses to process HTML elements, which it does every time the user begins speaking. You can increase this limit by editing the file options.ini, a user-specific file that resides by default in C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\Users\<username>\ current. You can make this the default option by editing nsdefaults.ini, which resides by default in C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12.

At the bottom of options.ini, add this line:

Number Of Enumerated Html Elements=n

where “n” is the maximim number of elements you are likely to present on one page.

For example: Number Of Enumerated Html Elements=500

Altering NaturallySpeaking's Number Formatting Scheme

Double-click on C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Data\Enx\numwords.dat in Ver. 7.3

To eliminate the automatic-(used in phone number formatting) simply change

30=NNN-NNNN
To
30=NNNNNNN
You can additionally make changes such as the following
30=N,NNN,NNN
which is commonly used by patent attorneys

How to Add an Optional Command to bring up Spell That

Open the ~ C:\Documents and Settings\All Users\Application Data\ScanSoft\NaturallySpeaking\Users\(Your User Name\)current\Options.ini in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username\)\Options.ini and add the following line
exn Correct That Command=Crap (or any phrase you prefer) just below [Options] on a separate line

Relocating Your User Files to a Thumb/Flash Drive

1. Use Windows Explorer/ File Explorer to locate the following address
   C:\ProgramData\Nuance\NaturallySpeaking1x\Users\(your username\) folder
2. Copy your (username) folder to Windows clipboard
3. Use Windows Explorer/ File Explorer to browse to your thumb/flash drive
4. Paste the contents of the clipboard onto your thumb drive
5. Say Manage Users ~ to open the Manage Users utility
6. Click the Browse button to Browse to your USB thumb drive address and select your (recently copied) user file
7. You can optionally point NaturallySpeaking to search for your thumb drive by editing the
   C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username\)\nsuser.ini file and changing address in the “User Base Directory”, “User File Location” and “UserMRU” which will tell NaturallySpeaking where to look for the user files.

Note: This procedure is preferable for computers with USB 3 ports
1. Simply change the default (underlined) **User Base Directory=C:\ProgramData\Nuance\NaturallySpeaking15\Users\(your username) folder** in Windows

Example #1: **User Base Directory=E:** could point to an external drive or thumb drive

**How to Turn on the Microphone of a Digital Recorder User File (not possible in Ver. 15)**

1. Open C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking1\Users\(Your User Name)\current\options.ini in Windows XP. The Windows Vista or Windows 7/8/10 address is ~ C:\ProgramData\Nuance\NaturallySpeaking1\Users\(your username)\current\Options.ini file
2. Locate **Dictation Source=8** and change the 8 to 2 so that it looks like this
3. **Dictation source=2**
4. Save and close the file
5. You will additionally need to run the Audio Setup Wizard by saying “Check Audio”

**Note:** In the event that you are unable to find the dictation source line, simply add it on a separate line. Also note that the previous hack doesn’t Dragon 15. In Ver. 15 try changing **Last Used Acoustics=8 1** to **Last Used Acoustics=2 1** (unverified)

**How to Prevent the Dictation Box from Disappearing (Win 2000/XP)**

1. Quit all Office programs.
2. Click **Start**, point to **Settings**, and then click **Control Panel**. **NOTE:** In Windows XP, click **Start** and then click **Control Panel**.
3. In Control Panel, double-click **Add/Remove Programs**. **NOTE:** In Windows XP, click **Add or Remove Programs**.
4. In the **Currently installed programs** list, click to select Microsoft **Office XP product**, where **Office XP product** is the name of the specific Office product being used. If you are using a standalone version of one of the Office programs, click to select the appropriate product in the list. Click **Change**.
5. In the **Maintenance Mode Options** dialog box, select **Add or Remove Features**, and then click **Next**. This displays the **Choose installation options for all Office applications and tools** dialog box.
6. Click the plus sign (+) next to **Office Shared Features** to expand it.
7. Click the icon next to **Alternative User Input**, and then select **Not Available**.
8. Click **Update**.

**NOTE:** If you have multiple Office XP products installed, for example, Office XP Professional and Publisher 2002, you must repeat the preceding steps for each installed product.
Why Don't HeardWord Scripts Work

HeardWord scripts are designed to refer to another macro. The general idea is to not have to create a command more than once. Unfortunately, since the release of version 6, HeardWord commands have not deployed properly. When using the HeardWord script, in a standard Advanced-Scripting macro, you can only HeardWord (refer to another command) that is standard boilerplate text, legacy.dvc command (many of which are in both the Command Browser and the Master General folder) or a natural language command. You cannot write an Advanced-Scripting HeardWord script to refer to another Advanced-Scripting command but you can create a legacy.dvc command by first pressing the "New Copy" button in the Command Browser, editing the copy command and then using the HeardWord script to refer to any other command. This is the only workaround we have been able to come up with.

USB Pod Fails to Work Properly with Port Replicators

Solution = Disabled "USB Enhanced Mode" in the Device Manager

Can’t Find the Serial Number (Install Key)

Option #1 (Ver 10-15 & DMPE4)

  Click About NaturallySpeaking or About Dragon if you are using Medical or 14 under the DragonBar Help menu and you should see the serial number appear near the top of splash screen. There serial # is in the following format xxxx-xxx-xxxx-xxxx-xx

Option #2

  2. Open C:\ProgramData\Nuance\NaturallySpeaking15\Ereg.ini in Windows Vista or Windows 7/8
  3. Your serial number will be listed as Ser_Num=Axxx-xxx-xxxx-xxxx-xx

What to do if the Acoustic Optimizer is Grayed out or if NaturallySpeaking Refuses to allow Windows to Exit (Tablet PCs) "0x5eddee78"

Option #1

  Turn the Roaming feature Off

Option #2

  1. Right-click on C:\Program Files\Nuance\NaturallySpeaking15\Program\natspeak.exe on Win 2000/XP
  2. Select Properties
  3. Left-click the Compatibility tab and put a checkmark in “Turn off advanced text services for this program”
Note: If you’re only experiencing this problem with Microsoft Word turn off the smart cursor option under Microsoft Word options.

Jumping Cursor

Option #1
The following steps will force Dragon NaturallySpeaking to use Natural Text rather than the default EditControl

2. Double Click ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking12\NSSystem.ini in Windows XP or in Windows Vista or Windows 7 C:\ProgramData\Nuance\NaturallySpeaking12\NSSystem.ini
3. Under the [Settings] section, add a new line and enter in the following string exactly as it appears:

   Edit Control If Probable=0
4. Save and close the file.
5. Launch Dragon NaturallySpeaking.

Option #2
Another possible culprit would be some another NaturallySpeaking incompatible program or utility like “1-Click” and Endnote. The easiest way to search for an incompatible program is the following:

1. Say “Start Task Manager” if you're using KnowBrainer or press {Ctrl+Shift+Esc}
2. Click the Processes tab
3. End Process each program until you locate the culprit

To prevent the malign program from relaunching when you reboot do the following:

1. Click the start button and select Run
2. Type “msconfig” (minus the quotes) and hit the OK button
3. Click the Startup tab in the System Configuration Utility and uncheck the culprit

Option #3
Click the Edit tab in Microsoft Words Tools/Options and remove the checkmark from “Use Smart Cursoring”

Option #4
Both MS Word and WordPerfect users may experience a Jumping Cursor problem when utilizing templates for specialized formatting created in previous versions of Word or WordPerfect. This problem shows up more commonly in WordPerfect. Each new version of WordPerfect requires you to re-create any existing templates (and in some cases documents) in order to work correctly with NaturallySpeaking.
Option #5
Try disabling all add-ins other than NaturallySpeaking. Disabling the dgnword.dll (NaturallySpeaking Select-&-Say add-in) will probably also be effective but you will lose Select-&-Say so DON'T recommend disabling this add-in.

In Microsoft Word XP & 2003
Click on Help/About Microsoft Word/Disabled Items/

In Microsoft Word 2007
- open, click on the Office button in the upper left-hand corner.
- Click on the Word Options button at the bottom right of the Microsoft Word 2007 options dialog.
- Select Add-Ins from the options on the left side of the Word Options

Jumping Cursor problem in Outlook
Click Outlook File followed by clicking Options. Click Add-ins, choose COM Addins (bottom of the page), click GO button and remove the checkmark from Skype Meeting Add-in for Microsoft Office. Note that searches should also be faster and Dragon commands should work better.

Disappearing Cursor in Microsoft Word

NaturallySpeaking has a nasty habit of losing cursor focus in Microsoft Word after using the Spell That Correction Box. This problem can be prevented by the following 2 options:

Option #1
If you're using KnowBrainer, you can temporarily prevent the problem by saying “Refresh Window” or pressing {Alt+Tab} twice. However, the problem may return during your next correction.

Option #2
To permanently eradicate the problem you need to turn off the Results Box via the following:

1. Say “View Options” if you're using KnowBrainer and if not, say “Show options”
2. Click the View tab
3. Select Never show under Auto-hide Delay

Reverse Caps Problem When Dictating Over A Network (Remote Dictation)
When dictating remotely over a network, like Citrix, you may experience reverse capitalization such as the following: tTHIS iS aN eXAMPLE. This may be prevented by a toggling off your Caps Lock and NumLock keys
Loss of IE 6 Command Capability

If NaturallySpeaking cannot click on hyperlinks or control buttons you may be suffering from a spyware problem. One excellent free anti-spyware utility is Ad-Aware at ~ http://www.majorgeeks.com/download506.html . We additionally recommend that you click your IE 6 Tools/Manage Add-ons and disable any unrecognizable or seemingly unnecessary add-ons.

How to Dictate Curly Quotes (Smart Quotes) Instead of Straight Quotes – Thanks to Graham Hendry

You can add the ANSI characters for left/right double quote to your Vocabulary (Smart Quotes in Microsoft Word, Internet Explorer, DragonPad and WordPerfect).
1. Say “Edit Vocabulary” or go to the DragonBar Vocabulary/Open Vocabulary Editor menu and with the cursor in the Written Form hold down the Alt key and on the NUMERIC KEYPAD type 0157(for Left double quote). Add a suitable phrase for the Spoken Form like “Left Quote”.
2. Click the Properties button and select “Keeps capitalization and has no following space”.
3. Repeat for Right double quote - Alt + 0158 and with Properties as “Keeps capitalization and has no preceding space”.
4. 0156 = Right Single Quote ‘

You can add any ANSII characters in this way - but not UNICODE characters. ANSII codes are shown when you go to the Windows Character Map (charmap.exe) and click on the appropriate character. You can also download various character charts from Microsoft at: http://office.microsoft.com/en-gb/assistance/HA011331361033.aspx

How to Dictate Superscripts 1, 2 & 3 – Thanks to Graham Hendry

You can add the ANSI characters for Superscripts to your Vocabulary via the following:
1. Say “Edit Vocabulary” or go to Words|View/Edit and with the cursor in the Written Form hold down the Alt key and on the NUMERIC KEYPAD type 0178 (for Superscript 2). Add a suitable phrase for the Spoken Form like “Superscript two”.
2. Click the Properties button and select “Keeps capitalization and has no following space”.
3. Repeat Step #1 & #2 for Superscript 1 (Alt key 0179) and Superscript 3 (Alt key 0185).

SAPIDLL.DLL Does Not Register Itself

Option #1
You can download a self installing version of this file from the ScanSoft web site at: http://ct.scansoft.com/customerfiles/kbasefiles/4280/spchapi.exe

Option #2
Delete the contents of the C:\Windows\speech folder and reinstall DNS
How to Create Your Own Training Text

1. Create or build your own training text from existing documentation. Carefully and accurately examine your enrolment text for errors. Use the following great instructions by Joel Gould: http://www.synapseadaptive.com/Joel/changingaenrollmentatext.htm
   You don't have to worry about paragraphs being too long - Dragon has learned to cope with that in the meantime.

2. You'll find the enroll0.bins in the C:\ProgramData\Nuance\NaturallySpeaking10\Data\Training\Enx folder. Please note that you will need to change your default Windows folder options to display hidden text before you will be able to display these files. (For a step-by-step, on this process, do a search for “hidden files” in this document)

3. After having followed Joel Gould's instructions, start enrolment assistant, choose your own enrolment text, and off you go.

4. Train Dragon to your document's writing style (Import as many of your Word doc's as possible into one single Word document using Word's Insert -> File (you can insert dozens of files at once this way!), save the collection as one large text-only file and use Dragons assistant to train on that text file. Works great.)

5. Save your user files and close NaturallySpeaking.

6. Put the following lines at the end of the C:\ProgramData\Nuance\NaturallySpeaking13\Users\(your username)\current\options.ini (not options.ini):

   DwTimeOutIncomplete=120
   DwTimeOutComplete=65
7. Start NaturallySpeaking.

Modifying the Default User File Location

2. Open C:\ProgramData\Nuance\NaturallySpeaking13\nsuser.ini

3. The file should look something like the following (note the bold entry):

NaturallySpeaking Doesn't Capitalize the First Word after A Period

1. Open the Vocabulary Editor by saying “show Vocabulary Editor”

2. Look for a “.” preceded with a red* as pictured below:

3. Click the Properties button and then change the Word Properties to Inserts basing in capitalized the following word “period” as pictured below:
4. Click the Ok button. You can optionally delete the unwanted red* period but NaturallySpeaking will just add it back into the software again in the future. This will prevent that undesirable event from occurring.

Can't See All Of The Training Text

1. Double-click **Display** in the Control Panel
2. Make sure that the Font size is set to Normal

Note: If you have changed any of the advanced font formatting settings, you will additionally need to change them back to their default settings.

Pdm.dll error

If Microsoft Visual Studio version 6.0 is installed on the computer, please install Microsoft Visual Studio Service Pack 3 or higher.

If you are not using Microsoft Visual Studio On Windows 2000 the problem file is probably located at C:\WINNT\System 32\Pdm.dll.

On Windows XP the file is probably located at C:\Windows\System32\Pdm.dll but may be located at C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG. Simply rename the Pdm.dll file to Pdm.old
“dd10edit” Error

This error is caused by a maligned program which is stealing too many resources. Symantec Norton Security is a known culprit.

Solution: When this problem occurs open the Task Manager to the Processes Tab. Click the Mem Usage bar twice so that it displays the programs that are using the most memory in descending order. End Task the program that is using the most memory and see if that frees up NaturallySpeaking. If this works you may want to consider uninstalling the rogue program.

Error 75

When verbalizing a KnowBrainer command you receive Error 75 it typically means that you didn’t not install KnowBrainer in the default Drive C directory. If your computer doesn’t have a Drive C, KnowBrainer will not work.

NaturallySpeaking Refuses to Properly Format Currency

Open NaturallySpeaking’s Tools/Options/Formatting and make sure there is a black check mark in Currency. If there is already a black check mark in Currency, click the Commands tab and move the Pause required before commands slider further to the right, as depicted below:

Options

Text-to-speech | Miscellaneous | Formatting | Data
Correction | Commands | View | Hot keys

Pause required before commands

Short (0.1 sec) | Long (1 sec)

Note that the mouse arrow depicts the default factory setting.

Philips Speech Mic Refuses to Turn on

1. Launch Task Manager
2. Click the Processes Tab
3. End Task “SMax4PNP.exe”
4. You can prevent this program from launching by removing the corresponding entry key from “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run” in your Windows registry

NaturallySpeaking Won’t launch because Speech.dll Version 4.0.4.2109 is out of Date

This happens most frequently on tablet computers and computers that haven’t been updated with the latest Microsoft patches.

1. Download spchapi.exe from the Nuance web site at:
2. Paste the newer version 4.04.2512 speech.dll into the C:\Windows\Speech\ folder
3. When prompted about overwriting the original file click OK

How to Prevent “cASE rEVERSAL” in Terminal Services

Toggle off both the NUM Lock & Caps Lock keys

Can’t Get Past the Audio Setup Wizard

Option #1.
Make sure you are using the correct sound system. There may be more than 1 choice. If you are using a microphone with a mute switch, make sure that the microphone is un-muted and that you have everything connected properly.

Option #2
Make sure you can see all of the control buttons as follows:

If you cannot see all the control buttons then your Windows display font size will need to be changed the default 96 dpi setting.

NaturallySpeaking Crashes When Attempting to Use Internet Explorer

This can be caused by Internet Explorer add-on utilities like the Google toolbar. You may need to uninstall these add-ons.

Adobe Acrobat 7 Crashes when DNS 8 is Open

We suspect that NaturallySpeaking is the catalyst by the then the culprit. Try disabling the Logitech mouse
CTSysVol.exe has encountered a problem and needs to close

This is Creative Labs (Sound Blaster) volume control. Disabling or preventing CTSysVol from launching should solve the problem.

NaturallySpeaking Slows to a Crawl in Long Documents

NaturallySpeaking can slow to a crawl in documents of 50 pages are more and/or documents that include a lot of formatting. The problem is caused by NaturallySpeaking attempting to Select-&-Say the entire document in programs like Microsoft Word and WordPerfect.

The solution is to either break your document up into smaller segments, i.e. chapters, or follow Microsoft’s suggestion about dealing with Master Documents at http://support.microsoft.com/kb/180152/en-us

WordPerfect Select-&-Say Correction Is Several Characters Off

Eliminate auto formatting functions such as “Ignore Left-Hand” and “Ignore Left Indentation”. You may additionally need to turn off spell and grammar checking.

Adobe Acrobat crashes when NaturallySpeaking is Running

Problem: Adobe Acrobat crashes when you attempt to click a menu item or resize the page.

Solution: Go to Acrobat's Edit/Preferences/Reading and set to read only the current page.

Enabling Select-&-Say in a Citrix Client Environment

If you intend to dictate from the Citrix client, you must run the Citrix Client Update before you run Dragon NaturallySpeaking for the first time.

For more information, see *The Dragon NaturallySpeaking IT Administrators Guide* on the NaturallySpeaking Tools menu.

Also take a look at the DNS9 Citrix Reference Guide

Transcribing Lectures
NaturallySpeaking is not capable of transcribing an instructor recorded in a conference situation. NaturallySpeaking is only capable of transcribing recordings made in close mic mode (within a few inches of the microphone) and only in situations where you have created a specific digital recorder user profile for that end-user (which typically takes about 45 minutes). Fortunately you have other options:

Option #1 (least efficient but most cost-effective)
You will minimally need NaturallySpeaking Preferred or higher for permit digital recorder transcription. You can use any recorder with an inexpensive conference microphone such as the CM 909. All you do is play back the recorded dictation for about 1.5 seconds and Echo Dictate everything you hear into NaturallySpeaking. It's much easier to do than you think. Although this option can be very effective, it is extremely time-consuming. Including corrections, a one hour lecture will probably take an additional 3 hours to transfer into text.

Option #2
Combine a professional recorder such as though Olympus DS-5000 or Philips 9600 digital recorder with the Sylencer SM100 Microphone. This will cut down your worktime by as much as 50% because you can record only the information that you require. NaturallySpeaking typically transcribes dictation at double speed and you can be doing something else while NaturallySpeaking converts your recording into dictation.

Option #3 (most efficient)
Combine a Sylencer microphone with a notebook computer. This process can be 50% faster than Option #2 which is 50% faster than Option #1. With this option you will basically be leaving out the middleman (digital recorder) and getting the job done while you’re in class however, there is one caveat: You won't have time to make corrections so you will need to utilize deferred correction and the Preferred version of NaturallySpeaking lacks this capability. DNS Professional permits deferred dictation because it allows you to record a wav file which is linked to your document so that you can play back the dictation, in your own voice, at a later date. Sometimes when NaturallySpeaking makes a mistake on a single word, it can significantly change the meaning of an entire passage and throw off your concentration.

Hanging Results Box (dictation hangs in Results Box)

Option #1:
You are using Ver. 9.0 and need to minimally upgrade to Ver. 9.1 via the Help update menu or better yet, upgrade to Ver. 9.5 via our DNS 9.5 Update Guide

Option #2:
4. Another utility, like a disk defragmenter has a higher priority than NaturallySpeaking and is preventing NaturallySpeaking's dictation from reaching the document.
   Solution: Click the Processes Tab of the Task Manager and End Task the problematic utility
5. You may be dictating into a text box that is only supported by JavaScript which will prevent the Vcmd.dll (Windows SAPI control) from passing the dictation to your document
   Solution: Use NaturallySpeaking Dictation Box utility
6. The original document that you were dictating into has lost focus

**Solution:** Mouse left-click back into the document

NaturallySpeaking is unable to find the USB soundcard

Some older versions of Windows XP that are updated to SP2 fail to update or install the WDMA_USB.INF file. Others have been unusual corporate IT builds. XP needs to see these files placed in the right locations and many of the errors we have encountered are a result of the files not being installed or SP2 placing them in backup folders and not reinstalling them.

A proper installation of WDMA_USB.INF will install the two following files. C:\WINDOWS\inf\WDMA_USB.inf and C:\WINDOWS\inf\WDMA_USB.pnf (this location is important)

USBAUDIO.SYS will be in C:\WINDOWS\system32\drivers\USBAUDIO.sys

If any of these files are missing, the OS will not be able to install the many USB soundcards.

If someone runs into this issue the WDMA_USB.INF can be found and installed from the XP installation disk (\386\WDMA_USB.INF). Extracting this file is possible via the Command Window using the following command: expand wdma_usb.inwdma_usb.inf

Internet Explorer 7 or Windows Explorer Freezes

1. Click NaturallySpeaking's Tools/Options/Miscellaneous Tab
2. Remove the check mark from Use Active Accessibility for menu and dialog control
3. Click OK

COM returned an unexpected error code: Details are E_FAIL or E_Unexpected

This error usually refers to a corrupted user file. See [Switching to Backup User Files](#) for a step-by-step solution.

*Note: If you are running Windows Vista or Windows 7 we additionally recommend turning off User Account Control. You will find a step-by-step on this procedure when you search for “Acquiring Senior Administration Rights”*

However, an E_Fail error can also occur when you close NaturallySpeaking and attempt to re-launch it. If you suspect this situation, Open the Task Manager to the Processes Tab, End Task natspeak.exe and re-launch NaturallySpeaking.

Data Collector Utility Closing with Errors
Problem: Error messages to the effect of “there was an internal system error which will prevent you from saving your user files etc…”

Solution: In Ver. 9.5 run the “check for updates” feature from the help menu to download the “Data Collector” patch. Note: As of 10/17/2007 the patch currently only works for Windows XP; not Windows Vista or Windows 7.

Commands are recognized by Dragon NaturallySpeaking but not executed

**Problem:**

When using certain commands such as "Go to Bottom" or "Beginning of Document", the command is recognized but is not executed in any application.

**Cause:**

This problem can occur on Microsoft Windows XP and Windows 2000 systems where Microsoft Windows Script 5.7 is not installed.

**Solution:**

**Download Microsoft Windows Script 5.7:**

2. Type "Microsoft Windows Script 5.7 " in the search field and click the "Go" button.
3. Click on the title of the Windows Script 5.7 download that corresponds to the correct Operating System.
4. Click the "Continue" button to start the download process of the Microsoft Windows Script 5.7 file.
5. Install the Microsoft Windows Script 5.7 after the download has completed.

**Where is the Dragon Log**

The Dragon log is located at `C:\ProgramData\Nuance\NaturallySpeaking13\logs\(Your Computer Name)\Dragon.log` which can be opened in notepad or any word processor.

In Windows XP the Dragon Log is located at `C:\Documents and Settings\<username>\Application Data\Nuance\NaturallySpeaking10\Dragon.log`

You can also open the Dragon Log but saying `open show dragon log`

**My archive size box is greyed out**

Problem: My archive size box is greyed out, but my data files keep growing. Periodically, I get a warning asking me if I want to increase the files, and I say yes.
Solution: The first time you answer “Yes” to this question NaturallySpeaking will automatically grey out the archive box because the developers didn't include an option for pre-setting the minutes. There is nothing wrong but you may occasionally be prompted to give DNS permission to raise the limit again. You can either say “Yes” to let NaturallySpeaking automatically raise the limit or you can choose to disable “Always preserve wave data” which will prevent NaturallySpeaking from saving your dra files. If you disable this option you will not be able to run the Acoustic and Language Model Optimizer.

DNS Medical 9.52 Update Patch (For DNS Medical 9 ONLY)

This update is only available through DNS updates and only to Medical Ver. 9 users. You can find the tech note at the following URL:

This update is ONLY available for download through the Nuance Update Service. The Nuance Update Service is an automatic update service included with Dragon NaturallySpeaking. To open the Nuance Update Service, do the following:

1. Click on "Help > Check for Updates".
2. When the Update Service opens, click "Show Updates" then click "Add" on any of the available Service Pack(s) as desired.
3. Click the "Next" button and then use the "Download" button to save the Service Pack(s) to the computer.
4. Once downloaded, double-click the Service Pack to install. Please be sure to close out of all open applications before installing the Service Pack.

This particular patch fixes the following:

The SDAPI error when launching an existing roaming profile (9.0/9.1) or creating a new roaming profile. This issue would occur when Dragon NaturallySpeaking copied the acoustic files from the roaming user to the local cache [files changed from mlstyle_large.sig to enu_med_large.sig and mlstyle_large.usr and enu_med_large.usr]. This issue will no longer occur. * After installing 9.5 Medical, Dragon NaturallySpeaking would not launch and an exception access violation would appear in the dragon.log. This issue was determined to be caused by the Micaudio.dll, which was added for Dictaphone PowerMic II support. This update resolves this launching issue and provides updated Dictaphone PowerMic II support. * The Stop/Play button on the PowerMic I and II will now start and stop playback. Before this update, it would only start playback and briefly pause when pressed again. * The REW and FF buttons on the PowerMic I and II have been updated to mimic the options on the DragonBar. Fast Forward (FF) word by word: focus moves to the end of the text by selecting the full word and then the next word, until the last word is reached. The word-focus moves faster than the speed that the audio has been dictated and the played audio will be heard at this higher speed. * When opening a French Medical roaming user, the following error would appear: "Echec de l'utilisateur itinerant". This would occur if the profile was being accessed from a secure server using SSL. This issue has been resolved. * After exporting commands to an existing file (.dat or .xml), it would freeze or hang for a few minutes. This issue no longer occurs. * After adding a large number of words, using the Voctool, the next button in "Train Added Words" will no longer be inactive. * When editing a document that contained formatting, such as $15 dollars, the DRA file would lose portions of the audio and sometimes become corrupt. This issue has been resolved and should not occur when creating new documents while savings the recorded speech. * When dictating into an application via a remote desktop session running Citrix, the following error will no longer occur: "Dictation is not supported for the Remote desktop session". * "Dictation is not supported for the Remote Desktop session" message appeared when working with SmoothRoaming (for example: when a user starting Dragon NaturallySpeaking as Published Application from Client PC1 and then reconnect from Client PC2). This issue
has been resolved. * After installing using the MSI command line and specifying roaming user options, the message appears: "Cannot create roaming user local directory [local cache]" when opening a new user. When trying to open existing user the following message appears: "Roaming user failure". The issue occurred if the MSI install is pointed to the local cache to a directory that did not exist. If the Local Cache folder was created from Administrative Settings, this message would not occur. If the Local Cache pointed to an existent folder, this message would not occur. This issue has been resolved. * When using the audio setup wizard to setup a new user or perform additional training, contractions were removed from the training texts to avoid causing issues completing the training. * When adding words from a list, the "Find known words with unknown capitalization" option is no longer available. This parameter was always ignored and capitalized words would appear in the list of new words. This option is only available if the Vocabulary Tool is analyzing documents and not words lists. * After upgrading from Windows XP to Windows Vista or Windows 7, the ACO Scheduler did not display tasks that contained multiple users. After installing this update, the tasks will appear in the ACO Scheduler. * The Command Browser will properly display the commands for Microsoft Office 2007. * When making corrections, with the Data Collection option enabled, the SDAPI errors no longer occur.

When Waking from Hibernation I receive the following error: CloseDSXWarning_UttsPurged

When you hibernate your computer, with a speech file loaded, you run the risk of corrupting your user profile. If you're going to hibernate your computer ALWAYS close your user profile. However, if you choose to Log Off, you can leave your profile loaded as long as you turn the microphone completely off.

RPC_E_DISCONNECTED

This error usually means that DNS initiated an ActiveX control which disabled the RPC server. This problem is usually related to a DNS ActiveX control, which may require a repair.

We recommend copying your user file to a safe location and depending on what version NaturallySpeaking you were using, running DPICleaner Remover which will remove every trace of every version of Dragon from your computer. We then recommend installing DNS.

How to Copy Command Names from the NaturallySpeaking or KnowBrainer Command Browsers

1. Download a shareware program called SnagIt
2. Under the Input menu click Auto Scroll
3. Under the Mode menu click Text Capture
4. Open either the KnowBrainer Command Browser or NaturallySpeaking Command Browser
5. Click the Red Capture button and place the cursor in the appropriate browser
6. You will see the text automatically appear within SnagIt after it finishes scrolling which could take quite a while if you're copying the KnowBrainer global commands.
7. Say Copy All, if you're using KnowBrainer, to copy the names to the clipboard and say Paste to paste the command list into any program/window/document of your choice.
How to Prevent the Wandering Results Box

1. Click NaturallySpeaking Tools/Options
2. Click the View Tab
3. Put a check mark in Anchor
4. Our preference is to change the Auto-hide delay to 1 second but this step isn't necessary
5. Click the Commands Tab
6. Put a checkmark in Require Click to select menus and controls

Putting a check mark in Require Click to select menus and controls not only prevents the Results Box from wandering but additionally eliminates accidentally clicking on unwanted controls and menu items. On the downside, you won’t be able to click on the File menu or click the OK button without saying Click File or Click OK but we think it's worth the slight inconvenience.

SDAPI Error When Opening User Files

When opening a user in Dragon NaturallySpeaking, the selected user may not open or you may receive an error, "SDAPI Error", "Signal Processing Error" or "The vocabulary you have chosen General - Large is incompatible or invalid" or "Internal Recognizer Error". This error usually points to a corrupted user profile. Restoring a good copy of the user's speech files will often resolve this issue. You will either have to switch to a backup user profile or create a new one. For additional information see "Switching to Backup User Files".

Sluggish Dictation in Remote Desktop Window

Instead of attempting to dictate directly into a remote desktop window say show Dictation Box.

Note: If you're planning on using the Dictation Box to dictate over a network you should additionally click the Settings button, on the Dictation Box, change the Paste function to Simulate keystrokes and add a check mark to Keep transferred text in clipboard when the Dictation Box is closed.

Single Hard Drive with Multiple Partitions

If you have a single hard drive with more than one partition NaturallySpeaking may not function properly. We recommend avoiding partitioning.

"Windows installer" stating "preparing to install" When DNS is Fully installed

This message is usually caused by Windows registry corruption and can be fixed by running a Repair of
NaturallySpeaking from the Add/Remove Programs applet in the Control Panel.

How to Prevent a NaturallySpeaking Command from Accidentally Deploying

If you're using DNS Preferred or higher, you can create a blank boilerplate text command and call it the same name as the command that is accidentally deploying.

Why Does DNS Pro Display “Restoring Speech Files” When I Switch Documents

The most likely reason for this problem is that you have opted to **Always** Save recorded dictation with document. Open NaturallySpeaking's Options to the Data tab and change **Always** to **Ask me** or **Never** under Save recorded dictation of document.

Error 1935

This error is most often caused by firewall utilities, anti-spyware programs and pop-up blockers. You should disable as many utilities and programs as possible before attempting to install Dragon.

Manual Activation (machine fingerprint)

When you are prompted to activate NaturallySpeaking you are offered 2 choices. Activate Automatically (our recommendation if you are connected to the Internet) or Activate Manually. If you choose to activate automatically, while connected to the Internet, within a few seconds you should receive a confirmation that your software's been activated. If you choose to activate manually, you'll be presented with an Enter Key box that will require you to click this hyperlink in the US: [http://Activation.ScanSoft.com/US](http://Activation.ScanSoft.com/US). You will then need to type in your original serial number and click the Generate Activation Key button. Nuance should automatically produce an activation key which you can copy and paste in the appropriate fields (which should appear automatically). After entering your activation number click the OK button to finish activating. If you need more detailed information you will find it at [http://support.nuance.com/productactivation/tour.asp](http://support.nuance.com/productactivation/tour.asp)

Acquiring Senior Administration Rights in Windows Vista

1. Open the Start/Control Panel
2. Click User Accounts and Family Safety
3. Click User Accounts
4. Click Turn User Account Control on or off
5. Remove check mark from use user account control (UAC)...
6. Click OK and Reboot
Acquiring Senior Administration Rights in Windows 7

9. Click the Start button (Windows logo)
10. Type UAC
11. Press Enter
12. Move the Slider all the way down to Never notify.

DNS Advanced Scripting Commands Do Not Work Reliably over a Virtual Private Network (VPN)

VB scripts that utilize SendKeys in the professional versions of NaturallySpeaking do not always transfer across a VPN. We recommend substituting NaturallySpeaking's native command technology which means substituting SendDragonKeys for SendKeys scripts.

Cursor Jumps to the Beginning of Outlook 2007 Messages with each new Utterance

This situation often presents itself when using Outlook 2007 with an earlier version of Microsoft Word. The solution is to install Word 2007 or rollback to an earlier version of Outlook.

How to Install DNS and on Multiple Languages

As long as both languages are exactly the same version and flavor of NaturallySpeaking; example German Pro 9.5 and Spanish Pro 9.5 simply install one over the other. NaturallySpeaking will treat the 2nd installation is an upgrade and install the appropriate language vocabularies and support.

"Can't Run in Elevated Mode" error when attempting to launch DNS

Problem:

When attempting to launch Dragon the following error message may appear:

"Dragon should not be run in elevated mode"

Cause:

This message occurs when using "User Account Control" in Microsoft Windows Vista or Windows 7/10 and "Run as Administrator" is selected for "natspeak.exe". "Run as Administrator" is not active by default, requiring the user to turn on this setting. This elevated privilege level is not needed to run Dragon NaturallySpeaking.

Solution:

To resolve this issue, please use the following steps to turn off the "Run as Administrator" setting:

1. Click the "Start" button.
Click "Computer".

Double-click the "Local Disk C:" drive.

Double-click the "Program Files (x86)" folder.

Double-click the "Nuance" folder.

Double-click the "NaturallySpeaking15" folder.

Double-click the "Program" folder.

Right-click "natspeak.exe".

Select "Properties".

Click the "Compatibility" tab.

Clear the check mark from "Run as Administrator".

Click "OK".

We additionally recommend turning off Windows Vista/7/8/10 User Account Control (UAC) unless you enjoy being constantly prompted by Windows when you want to do something as simple as deleting a shortcut on a secondary drive. To obtain full Windows senior administrative rights do the following:

1. Open the Control Panel
2. Click User Accounts and Family
3. Click User Accounts
4. Click Turn User Account Control on or off
5. Remove check mark from use user account control (UAC)...
6. Reboot if you are using Windows Vista or 7. Windows 8/10 does not require a reboot

Internet Explorer Links Occasionally Appear As Blank Graphics Squares

Problem: This may be caused by the corruption of the DNS Natural Web ActiveX DLL.

Solution: Delete the C:\Program Files\Nuance\NaturallySpeaking10\Program\web_ie.dll and perform a Repair of NaturallySpeaking.

DNS Will Run on a Mac Computer in Boot Camp but not Parallels or vice versa

DNS can only run from one operation system in a Mac. You cannot install in 2 separate Windows emulation programs because DNS will prompt you for a machine fingerprint when you boot from the opposite system. This is one of the reasons why Nuance doesn’t officially support running DNS on a Mac.

This Application Requires Administrative Rights to Overwrite Some of the OLE Files error

You may experience this error with NaturallySpeaking or KnowBrainer when installing. If you do experience this problem simply right-click on the installer.exe, on the CD, and select the Run as Administrator option.
Vista Soundcard Stops Working after running an Audio Check for another program like Live Messenger

Programs like Windows Live Messenger can take over the soundcard by changing the settings. You can prevent this from occurring by right-clicking on the speaker icon in the Taskbar, selecting Recording, clicking on the appropriate microphone, clicking properties, click the Advanced tab and removing the checkmark from Allow applications to take exclusive control of this device.

Installing DNS 9.5 on Vista 64-bit (not endorsed or recommended by Nuance or KnowBrainer)

Nuance not only recommends against installing NaturallySpeaking on Vista 64-bit operating systems but they go to great lengths to prevent you from doing so by modifying the Dragon NaturallySpeaking 9.MSI. Note that Nuance will not support 64-bit installations of DNS. However, you can modify the DNS installation to install on a Windows 64-bit OS but you do so at your own risk. If you still wish to install DNS 9.5 on Vista 64, See following step-by-step:

1. Copy the entire contents of both or all 3 (if you're using Medical) NaturallySpeaking installation CDs to a folder on your computer.
3. Download and install Orca (an open-source part of the Microsoft core platform SDK)
4. Open Dragon NaturallySpeaking 9.msi from the DNS installer folder
5. To the left under tables, scroll down and click on the “launch Conditions”. The error conditions will appear to the right.
6. Select the Condition “Not VersionNT64”
7. Right-Click and select “Cut Row(s)”
8. Save the edited "Dragon Naturally Speaking 9.msi"
9. Double-click install.exe to begin the installation

Additional notes:

After Install, Run the Voice recognition setup in the Control Panel. Make sure the “boosted” option on the volume setting of your microphone in the Sound Properties of Control Panel is off.

If a volume check fails in DNS using “Tools -- Accuracy Center -- Check your audio settings -- pick soundcard -- Start Volume Check”, adjust the microphone volume input manually in the voice recognition setup. Some soundcards may require you to do this every time DNS is run.

Sometimes you may get an error message saying DNS won't run in "elevated mode". This is because DNS won't run in Administrator mode.

Possible fixes include:

Use a non-administrator account.
Vista will run the program in elevated mode automatically when using an administrator account. Turn off User Account Control, via the control panel.
Under preferences for the program, uncheck the “Run as Administrator” button.

**How Do You Stop DNS From Processing a very long utterance A Long Utterance**

Left mouse click on the tiny square to the right of the microphone icon in the taskbar or the DNS program.

**Error: DgnUseDll failed with the error code -1...wav.dll /mobile.dll /dd10shrd.dll” during installation**

**Problem:**

When installing Dragon NaturallySpeaking the following error messages may appear:

"Error: DgnUseDll failed with the error code -1 when attempting to load C:\Windows\Temp\{DDD90B2-80F2-413A-8A8E38C5076A7DBA}wav.dll into memory."

"Error: DgnUseDll failed with the error code -1 when attempting to load C:\Windows\Temp\{DDD90B2-80F2-413A-8A8E38C5076A7DBA}mobile.dll into memory."

"Error: DgnUseDll failed with the error code -1 when attempting to load C:\Windows\Temp\{DDD90B2-80F2-413A-8A8E38C5076A7DBA}dd10shrd.dll into memory."

**Cause:**

This issue can occur if the system does not have the Microsoft Visual C++ 2005 Redistributable Package (x86) installed prior to the installation of Dragon NaturallySpeaking.

**Solution:**

Downloading and installing the Microsoft Visual C++ 2005 Redistributable Package (x86) will resolve this issue.

**Follow these steps to download and install:**

1. Close out of the current Dragon NaturallySpeaking installation.
3. Type or copy and paste the following phrase into the Search box at the top of the page: Microsoft Visual C++ 2005 Redistributable Package (x86)
4. Click Microsoft Visual C++ 2005 Redistributable Package (x86) from the list of returned search items.
5. Follow the instructions to download and install.
DNS Will Install - Error 1500 - Another Installation Is in Progress

Error 1500 typically means that another installation is in progress which is preventing DNS, or any other program, from installing. In both cases, rebooting may fix this problem but in some cases you may have to press {Ctrl+Alt+Esc} to open the Task Manager, click on the Processes tab and End Task Msiexec.exe

Outlook Crashes When NaturallySpeaking Is Running

This problem can occur when Microsoft Outlook is damaged. Fortunately the Microsoft developers put together a utility called Scanpst.exe which can give you a more detailed explanations and solutions to Microsoft Outlook problems and recovery issues.

Text Appears in Yellow Results Box but Doesn't Always Transfer to My Document

This problem can occur when using a substandard microphone / soundcard (like the one that came in the box of your software, running with too little RAM or a utility running in the background that is taking priority such as anti-virus software conducting a scan of your computer or an automated defragmentation utility to name a few.

Solutions:

- Rebooting your computer should work but it will probably only be a temporary solution.
- Identifying and closing the problematic utility is our 1st recommendation but that's not always easy.
- Forcing NaturallySpeaking run in a higher priority by right-clicking on natspeak.exe, under the Processes tab of the Task Manager, clicking Set priority to above normal may also eliminate the problem but this fix should only be used as a last resort as it can cause of the problems.

Where is the System.dvc Master Command File

C:\Documents and Settings\All Users\Application
Data\Nuance\NaturallySpeaking10\Data\enx\dvcu\general\system.dvc in Windows XP
C:\ProgramData\Nuance\NaturallySpeaking15\Data\enx\dvcu\general\system.dvc in Windows Vista or Windows 7/8/10

Spell That Correction Box Makes Corrections but leaves the existing text in Microsoft Word

Put the default checkmark back into Typing Replaces Selection in your Microsoft Word options.

Slow Dictation and Thunderbird
1. Double-click the ~ C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\Data\Enx\dvcu\general\ nsapps.ini in Windows XP and ~ C:\ProgramData\Nuance\NaturallySpeaking10\nsapps.ini file in Windows Vista or Windows 7

2. Search for [Thunderbird] (include the braces)

3. Just below the [Thunderbird] line you will find Key Delay=3 (on a separate line)

4. Change the 3 to a 1, save and close the file.

How to Raise NaturallySpeaking’s Default 200 HTML Elements on a Web Page

1. Open your personal user C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\Users\(Your User Name)\Current\Option.ini file " in Windows XP. The Windows Vista or Windows 7 address is ~ C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username)\Options.ini with NotePad or WordPad.

2. Type Number Of Enumerated Html Elements=500 on a separate line at the bottom of the Option.ini file

3. Save the file and re-launch DNS to increase the available Web links from 200 to 500. You can also increase the number beyond 500 but keep in mind that the higher the number is, the more you will tax your computer resources.

When Saying “Click Link” DNS Inserts Little Useless Graphics Instead of Numbers

Problem:
Numbered Links are replaced with useless graphics when you say Click Link

Solution:
Option #1
1. Click Internet Explorer Tools/Internet Options
2. Click Security Tab/Trusted Sites
3. Click the Sites button
4. Remove the checkmark from Require server verification if there is a checkmark
5. The Website you wish to display links in should automatically show up on the Add field. Click the Add button to add this to your trusted list.

   Note #1: You may have to re-launch Internet Explorer before the changes take effect.

   Note #2: You might consider changing your Internet Security settings by clicking Internet Explorer Tools/Internet Options/Security (Tab) Internet (icon) and setting the security at Medium-high (the default setting).

Option #2
Uninstall and Reinstall Internet Explorer updates and plug-ins

NaturallySpeaking Closes and Displays a Run Time Error When You Click the Microphone

This error usually refers to a corrupted user profile. You will either need to switch to your backup user file or
create a new one. For a step-by-step on switching to your backup user profile search for “switching” in this document.

Vanishing Text in Word 2007 during dictation and correcting

**Problem:**
Corrections and dictation disappear in Word 2007 until you press {Enter}

**Solution:**
Switch to Draft under the View menu.

**Available DNS Languages**
NaturallySpeaking is available in American English, Australian English, Asian English, Indian English, UK English, Dutch, French, German, Italian and Spanish.

The French, Italian, German and Spanish editions also support English. The Dutch edition supports English, French and German.

**Formatting Numbers** (contributed by Chuck Runquist)
It doesn't matter what version of DNS you are using. The formatting of numbers is controlled by Windows.
Dragon Medical 10 Insists on Substituting “disfunction” for “dysfunction”

Click the DNS Formatting menu and click Miscellaneous. You will see an option, near the bottom of the list, that says cap spell “disfluency” and related words with “dys”.

Server Busy Error

The Server Busy Error typically occurs when you attempt to manually change something in or connected to DNS when it is making a Remote Procedure Call (RPC). This can result in an error which is NaturallySpeaking’s way of telling you to wait until it finishes executing the ActiveX control. The holdup can occur when another process is making an RPC. Example: If you try to close KnowBrainer immediately after exiting NaturallySpeaking or while saving user files you will see this error. Some, less than stellar, noise cancellation microphones can produce this error when you leave DNS in Sleep Mode also. Completely turning off the microphone or purchasing a more noise cancelling microphone will help with this problem.

How to Eliminate the Extra Space at the Beginning of an Excel Cell

Problem:
DNS inserts an extra space at the beginning of a cell in Excel

Solution:
Click Format cells in Excel. Click Alignment Tab. Chose the option to the right of the alignment setting and change the number in the drop down list to 0.

Solution:
Either run the Acoustic Optimizer to increase your accuracy or remove the checkmark from Store corrections in archive. Note that if you remove the checkmark that you won’t receive the full benefit of the Acoustic Optimizer because your most recent data won’t be available.

DNS Crashes Every Few Minutes

Problem:
DNS abruptly closes after a few minutes. The Dragon log shows several RPC_Server unavailable errors. This problem often occurs because of file system corruption and happens most frequently on systems that haven’t seen regular (weekly) defragging (optimizing).

Solution:
1. Run CHKDSK
2. Defrag your hard drive once a week or or automate the procedure with a third-party utility such as Diskeeper.
3. Switch to a backup DNS user file or create a new user.
DNS Types Dysfunction as Disfunction and Dyspagia as Disphagia

1. Open the Dragon Medical 10 (only) formatting menu by saying show NaturallySpeaking formatting
2. Put a checkmark in Spell disfluency and related words with “dys”

Internet Explorer Doesn’t Display Proper Arrows and Icons

**Problem:**
Internet Explorer displays generic graphics instead of proper numbers, arrows etc…

**Solution:**
Click Internet Explorer Tools/Internet Options/Security tab. Then click trusted sites and click the Sites button. Note that you must be on the webpage that you wish to add to your trusted sites for this process to work. When you click on the Sites button, you will be presented with see the web address for the website. Click Add and close out of the dialog boxes.

How to Prevent the “You Have Reached the Maximum Amount of Speech Data”

1. Go to the following location – C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking 10\Users\<your user name>\current
2. Locate the file soptions.ini
3. You should see entries similar to the following:

[Server Overrides]
DwSpeechThreshold=50
ComputeSpeed=100
CreateNewWordsInCorrection=0
UseBackupDictInWords=0
WAVFileMax=40000
SaveWAVToDisk=1
DoDataCollection=0
PunctuationGuesserOn=0
DwTimeOutIncomplete=100
DwTimeOutComplete=225

Note the two entries in **bold**. If they exist, change them as follows:

WAVFileMax=0
SaveWAVToDisk=0

If the 2 entries do not exist; add them.

---

**Every Time I Launch NaturallySpeaking It am Prompted to Finish the Installation**

**Problem:**
Every time you launch NaturallySpeaking it prompts you to finish installing.

**Solution:**
This problem is usually caused by a registry error which often occurs with bloated registries. We recommend the following:

1. Move your `~` `C:\Documents and Settings\All Users\Application Data\Nuance\NaturallySpeaking10\Users\(your username)` in Windows XP and `~` `C:\ProgramData\Nuance\NaturallySpeaking10\Users\(your username)` in Windows Vista or Windows 7 to a temporary safe location such as your desktop.

2. Uninstall Preferred 9/10 so that you don't lose an activation in step #3.

3. Run [DNS9.5 Remover](#) (DNS Ver. 9) or [DNS10 Remover](#) (DNS Ver. 10) which will remove every trace of NaturallySpeaking from your computer and most importantly; the registry.


5. Move your user files back to their original location and launch NaturallySpeaking. Note that you will be prompted to run the Audio Setup Wizard and Activate this procedure should take care of the problem.

We additionally recommend **obtaining a registry cleaning utility to clean out your registry**.
NaturallySpeaking Crashes When Using Spell That correction
Remove the checkmark from Automatic playback on correction under the Corrections Tab of the DNS options.

DNS Ignores the Cap <next word> Vocabulary Command
You can create your own version of this command via the following:
1. Say edit vocabulary to open the Vocabulary Editor
2. Type the phrase title case into the Written Form and click the Add button
3. While the phrase title case is highlighted click the Properties button
4. Put a checkmark in Use alternate Written Form I
5. Delete any text that appears in the box
6. Click the Format button
7. Change Format the next word from with normal capitalization to capitalized
8. Click both OK buttons and close the Vocabulary Editor
You may optionally wish to add UPPERCASE and lowercase view the same procedure

NaturallySpeaking Will Not Allow Importing Personal Commands into an Older Version of DNS

Problem:
NaturallySpeaking will not allow me to import my Ver. 10.1 commands into Ver. 9.5

Solution:
Export your personal commands in .xml rather than the default .dat setting and import your commands as .xml when importing a newer version of NaturallySpeaking commands into an older version of NaturallySpeaking.

NaturallySpeaking 9.5 Does Not Permit Dictation in Microsoft Outlook Web Access
Only NaturallySpeaking 10 and 10.1 Permit Dictation in Microsoft Outlook Web Access

Olympus DSS Player Software Doesn't Work Well on a Mac Computer
Parallels is not particularly user-friendly we Olympus DSS Player Pro software on a Mac computer. We recommend VMware or Bootcamp.

NaturallySpeaking Won't Run in Lotus Notes
Run Lotus Notes in Basic Mode. You will lose some functionality but at least you'll be able to dictate.

Why Doesn't NaturallySpeaking Work in All Applications
The ability to dictate into any specific application is dependent upon the text Window you are dictating into. The reason why NaturallySpeaking works well with applications like Internet Explorer, Windows, DragonPad, WordPad and Notepad is because these applications conform to the Microsoft SAPI (Microsoft Speech Application Program Interface) Rich Text technical specifications. You may or may not be able to dictate into many applications with NaturallySpeaking or WSR, such as Mozilla Firefox, but you will not be able to utilize Select-&-Say unless the application fully conforms to SAPI specifications.
NaturallySpeaking Pastes the Contents of the Clipboard Twice

Turn off the Microsoft Word option to use the Insert key for paste function

Low System Resources

Although NaturallySpeaking isn't typically directly responsible for low system resources, it can further exacerbate the issue. If you find yourself experiencing this error, after rebooting, try the following steps:

1) To delete %temp% files:
   >> Click on "start" button
   >> Type "RUN" in the search program and files.
   >> Type "%temp%" in the run window and press OK.
   >> Highlight all by pressing "cntrl and A" together.
   >> Right click and delete it.

2) To delete prefetch files:
   >> Click on "start" button
   >> Type "RUN" in the search program and files.
   >> Type "Prefetch" in the run window and press OK.
   >> Highlight all by pressing "cntrl and A" together.
   >> Right click and delete it.

3) To delete Temp files:
   >> Click on "start" button
   >> Type "RUN" in the search program and files.
   >> Type "temp" in the run window and press OK.
   >> Highlight all by pressing "cntrl and A" together.
   >> Right click and delete it.

4) To do disk cleanup:
   >> Click on start and open "computer"
   >> Right click on the c drive.
   >> Go to properties.
   >> Click on disk clean up
   >> Put a check mark on all the items in the next window.
   >> Click on ok and yes to do disk cleanup.

5) To optimise system paging file:
   >> Click on start
   >> Right click on 'Computer'
   >> Select 'Properties'
   >> Make note of the GB value of your 'Installed Memory (RAM)' category under 'System'
   >> Click on 'Advanced system settings' on the left hand bar.
   >> Make sure the 'advanced' tab is selected.
>>Under 'Performance', select 'Settings.'
>>Select the 'Advanced' tab again.
>>Under the 'virtual memory' section, select 'Change.'
>>Uncheck 'automatically manage paging file size for all drives'
>>Choose the 'custom size' radio button.
>>Before entering a value, select the 'start' button

...e search bar, type 'calculator' and press enter (or go to All Programs > Accessories > Calculator)
>>Once your calculator is open, enter '1024' and multiply it by the GB value of your 'Installed Memory (RAM)' you made note of earlier.
Note: For example, if you had 3 gigabytes, it would be '1024 * 3 = 3072.
>>Now, multiply your new value (3072 in this case) by 1.5 to get your new paging file memory size (4608 in this case)
>>Return to 'custom size' and enter your new value in both the 'Initial Size' and 'Maximum Size' boxes.
>>click 'set'
>>Click 'apply'

How to Enable Full Text Control in Jarte

Here are the instructions from Bob Flora of Carolina Road Software:

- Close DNS.

- Find a file named C:\ProgramData\Nuance\NaturallySpeaking12\nsapps.ini in your DNS installation folder and edit it.

- Find section [.Global\Global Enable Class Names] in the file.

- Add the following line to the end of that section: RichEdit20=4

- Save the the change and close the file.

- In Jarte, go to Help > System Information > Edit Settings

- Find setting "Class Name" and change it to: Class Name=RichEdit20

- Restart both DNS and Jarte.

Philips SpeechMike Programmable Buttons Failed to Work

Click SpeechMike Support and look for a step-by-step on clicking the Reset device under the troubleshooting tab and see if the Dragon application is enabled.

Dictation Box = TextEdit in Dragon for Mac